aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-09-20 18:10:18 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-09-20 18:10:18 +0000
commit0d793aa06e15f65ec3de65da4280ed04b458438c (patch)
tree71b1d3b21ac6660b21b755df310213c40cf60c6a /audio
parentee7d5add74bdc8106dc17e2576791c6dbea34fdc (diff)
downloadports-0d793aa06e15f65ec3de65da4280ed04b458438c.tar.gz
ports-0d793aa06e15f65ec3de65da4280ed04b458438c.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/asterisk-flite/Makefile44
-rw-r--r--audio/asterisk-flite/distinfo3
-rw-r--r--audio/asterisk-flite/files/patch-Makefile58
-rw-r--r--audio/asterisk-flite/pkg-descr4
-rw-r--r--audio/asterisk-flite/pkg-plist2
6 files changed, 112 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index d13c84dc7ea4..4997996fb573 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -31,6 +31,7 @@
SUBDIR += ascd
SUBDIR += asmix
SUBDIR += asmixer
+ SUBDIR += asterisk-flite
SUBDIR += asunder
SUBDIR += atunes
SUBDIR += aubio
diff --git a/audio/asterisk-flite/Makefile b/audio/asterisk-flite/Makefile
new file mode 100644
index 000000000000..2c26d933b17a
--- /dev/null
+++ b/audio/asterisk-flite/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= asterisk-flite
+PORTVERSION= 2.3
+DISTVERSIONPREFIX= v
+CATEGORIES= audio
+
+MAINTAINER= madpilot@FreeBSD.org
+COMMENT= Flite dialplan application for Asterisk
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libflite.so:audio/flite
+
+USE_GITHUB= yes
+GH_ACCOUNT= zaf
+GH_PROJECT= Asterisk-Flite
+
+USES= compiler gmake localbase
+INSTALL_TARGET= install samples
+
+OPTIONS_SINGLE= ASTVER
+OPTIONS_SINGLE_ASTVER= ASTERISK11 ASTERISK13
+
+OPTIONS_DEFAULT= ASTERISK13
+
+ASTERISK11_DESC= Depend on Asterisk 11
+ASTERISK13_DESC= Depend on Asterisk 13
+
+ASTERISK11_BUILD_DEPENDS= asterisk:net/asterisk11
+ASTERISK11_RUN_DEPENDS= asterisk:net/asterisk11
+ASTERISK13_BUILD_DEPENDS= asterisk:net/asterisk13
+ASTERISK13_RUN_DEPENDS= asterisk:net/asterisk13
+
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == clang
+CFLAGS+= -fblocks
+.endif
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/asterisk/modules/app_flite.so
+
+.include <bsd.port.post.mk>
diff --git a/audio/asterisk-flite/distinfo b/audio/asterisk-flite/distinfo
new file mode 100644
index 000000000000..89dfc3365cc2
--- /dev/null
+++ b/audio/asterisk-flite/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1474382391
+SHA256 (zaf-Asterisk-Flite-v2.3_GH0.tar.gz) = 208a2dfd4c6345c99d6b15cd136fa938355b937fa5f9efe849fcf53106667e4c
+SIZE (zaf-Asterisk-Flite-v2.3_GH0.tar.gz) = 11977
diff --git a/audio/asterisk-flite/files/patch-Makefile b/audio/asterisk-flite/files/patch-Makefile
new file mode 100644
index 000000000000..81c463cad0fd
--- /dev/null
+++ b/audio/asterisk-flite/files/patch-Makefile
@@ -0,0 +1,58 @@
+--- Makefile.orig 2016-03-20 14:01:21 UTC
++++ Makefile
+@@ -7,30 +7,15 @@
+ # at the top of the source tree.
+
+ INSTALL=install
+-ASTLIBDIR:=$(shell awk '/moddir/{print $$3}' /etc/asterisk/asterisk.conf)
+-ifeq ($(strip $(ASTLIBDIR)),)
+- MODULES_DIR=$(INSTALL_PREFIX)/usr/lib/asterisk/modules
+-else
+- MODULES_DIR=$(INSTALL_PREFIX)$(ASTLIBDIR)
+-endif
+-ASTETCDIR=$(INSTALL_PREFIX)/etc/asterisk
++MODULES_DIR=$(PREFIX)/lib/asterisk/modules
++ASTETCDIR=$(PREFIX)/etc/asterisk
+ SAMPLENAME=flite.conf.sample
+-CONFNAME=$(basename $(SAMPLENAME))
+-
+-CC=gcc
+-OPTIMIZE=-O2
+-DEBUG=-g
++CONFNAME=$(SAMPLENAME)
+
+-LIBS+=-lflite_cmu_us_kal -lflite_cmu_us_kal16 -lflite_cmu_us_awb -lflite_cmu_us_rms -lflite_cmu_us_slt -lflite_usenglish -lflite_cmulex -lflite
++LIBS+=$(LDFLAGS) -lflite_cmu_us_kal -lflite_cmu_us_kal16 -lflite_cmu_us_awb -lflite_cmu_us_rms -lflite_cmu_us_slt -lflite_usenglish -lflite_cmulex -lflite
+ CFLAGS+=-pipe -fPIC -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -D_REENTRANT -D_GNU_SOURCE
+
+ all: _all
+- @echo " +--------- app_flite Build Complete --------+"
+- @echo " + app_flite has successfully been built, +"
+- @echo " + and can be installed by running: +"
+- @echo " + +"
+- @echo " + make install +"
+- @echo " +-------------------------------------------+"
+
+ _all: app_flite.so
+
+@@ -46,20 +31,7 @@ clean:
+ install: _all
+ $(INSTALL) -m 755 -d $(DESTDIR)$(MODULES_DIR)
+ $(INSTALL) -m 755 app_flite.so $(DESTDIR)$(MODULES_DIR)
+- @echo " +---- app_flite Installation Complete ------+"
+- @echo " + +"
+- @echo " + app_flite has successfully been installed.+"
+- @echo " + If you would like to install the sample +"
+- @echo " + configuration file run: +"
+- @echo " + +"
+- @echo " + make samples +"
+- @echo " +-------------------------------------------+"
+
+ samples:
+ @mkdir -p $(DESTDIR)$(ASTETCDIR)
+- @if [ -f $(DESTDIR)$(ASTETCDIR)/$(CONFNAME) ]; then \
+- echo "Backing up previous config file as $(CONFNAME).old";\
+- mv -f $(DESTDIR)$(ASTETCDIR)/$(CONFNAME) $(DESTDIR)$(ASTETCDIR)/$(CONFNAME).old ; \
+- fi ;
+ $(INSTALL) -m 644 $(SAMPLENAME) $(DESTDIR)$(ASTETCDIR)/$(CONFNAME)
+- @echo " ------- app_flite confing Installed ---------"
diff --git a/audio/asterisk-flite/pkg-descr b/audio/asterisk-flite/pkg-descr
new file mode 100644
index 000000000000..c12661cc8785
--- /dev/null
+++ b/audio/asterisk-flite/pkg-descr
@@ -0,0 +1,4 @@
+Flite For Asterisk provides the "Flite" dialplan application, which
+allows you to use the Flite TTS Engine with Asterisk.
+
+WWW: http://zaf.github.io/Asterisk-Flite/
diff --git a/audio/asterisk-flite/pkg-plist b/audio/asterisk-flite/pkg-plist
new file mode 100644
index 000000000000..c3f37a15e811
--- /dev/null
+++ b/audio/asterisk-flite/pkg-plist
@@ -0,0 +1,2 @@
+@sample etc/asterisk/flite.conf.sample
+lib/asterisk/modules/app_flite.so