aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-25 19:27:40 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-25 19:27:40 +0000
commit55325f9a6e2b487f8f9e2202bd6af214d9945688 (patch)
treebbf3c358b9691becdce0996150fbda6ff2c1d305 /audio
parentab59082c5351d52149f46bbe7eead7cc9aecec5c (diff)
downloadports-55325f9a6e2b487f8f9e2202bd6af214d9945688.tar.gz
ports-55325f9a6e2b487f8f9e2202bd6af214d9945688.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/musicpd/Makefile21
-rw-r--r--audio/musicpd/distinfo4
-rw-r--r--audio/musicpd/files/mpd.conf.sample45
-rw-r--r--audio/musicpd/files/patch-ogg_decode.c10
-rw-r--r--audio/musicpd/files/patch-src:flac_decode.c11
-rw-r--r--audio/musicpd/pkg-descr2
6 files changed, 47 insertions, 46 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 9eb018df46ab..70a66acb6b59 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= musicpd
-PORTVERSION= 0.10.0
-PORTREVISION= 1
+PORTVERSION= 0.10.2
CATEGORIES= audio ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -25,7 +24,9 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS= FLAC "Support for FLAC Audio" on \
VORBIS "Support for OGG Vorbis Audio" on \
WAV "Support for WAV Audio" on \
- ICONV "Support for international characters" on
+ AAC "Support for MP4/AAC Audio" off \
+ ICONV "Support for international characters" on \
+ IPV6 "Support for IPV6" on
.include <bsd.port.pre.mk>
@@ -37,6 +38,10 @@ USE_RC_SUBR= yes
RC_SUFX= .sh
.endif
+#.if ${OSVERSION} < 500000
+#EXTRA_PATCHES+= ${PATCHDIR}/src-mp4ff::mp4ff_int_types.h.patch
+#.endif
+
.ifdef(WITHOUT_FLAC)
CONFIGURE_ARGS+=--disable-flac
.else
@@ -55,12 +60,22 @@ CONFIGURE_ARGS+=--disable-audiofile
LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libaudiofile
.endif
+.ifdef(WITH_AAC)
+LIB_DEPENDS+= faad.0:${PORTSDIR}/audio/faad
+.else
+CONFIGURE_ARGS+=--disable-aac
+.endif
+
.ifdef(WITHOUT_ICONV)
CONFIGURE_ARGS+=--disable-iconv
.else
LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
.endif
+.ifdef(WITHOUT_IPV6)
+CONFIGURE_ARGS+=--disable-ipv6
+.endif
+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/audio/musicpd/distinfo b/audio/musicpd/distinfo
index 8d582582e5b7..8d20c0201d66 100644
--- a/audio/musicpd/distinfo
+++ b/audio/musicpd/distinfo
@@ -1,2 +1,2 @@
-MD5 (mpd-0.10.0.tar.gz) = bfb1b185fe603e81d7099422267d0ea6
-SIZE (mpd-0.10.0.tar.gz) = 783063
+MD5 (mpd-0.10.2.tar.gz) = a8d7f7299fb367e4110c3b6c8c8f6887
+SIZE (mpd-0.10.2.tar.gz) = 815198
diff --git a/audio/musicpd/files/mpd.conf.sample b/audio/musicpd/files/mpd.conf.sample
index 7a6e13dfaf52..e4902b777889 100644
--- a/audio/musicpd/files/mpd.conf.sample
+++ b/audio/musicpd/files/mpd.conf.sample
@@ -1,27 +1,34 @@
# required
-port "2100"
-music_directory "/mp3"
-playlist_directory "/mp3"
-log_file "/var/log/mpd.log"
-error_file "/var/log/mpd.error"
+port "2100"
+music_directory "/mp3"
+playlist_directory "/mp3"
+log_file "/var/log/mpd.log"
+error_file "/var/log/mpd.error"
# optional
-max_connections "5"
-connection_timeout "60"
-db_file "/mp3/.mpddb"
+max_connections "5"
+max_command_list_size "2048"
+max_output_buffer_size "2048"
+connection_timeout "60"
+db_file "/mp3/.mpddb"
+state_file "/mp3/.mpdstate"
+save_absolute_paths_in_playlists "no"
-# log_level can be "default", "secure", "verbose"
-log_level "default"
+max_playlist_length "4096"
+buffer_before_play "25%"
+bind_to_address "any"
-mixer_device "/dev/mixer"
-max_playlist_length "4096"
-buffer_before_play "25%"
-bind_to_address "any"
+mixer_type "oss"
+mixer_device "/dev/mixer"
-mixer_type "oss"
-mixer_device "/dev/mixer"
+ao_driver "oss"
+ao_driver_options "dsp=/dev/dsp"
+audio_write_size "1024"
-ao_driver "oss"
-ao_driver_options "dsp=/dev/dsp"
+#user "mp3"
-#user "mp3"
+# log_level can be "default", "secure", "verbose"
+log_level "default"
+#password "password@read,add,control,admin"
+#default_permissions "read,add,control,admin"
+#filesystem_charset "UTF-8"
diff --git a/audio/musicpd/files/patch-ogg_decode.c b/audio/musicpd/files/patch-ogg_decode.c
deleted file mode 100644
index 3dce899903b7..000000000000
--- a/audio/musicpd/files/patch-ogg_decode.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/ogg_decode.c.orig Tue Sep 30 13:46:36 2003
-+++ src/ogg_decode.c Tue Sep 30 13:46:55 2003
-@@ -28,6 +28,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <vorbis/vorbisfile.h>
-+#include <sys/time.h>
-
- int ogg_decode(Buffer * cb, AudioFormat * af, DecoderControl * dc)
- {
diff --git a/audio/musicpd/files/patch-src:flac_decode.c b/audio/musicpd/files/patch-src:flac_decode.c
deleted file mode 100644
index 1ca099cf7289..000000000000
--- a/audio/musicpd/files/patch-src:flac_decode.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/flac_decode.c Tue Mar 9 20:29:35 2004
-+++ src/flac_decode.c Tue Mar 9 20:29:59 2004
-@@ -188,7 +188,7 @@
- if(data->dc->seek) return 0;
-
- #ifdef WORDS_BIGENDIAN
-- pcm_changeBufferEndianness(chunk,CHUNK_SIZE,data->af->bits);
-+ pcm_changeBufferEndianness(data->chunk,CHUNK_SIZE,data->af->bits);
- #endif
- memcpy(data->cb->chunks+data->cb->end*CHUNK_SIZE,data->chunk,
- CHUNK_SIZE);
diff --git a/audio/musicpd/pkg-descr b/audio/musicpd/pkg-descr
index e63f7869507f..977e02d98237 100644
--- a/audio/musicpd/pkg-descr
+++ b/audio/musicpd/pkg-descr
@@ -1,5 +1,5 @@
Music Player Daemon (MPD) allows remote access for playing music
-(MP3's, Ogg's, and Flac's) and managing playlists.
+(MP3, MP4, Ogg, and Flac) and managing playlists.
The design focus is on integrating a computer into a stereo system
that provides control for music playback over a local network.