aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-01-15 21:56:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-01-15 21:56:45 +0000
commita4f04f0b77025742e517ee1b8eaac7abf1da5679 (patch)
tree639e6f5e664535ff4a0781efcd9b9b821664c997 /audio
parent1d3eedfd1407310c68c8e9f0ccb4dab5596fd760 (diff)
downloadports-a4f04f0b77025742e517ee1b8eaac7abf1da5679.tar.gz
ports-a4f04f0b77025742e517ee1b8eaac7abf1da5679.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/py-wavio/Makefile20
-rw-r--r--audio/py-wavio/distinfo3
-rw-r--r--audio/py-wavio/pkg-descr7
4 files changed, 31 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 051515b05319..abc070220b32 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -687,6 +687,7 @@
SUBDIR += py-speex
SUBDIR += py-tagpy
SUBDIR += py-vorbis
+ SUBDIR += py-wavio
SUBDIR += py-xmms2
SUBDIR += pytone
SUBDIR += qjackctl
diff --git a/audio/py-wavio/Makefile b/audio/py-wavio/Makefile
new file mode 100644
index 000000000000..b2e89cee05b8
--- /dev/null
+++ b/audio/py-wavio/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= wavio
+DISTVERSION= 0.0.3
+CATEGORIES= audio python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python module for reading and writing WAV files using numpy arrays
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/audio/py-wavio/distinfo b/audio/py-wavio/distinfo
new file mode 100644
index 000000000000..b2bb0730a556
--- /dev/null
+++ b/audio/py-wavio/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1516011069
+SHA256 (wavio-0.0.3.tar.gz) = 8db5413db700915bfd649ba912bc4ddbae632713f780fb7a19ce00ad995d85f7
+SIZE (wavio-0.0.3.tar.gz) = 7008
diff --git a/audio/py-wavio/pkg-descr b/audio/py-wavio/pkg-descr
new file mode 100644
index 000000000000..a1223233c2ab
--- /dev/null
+++ b/audio/py-wavio/pkg-descr
@@ -0,0 +1,7 @@
+wavio is a Python module that defines two functions:
+* wavio.read reads a WAV file and returns an object that holds the sampling
+ rate, sample width (in bytes), and a numpy array containing the data.
+* wavio.write writes a numpy array to a WAV file, optionally using a specified
+ sample width.
+
+WWW: https://github.com/WarrenWeckesser/wavio