aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-06-13 06:22:21 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-06-13 06:22:21 +0000
commiteecd79041123495098018a5b8d7e8d34152a87f6 (patch)
treeb77402e9c2d41b1ba43d4148cf6694f99c407712 /audio
parent78254ff1e5ba948c3239ab3557e1c2db3c22c567 (diff)
downloadports-eecd79041123495098018a5b8d7e8d34152a87f6.tar.gz
ports-eecd79041123495098018a5b8d7e8d34152a87f6.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/baresip/Makefile23
-rw-r--r--audio/baresip/Makefile.depends1
-rw-r--r--audio/baresip/distinfo5
-rw-r--r--audio/re/Makefile3
-rw-r--r--audio/re/distinfo5
-rw-r--r--audio/re/pkg-plist68
-rw-r--r--audio/rem/Makefile3
-rw-r--r--audio/rem/distinfo5
-rw-r--r--audio/rem/pkg-plist19
9 files changed, 69 insertions, 63 deletions
diff --git a/audio/baresip/Makefile b/audio/baresip/Makefile
index 1c2a11953a3b..b2e5bdeb7b47 100644
--- a/audio/baresip/Makefile
+++ b/audio/baresip/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= baresip
-PORTVERSION= 0.4.8
-PORTREVISION= 4
+PORTVERSION= 0.4.19
CATEGORIES= audio
MASTER_SITES= http://www.creytiv.com/pub/
@@ -12,8 +11,8 @@ COMMENT= Small SIP client
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/docs/COPYING
-BUILD_DEPENDS= re>=0.4.6:audio/re \
- rem>=0.4.4:audio/rem
+BUILD_DEPENDS= re>=0.4.14:audio/re \
+ rem>=0.4.7:audio/rem
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= gmake pkgconfig
@@ -23,10 +22,11 @@ MAKE_ARGS= MOD_AUTODETECT=""
PLIST_FILES= bin/baresip
PORTDATA= *
PORTDOCS= *
+PORTEXAMPLES= *
#OPTIONS_NOT_YET_WORKING= ALSA BV32 G722_1 PLC ISAC OPENGLES
-OPTIONS_DEFINE= CELT CONS DOCS FFMPEG G711 G722 G726 GSM GSTREAMER ILBC L16 \
- OPUS OSS PORTAUDIO SDL SNDFILE SPEEX SRTP STDIO UUID V4L V4L2 X11 \
+OPTIONS_DEFINE= CONS DOCS EXAMPLES FFMPEG G711 G722 G726 GSM GSTREAMER ILBC \
+ L16 OPUS OSS PORTAUDIO SDL SNDFILE SPEEX SRTP STDIO UUID V4L V4L2 X11 \
DTLS_SRTP AUBRIDGE VIDBRIDGE HTTPD DSHOW DIRECTFB ACCOUNT \
NATPMP SDL MIW SNAPSHOT SELFVIEW VUMETER AULOOP CONTACT \
MENU PRESENCE SYSLOG VIDLOOP
@@ -34,7 +34,6 @@ OPTIONS_DEFAULT=CONS G711 G722 G726 L16
AULOOP_DESC= Audio-loop test module
BV32_DESC= BroadVoice32 Wideband Audio codec
-CELT_DESC= Celt support [broken]
CONTACT_DESC= Contacts module
CONS_DESC= Console input driver
DTLS_SRTP_DESC= DTLS Secure RTP module [broken]
@@ -84,7 +83,7 @@ MAKE_ARGS+= USE_$s=yes
MAKE_ARGS+= HAVE_SPEEXDSP=yes
.endif
-.for o in CELT SRTP V4L DTLS_SRTP V4L2 X11
+.for o in SRTP V4L DTLS_SRTP V4L2 X11
. if ${PORT_OPTIONS:M$o}
BROKEN= OPTIONS marked as BROKEN have not been updated to the new Baresip API
. endif
@@ -106,8 +105,6 @@ post-patch:
${ECHO_CMD} ".PHONY: showmodules" >> ${WRKSRC}/Makefile
${ECHO_CMD} "showmodules:" >> ${WRKSRC}/Makefile
${ECHO_CMD} ' @${ECHO_CMD} $$(MODULES)' >> ${WRKSRC}/Makefile
- ${REINPLACE_CMD} 's,-lcelt[0-9]*,$$(pkg-config --libs celt),' \
- ${WRKSRC}/modules/celt/module.mk
${REINPLACE_CMD} 's,-lportaudio[0-9]*,-L${LOCALBASE}/lib -lportaudio,' \
${WRKSRC}/modules/portaudio/module.mk
@@ -124,7 +121,9 @@ post-install:
${STAGEDIR}${PREFIX}/lib/baresip/modules; \
${ECHO_CMD} lib/${PORTNAME}/modules/$$m.so >> ${TMPPLIST}; \
done
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/* ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+ ${MV} ${STAGEDIR}${DOCSDIR}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+ ${RMDIR} ${STAGEDIR}${DOCSDIR}/examples
.include <bsd.port.mk>
diff --git a/audio/baresip/Makefile.depends b/audio/baresip/Makefile.depends
index 39b20a99c45a..2dbc5bc24e01 100644
--- a/audio/baresip/Makefile.depends
+++ b/audio/baresip/Makefile.depends
@@ -2,7 +2,6 @@
ALSA_DEPEND= ${LOCALBASE}/include/alsa/asoundlib.h:audio/alsa-lib
BV32_DEPEND= # nonexistent
-CELT_DEPEND= ${LOCALBASE}/include/celt/celt.h:audio/celt
CONS_DEPEND= # unnecessary
DTLS_SRTP_DEPEND= # unnecessary
EVDEV_DEPEND=
diff --git a/audio/baresip/distinfo b/audio/baresip/distinfo
index bf6ad9d396c5..4370463cd41d 100644
--- a/audio/baresip/distinfo
+++ b/audio/baresip/distinfo
@@ -1,2 +1,3 @@
-SHA256 (baresip-0.4.8.tar.gz) = f13f63aa27bd565dcd08d5fd56cc5eae9043495b27513a7e488bd2935c2932f7
-SIZE (baresip-0.4.8.tar.gz) = 360486
+TIMESTAMP = 1465682412
+SHA256 (baresip-0.4.19.tar.gz) = bb8c62da225d7ee30ad371e6e0cd0f4bb663635e73b8c09cd43b054b981eb0d1
+SIZE (baresip-0.4.19.tar.gz) = 449660
diff --git a/audio/re/Makefile b/audio/re/Makefile
index c92630381b53..f7c8461aa92c 100644
--- a/audio/re/Makefile
+++ b/audio/re/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= re
-PORTVERSION= 0.4.6
-PORTREVISION= 1
+PORTVERSION= 0.4.16
CATEGORIES= audio devel
MASTER_SITES= http://www.creytiv.com/pub/
diff --git a/audio/re/distinfo b/audio/re/distinfo
index e6eac70d0a70..15f8ede0d6bd 100644
--- a/audio/re/distinfo
+++ b/audio/re/distinfo
@@ -1,2 +1,3 @@
-SHA256 (re-0.4.6.tar.gz) = 7e12582254f17fc3e24d0cbca9303117392501a024550f3ed08138decd0127ee
-SIZE (re-0.4.6.tar.gz) = 272017
+TIMESTAMP = 1465679980
+SHA256 (re-0.4.16.tar.gz) = bc36fcf37302bfdb964374f2842179f1521d78df79e42e74c4fd102e61fa4b29
+SIZE (re-0.4.16.tar.gz) = 308213
diff --git a/audio/re/pkg-plist b/audio/re/pkg-plist
index c6431fc4f0b3..4769ba8a6d13 100644
--- a/audio/re/pkg-plist
+++ b/audio/re/pkg-plist
@@ -1,45 +1,51 @@
-include/re/re_net.h
-include/re/re_list.h
-include/re/re_hash.h
-include/re/re_stun.h
-include/re/re_tls.h
-include/re/re_lock.h
+include/re/re.h
+include/re/re_aes.h
include/re/re_base64.h
include/re/re_bfcp.h
-include/re/re_sip.h
-include/re/re_dbg.h
-include/re/re_sys.h
-include/re/re_tmr.h
-include/re/re_types.h
-include/re/re_mbuf.h
-include/re/re_mem.h
-include/re/re_mqueue.h
+include/re/re_bitv.h
+include/re/re_conf.h
include/re/re_crc32.h
-include/re/re_main.h
-include/re/re_uri.h
-include/re/re_jbuf.h
-include/re/re_sipevent.h
-include/re/re_telev.h
+include/re/re_dbg.h
+include/re/re_dns.h
+include/re/re_fmt.h
+include/re/re_hash.h
+include/re/re_hmac.h
include/re/re_http.h
include/re/re_httpauth.h
-include/re/re_dns.h
include/re/re_ice.h
-include/re/re_sdp.h
-include/re/re.h
-include/re/re_conf.h
-include/re/re_rtp.h
+include/re/re_jbuf.h
+include/re/re_json.h
+include/re/re_list.h
+include/re/re_lock.h
+include/re/re_main.h
+include/re/re_mbuf.h
include/re/re_md5.h
-include/re/re_fmt.h
-include/re/re_turn.h
-include/re/re_sipreg.h
+include/re/re_mem.h
+include/re/re_mod.h
+include/re/re_mqueue.h
+include/re/re_msg.h
include/re/re_natbd.h
-include/re/re_bitv.h
+include/re/re_net.h
+include/re/re_odict.h
+include/re/re_rtp.h
include/re/re_sa.h
+include/re/re_sdp.h
include/re/re_sha.h
-include/re/re_mod.h
+include/re/re_sip.h
+include/re/re_sipevent.h
+include/re/re_sipreg.h
include/re/re_sipsess.h
-include/re/re_hmac.h
+include/re/re_srtp.h
+include/re/re_stun.h
+include/re/re_sys.h
include/re/re_tcp.h
+include/re/re_telev.h
+include/re/re_tls.h
+include/re/re_tmr.h
+include/re/re_turn.h
+include/re/re_types.h
include/re/re_udp.h
-lib/libre.so
+include/re/re_uri.h
+include/re/re_websock.h
lib/libre.a
+lib/libre.so
diff --git a/audio/rem/Makefile b/audio/rem/Makefile
index 1a5a1cff0479..2a4325f0fcdf 100644
--- a/audio/rem/Makefile
+++ b/audio/rem/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= rem
-PORTVERSION= 0.4.4
-PORTREVISION= 2
+PORTVERSION= 0.4.7
CATEGORIES= audio devel
MASTER_SITES= http://www.creytiv.com/pub/
diff --git a/audio/rem/distinfo b/audio/rem/distinfo
index 1b585d9649c0..4e48d474d1a2 100644
--- a/audio/rem/distinfo
+++ b/audio/rem/distinfo
@@ -1,2 +1,3 @@
-SHA256 (rem-0.4.4.tar.gz) = 2551dc0888846af59d6392b5dfbb7e845d3bc70b98b03ff93c4ccdbafe2d7d43
-SIZE (rem-0.4.4.tar.gz) = 34381
+TIMESTAMP = 1465679998
+SHA256 (rem-0.4.7.tar.gz) = 5d084f5ee17b839680ab6b978357c095c2a85d04bdf61fa03192019e3435954e
+SIZE (rem-0.4.7.tar.gz) = 36986
diff --git a/audio/rem/pkg-plist b/audio/rem/pkg-plist
index eb26aff6d16a..a02e7e628df2 100644
--- a/audio/rem/pkg-plist
+++ b/audio/rem/pkg-plist
@@ -1,17 +1,18 @@
+include/rem/rem.h
include/rem/rem_au.h
include/rem/rem_aubuf.h
+include/rem/rem_auconv.h
+include/rem/rem_audio.h
include/rem/rem_aufile.h
-include/rem/rem_g711.h
+include/rem/rem_aumix.h
+include/rem/rem_auresamp.h
+include/rem/rem_autone.h
include/rem/rem_dsp.h
-include/rem/rem_video.h
-include/rem/rem.h
include/rem/rem_fir.h
+include/rem/rem_g711.h
include/rem/rem_vid.h
-include/rem/rem_auresamp.h
-include/rem/rem_vidmix.h
-include/rem/rem_aumix.h
-include/rem/rem_audio.h
-include/rem/rem_autone.h
include/rem/rem_vidconv.h
-lib/librem.so
+include/rem/rem_video.h
+include/rem/rem_vidmix.h
lib/librem.a
+lib/librem.so