aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-05-30 20:43:12 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-05-30 20:43:12 +0000
commitd0981a015d74adcbb726d2219d26819d378ad685 (patch)
tree2fb15beb461038c1e387328259c4f7577afde2d9 /audio
parent2b62391dad6b67c294f2d3797b62c07250870ad5 (diff)
downloadports-d0981a015d74adcbb726d2219d26819d378ad685.tar.gz
ports-d0981a015d74adcbb726d2219d26819d378ad685.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/audacity/Makefile174
-rw-r--r--audio/audacity/distinfo4
-rw-r--r--audio/audacity/files/patch-Makefile.in15
-rw-r--r--audio/audacity/files/patch-cext.h12
-rw-r--r--audio/audacity/files/patch-gcc4111
-rw-r--r--audio/audacity/files/patch-lib-src__libnyquist__nyquist__nyqstk__include__FileRead.h10
-rw-r--r--audio/audacity/files/patch-libnyquist-Makefile.in36
-rw-r--r--audio/audacity/files/patch-libnyquist-switches.h11
-rw-r--r--audio/audacity/files/patch-libnyquist-term.c11
-rw-r--r--audio/audacity/files/patch-libresample-Makefile.in11
-rw-r--r--audio/audacity/files/patch-portaudio-pa_unix.c29
-rw-r--r--audio/audacity/files/patch-portaudio-pa_unix.h11
-rw-r--r--audio/audacity/files/patch-portaudio-pa_unix_oss.c11
-rw-r--r--audio/audacity/files/patch-portmixer-px_unix_oss.c11
-rw-r--r--audio/audacity/files/patch-src-effects-ToneGen.cpp11
-rw-r--r--audio/audacity/files/patch-xlisp.h18
-rw-r--r--audio/audacity/pkg-plist114
17 files changed, 306 insertions, 194 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 57c87d54d364..01444842df1d 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -5,31 +5,53 @@
# $FreeBSD$
PORTNAME= audacity
-PORTVERSION= 1.2.4b
-PORTREVISION= 9
+PORTVERSION= 2.0.0
CATEGORIES= audio
-MASTER_SITES= SF
-DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+MASTER_SITES= GOOGLE_CODE \
+ SF/${PORTNAME}/${PORTNAME}-unstable/${PORTVERSION}
+PKGNAMESUFFIX= -devel
+DISTNAME= ${PORTNAME}-minsrc-${PORTVERSION}
-MAINTAINER= craig@yekse.gank.org
+MAINTAINER= xxjack12xx@gmail.com
COMMENT= Audacity is a GUI editor for digital audio waveforms
-BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-CONFLICTS= audacity-devel-[0-9]*
+LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile
+
+CONFLICTS= audacity-[0-9]*
WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION}
+
+USE_AUTOTOOLS= aclocal autoconf
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GETTEXT= yes
-USE_WX= 2.6
-
+USE_BZIP2= yes
+USE_WX= 2.8
+WX_UNICODE= yes
+WX_COMPS= wx
+INSTALLS_ICONS= yes
+MAKE_JOBS_SAFE= yes
MAN1= audacity.1
MANCOMPRESSED= yes
-OPTIONS= ID3TAG "ID3 tag support" off \
- MAD "Mad MP3 audio decoder support" on \
- VORBIS "OGG/Vorbis audio support" on
+OPTIONS= FFMPEG "Use ffmpeg for import and export support" on \
+ FLAC "Use libFLAC for FLAC support" on \
+ ID3TAG "Use libid3tag for mp3 id3 tag support" on \
+ JACK "Use JACK audio server" on \
+ LADSPA "LADSPA plug-in support" on \
+ MAD "Use libmad for mp2/3 decoding support" on \
+ NYQUIST "Nyquist plug-in support" on \
+ PORTMIXER "Compile with PortMixer" on \
+ SAMPLERATE "Use libsamplerate for sample rate conversion" on \
+ SBSMS "Use libsbsms for pitch and tempo changing" on \
+ SOUNDTOUCH "Use libSoundTouch for pitch and tempo changing" on\
+ TAGLIB "Use TagLib for metadata support" on \
+ TWOLAME "Use libtwolame for MP2 export support" on \
+ VORBIS "Use libvorbis for Ogg Vorbis support" on \
+ VAMP "Use libvamp for Vamp plug-in support" on
.include <bsd.port.pre.mk>
@@ -37,33 +59,137 @@ OPTIONS= ID3TAG "ID3 tag support" off \
SSE_CFLAGS= -mno-sse -mno-sse2
.endif
-CFLAGS+= -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}
-CPPFLAGS+= -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}
+ACLOCAL_ARGS+= -I ${WRKSRC}/m4
+AUTOCONF_ARGS+= -I ${WRKSRC}/m4
+
+CONFIGURE_ARG+ =--destdir=/
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${WRKSRC}/lib-src/portsmf -I${WRKSRC}/lib-src/portaudio-v19/include -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}
+CXXFLAGS+= -I${WRKSRC}/lib-src/portsmf -I${WRKSRC}/lib-src/portaudio-v19/include -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}
+CFLAGS+= -I${WRKSRC}/lib-src/portsmf -I${WRKSRC}/lib-src/portaudio-v19/include -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}
+
+CONFIGURE_ENV+= WX_CONFIG="${WX_CONFIG}"
.if !defined(NOPORTDOCS)
MAKE_ENV= DOC=yes
.endif
-.if !defined(WITHOUT_MAD)
-CONFIGURE_ARGS+= --with-libmad=system
-LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
+CONFIGURE_ARGS+= --with-lib-preference="local system"
+CONFIGURE_ARGS+= --with-portaudio
+CONFIGURE_ARGS+= --enable-unicode
+
+.if defined(WITH_FFMPEG)
+RUN_DEPENDS+= ffmpeg:${PORTSDIR}/multimedia/ffmpeg
+CONFIGURE_ARGS+= --with-ffmpeg
.else
-CONFIGURE_ARGS+= --without-libmad
+CONFIGURE_ARGS+= --without-ffmpeg
.endif
-.if !defined(WITHOUT_VORBIS)
-CONFIGURE_ARGS+= --with-vorbis=system
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+.if defined(WITH_FLAC)
+LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
+CONFIGURE_ARGS+= --with-libflac
.else
-CONFIGURE_ARGS+= --without-vorbis
+CONFIGURE_ARGS+= --without-libflac
.endif
.if defined(WITH_ID3TAG)
-CONFIGURE_ARGS+= --with-id3tag=system
LIB_DEPENDS+= id3tag.0:${PORTSDIR}/audio/libid3tag
+CONFIGURE_ARGS+= --with-libid3tag
.else
-CONFIGURE_ARGS+= --without-id3tag
+CONFIGURE_ARGS+= --without-libid3tag
+.endif
+
+.if defined(WITH_JACK)
+LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
+CONFIGURE_ARGS+= --with-jack
+.else
+CONFIGURE_ARGS+= --without-jack
+.endif
+
+.if defined(WITH_LADSPA)
+RUN_DEPENDS+= listplugins:${PORTSDIR}/audio/ladspa
+CONFIGURE_ARGS+= --enable-ladspa
+.else
+CONFIGURE_ARGS+= --disable-ladspa
+.endif
+
+.if defined(WITH_MAD)
+LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
+CONFIGURE_ARGS+= --with-libmad
+.else
+CONFIGURE_ARGS+= --without-libmad
+.endif
+
+.if defined(WITH_NYQUIST)
+CONFIGURE_ARGS+= --enable-nyquist
+.else
+CONFIGURE_ARGS+= --disable-nyquist
+.endif
+
+.if defined(WITH_PORTMIXER)
+CONFIGURE_ARGS+= --with-portmixer
+.else
+CONFIGURE_ARGS+= --without-portmixer
+.endif
+
+.if defined(WITH_SAMPLERATE)
+LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
+CONFIGURE_ARGS+= --with-libsamplerate
+.else
+CONFIGURE_ARGS+= --without-libsamplerate
+.endif
+
+.if defined(WITH_SBSMS)
+CONFIGURE_ARGS+= --with-sbsms
+.else
+CONFIGURE_ARGS+= --without-sbsms
+.endif
+
+.if defined(WITH_SOUNDTOUCH)
+LIB_DEPENDS+= SoundTouch.0:${PORTSDIR}/audio/soundtouch
+CONFIGURE_ARGS+= --with-soundtouch
+.else
+CONFIGURE_ARGS+= --without-soundtouch
+.endif
+
+.if defined(WITH_TWOLAME)
+LIB_DEPENDS+= twolame.0:${PORTSDIR}/audio/twolame
+CONFIGURE_ARGS+= --with-libtwolame
+.else
+CONFIGURE_ARGS+= --without-libtwolame
+.endif
+
+.if defined(WITH_TAGLIB)
+LIB_DEPENDS+= tag.1:${PORTSDIR}/audio/taglib
+CONFIGURE_ARGS+= --with-taglib
+.else
+CONFIGURE_ARGS+= --without-taglib
+.endif
+
+.if defined(WITH_VAMP)
+CONFIGURE_ARGS+= --with-libvamp
+.else
+CONFIGURE_ARGS+= --without-libvamp
+.endif
+
+.if defined(WITH_VORBIS)
+LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+CONFIGURE_ARGS+= --with-libvorbis
+.else
+CONFIGURE_ARGS+= --without-libvorbis
+.endif
+
+post-patch:
+#audacity links to some dependencies if present, even if explicitly disabled.
+#these must be patched out for the case when they are installed but
+#option-disabled to avoid unrecorded dependencies.
+
+.if defined(WITHOUT_JACK)
+ @${REINPLACE_CMD} -e 's|PKG_CHECK_MODULES(JACK, jack, have_jack=yes, have_jack=no)|have_jack=no|' ${WRKSRC}/configure.in
+.endif
+
+.if defined(WITHOUT_SAMPLERATE)
+ @${REINPLACE_CMD} -e 's|libresample.a -lsamplerate $(LIBS)|libresample.a $(LIBS)|' ${WRKSRC}/lib-src/libresample/Makefile.in
.endif
.include <bsd.port.post.mk>
diff --git a/audio/audacity/distinfo b/audio/audacity/distinfo
index 05199e0a2154..b0344fa706e0 100644
--- a/audio/audacity/distinfo
+++ b/audio/audacity/distinfo
@@ -1,2 +1,2 @@
-SHA256 (audacity-src-1.2.4b.tar.gz) = 7c6f53ceffc10fbff96cc3fdf2a2b61072ed8b527d4f7313b3216390907de113
-SIZE (audacity-src-1.2.4b.tar.gz) = 4499894
+SHA256 (audacity-minsrc-2.0.0.tar.bz2) = d849288ca5f90764d497953e7d2744e269bfbb6f71840762c66419e4c68aeb6a
+SIZE (audacity-minsrc-2.0.0.tar.bz2) = 6625078
diff --git a/audio/audacity/files/patch-Makefile.in b/audio/audacity/files/patch-Makefile.in
index b60ff9e8b2c5..5d907cc28585 100644
--- a/audio/audacity/files/patch-Makefile.in
+++ b/audio/audacity/files/patch-Makefile.in
@@ -1,14 +1,15 @@
---- Makefile.in.orig Tue Nov 30 21:49:32 2004
-+++ Makefile.in Tue Nov 30 21:50:05 2004
-@@ -31,9 +31,11 @@
- $(INSTALL) -d $(DESTDIR)$(DATADIR)/$(AUDACITY_NAME)
- -test -f audacity-1.2-help.htb && $(INSTALL) -m 644 audacity-1.2-help.htb \
- $(DESTDIR)$(DATADIR)/$(AUDACITY_NAME)/audacity-1.2-help.htb
+--- Makefile.in 2008-06-25 09:55:22.000000000 -0300
++++ Makefile.in.new 2008-06-25 09:58:26.000000000 -0300
+@@ -31,11 +31,12 @@
+ $(INSTALL) -m 755 audacity $(DESTDIR)$(BINDIR)/$(AUDACITY_NAME)
+
+ # install docs
+ifeq ($(DOC),yes)
$(INSTALL) -d $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)
$(INSTALL) -m 644 README.txt $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)/README.txt
$(INSTALL) -m 644 LICENSE.txt $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)/LICENSE.txt
+-
+endif
-
# install manpage
$(INSTALL) -d $(DESTDIR)$(MANDIR)/man1
+ -test -f help/audacity.1.gz && \
diff --git a/audio/audacity/files/patch-cext.h b/audio/audacity/files/patch-cext.h
new file mode 100644
index 000000000000..5ca84120ced0
--- /dev/null
+++ b/audio/audacity/files/patch-cext.h
@@ -0,0 +1,12 @@
+--- lib-src/libnyquist/nyquist/cmt/cext.h 2009-07-15 20:27:36.000000000 -0700
++++ lib-src/libnyquist/nyquist/cmt/cext.h 2009-07-19 00:37:45.000000000 -0700
+
+@@ -58,7 +58,7 @@
+ #include <malloc.h>
+ #endif
+
+-#if NEED_ULONG
++#if NEED_ULONG || __FreeBSD__
+ typedef unsigned long ulong;
+ #endif
+
diff --git a/audio/audacity/files/patch-gcc41 b/audio/audacity/files/patch-gcc41
deleted file mode 100644
index ea482a83b6ad..000000000000
--- a/audio/audacity/files/patch-gcc41
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib-src/soundtouch/include/SoundTouch.h.orig Sun Nov 27 08:47:29 2005
-+++ lib-src/soundtouch/include/SoundTouch.h Sun Dec 17 22:52:47 2006
-@@ -146,7 +146,7 @@
- static const char *getVersionString();
-
- /// Get SoundTouch library version Id
-- static uint SoundTouch::getVersionId();
-+ static uint getVersionId();
-
- /// Sets new rate control value. Normal rate = 1.0, smaller values
- /// represent slower rate, larger faster rates.
diff --git a/audio/audacity/files/patch-lib-src__libnyquist__nyquist__nyqstk__include__FileRead.h b/audio/audacity/files/patch-lib-src__libnyquist__nyquist__nyqstk__include__FileRead.h
new file mode 100644
index 000000000000..0e3b2e97887c
--- /dev/null
+++ b/audio/audacity/files/patch-lib-src__libnyquist__nyquist__nyqstk__include__FileRead.h
@@ -0,0 +1,10 @@
+--- ./lib-src/libnyquist/nyquist/nyqstk/include/FileRead.h.orig 2011-05-04 17:18:48.000000000 +0200
++++ ./lib-src/libnyquist/nyquist/nyqstk/include/FileRead.h 2011-05-04 17:19:13.000000000 +0200
+@@ -33,6 +33,7 @@
+ #define STK_FILEREAD_H
+
+ #include "Stk.h"
++#include <stdio.h>
+
+ namespace Nyq
+ {
diff --git a/audio/audacity/files/patch-libnyquist-Makefile.in b/audio/audacity/files/patch-libnyquist-Makefile.in
deleted file mode 100644
index 2f57bbaf95bb..000000000000
--- a/audio/audacity/files/patch-libnyquist-Makefile.in
+++ /dev/null
@@ -1,36 +0,0 @@
---- lib-src/libnyquist/Makefile.in.orig Tue Dec 2 19:32:18 2003
-+++ lib-src/libnyquist/Makefile.in Tue Dec 2 19:32:42 2003
-@@ -465,13 +465,13 @@
- cc -c cmt/userio.c -o cmt/userio.o $(CFLAGS)
-
- misc/intgen: misc/intgen.c
-- cd misc; make intgen
-+ cd misc; $(MAKE) intgen
-
- misc/unpacker: misc/unpacker.c misc/convert.c
-- cd misc; make unpacker
-+ cd misc; $(MAKE) unpacker
-
- misc/packer: misc/packer.c misc/convert.c
-- cd misc; make packer
-+ cd misc; $(MAKE) packer
-
- nyqsrc/sndfnintptrs.h: $(NYQHDRS) snd/snd.h misc/intgen
- $(INTGEN) nyqsrc/sndfnint $(NYQHDRS)
-@@ -481,14 +481,14 @@
-
- clean:
- rm -f libnyquist.a
-- cd misc; make clean
-+ cd misc; $(MAKE) clean
- rm -f $(OBJECTS)
- # Note that these files are machine-generated:
- rm -f nyqsrc/sndfnintptrs.h nyqsrc/sndfnint.c nyqsrc/sndfnintdefs.h
- rm -f nyqsrc/seqfnintptrs.h nyqsrc/seqfnint.c nyqsrc/seqfnintdefs.h
-
- cleaner: clean
-- cd misc; make cleaner
-+ cd misc; $(MAKE) cleaner
- rm -f *.backup */*.backup
- rm -f *~ */*.*~
- rm -f *.save */*.save
diff --git a/audio/audacity/files/patch-libnyquist-switches.h b/audio/audacity/files/patch-libnyquist-switches.h
deleted file mode 100644
index 4cd74add2be3..000000000000
--- a/audio/audacity/files/patch-libnyquist-switches.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib-src/libnyquist/sys/switches.h.orig Tue Dec 2 19:14:40 2003
-+++ lib-src/libnyquist/sys/switches.h Tue Dec 2 19:16:20 2003
-@@ -39,7 +39,7 @@
- */
- #define nyquist_printf printf
-
--#if __APPLE__ && __GNUC__ /* Mac OS X */
-+#if (__FreeBSD__ || __APPLE__) && __GNUC__ /* Mac OS X */
- #define NEED_ULONG 1
- #else
- #include <sys/types.h>
diff --git a/audio/audacity/files/patch-libnyquist-term.c b/audio/audacity/files/patch-libnyquist-term.c
deleted file mode 100644
index 5e33f81c2f38..000000000000
--- a/audio/audacity/files/patch-libnyquist-term.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib-src/libnyquist/sys/term.c.orig Tue Dec 2 19:17:30 2003
-+++ lib-src/libnyquist/sys/term.c Tue Dec 2 19:17:51 2003
-@@ -40,7 +40,7 @@
- #else
-
- #include <termios.h>
--#ifndef __APPLE__
-+#if !defined(__APPLE__) && !defined(__FreeBSD__)
- #include <asm/ioctls.h>
- #endif
- #include <signal.h>
diff --git a/audio/audacity/files/patch-libresample-Makefile.in b/audio/audacity/files/patch-libresample-Makefile.in
deleted file mode 100644
index bcb4513bcd20..000000000000
--- a/audio/audacity/files/patch-libresample-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib-src/libresample/Makefile.in.orig Tue Dec 2 19:46:02 2003
-+++ lib-src/libresample/Makefile.in Tue Dec 2 19:46:25 2003
-@@ -6,7 +6,7 @@
- CC = @CC@
- CFLAGS = @CFLAGS@ -Wall
-
--LIBS = @LIBS@ -lm
-+LIBS = @LDFLAGS@ @LIBS@ -lm
-
- AR = @AR@
- RANLIB = @RANLIB@
diff --git a/audio/audacity/files/patch-portaudio-pa_unix.c b/audio/audacity/files/patch-portaudio-pa_unix.c
deleted file mode 100644
index ff3c8ca818fd..000000000000
--- a/audio/audacity/files/patch-portaudio-pa_unix.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- lib-src/portaudio/pa_unix_oss/pa_unix.c.orig Tue Nov 30 21:18:35 2004
-+++ lib-src/portaudio/pa_unix_oss/pa_unix.c Tue Nov 30 21:33:58 2004
-@@ -422,7 +422,7 @@
- maxPri = sched_get_priority_max(SCHEDULER_POLICY);
- if( schp.sched_priority > maxPri ) schp.sched_priority = maxPri;
-
-- if (sched_setscheduler(0, SCHEDULER_POLICY, &schp) != 0)
-+ if (pthread_setschedparam(pahsc->pahsc_WatchDogThread, SCHEDULER_POLICY, &schp) != 0)
- {
- ERR_RPT(("PaHost_WatchDogProc: cannot set watch dog priority!\n"));
- goto killAudio;
-@@ -465,7 +465,7 @@
- lowerAudio:
- {
- struct sched_param schat = { 0 };
-- if( sched_setscheduler(pahsc->pahsc_AudioThreadPID, SCHED_OTHER, &schat) != 0)
-+ if( pthread_setschedparam(pahsc->pahsc_AudioThread, SCHED_OTHER, &schat) != 0)
- {
- ERR_RPT(("PaHost_WatchDogProc: failed to lower audio priority. errno = %d\n", errno ));
- /* Fall through into killing audio thread. */
-@@ -585,7 +585,7 @@
- sched_get_priority_min(SCHEDULER_POLICY)) / 2;
- schp.sched_priority = pahsc->pahsc_AudioPriority;
-
-- if (sched_setscheduler(0, SCHEDULER_POLICY, &schp) != 0)
-+ if (pthread_setschedparam(pahsc->pahsc_AudioThread, SCHEDULER_POLICY, &schp) != 0)
- {
- DBUG(("PortAudio: only superuser can use real-time priority.\n"));
- }
diff --git a/audio/audacity/files/patch-portaudio-pa_unix.h b/audio/audacity/files/patch-portaudio-pa_unix.h
deleted file mode 100644
index e4a44ff9a1bf..000000000000
--- a/audio/audacity/files/patch-portaudio-pa_unix.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib-src/portaudio/pa_unix_oss/pa_unix.h.orig Tue Dec 2 19:56:56 2003
-+++ lib-src/portaudio/pa_unix_oss/pa_unix.h Tue Dec 2 19:58:33 2003
-@@ -82,7 +82,7 @@
- #define MAX_TIMEOUT_MSEC (1000)
-
- /************************************************* Definitions ********/
--#ifdef __linux__
-+#if defined(__linux__) || defined(__FreeBSD__)
- #define DEVICE_NAME_BASE "/dev/dsp"
- #else
- #define DEVICE_NAME_BASE "/dev/audio"
diff --git a/audio/audacity/files/patch-portaudio-pa_unix_oss.c b/audio/audacity/files/patch-portaudio-pa_unix_oss.c
deleted file mode 100644
index 43b2d587cca5..000000000000
--- a/audio/audacity/files/patch-portaudio-pa_unix_oss.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib-src/portaudio/pa_unix_oss/pa_unix_oss.c.orig Tue Dec 2 19:57:13 2003
-+++ lib-src/portaudio/pa_unix_oss/pa_unix_oss.c Tue Dec 2 19:57:47 2003
-@@ -42,6 +42,8 @@
-
- #ifdef __linux__
- #include <linux/soundcard.h>
-+#elif defined(__FreeBSD__)
-+#include <sys/soundcard.h>
- #else
- #include <machine/soundcard.h> /* JH20010905 */
- #endif
diff --git a/audio/audacity/files/patch-portmixer-px_unix_oss.c b/audio/audacity/files/patch-portmixer-px_unix_oss.c
deleted file mode 100644
index f55e651d1176..000000000000
--- a/audio/audacity/files/patch-portmixer-px_unix_oss.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib-src/portmixer/px_unix_oss/px_unix_oss.c.orig Tue Dec 2 20:06:55 2003
-+++ lib-src/portmixer/px_unix_oss/px_unix_oss.c Tue Dec 2 20:07:09 2003
-@@ -37,6 +37,8 @@
-
- #ifdef __linux__
- #include <linux/soundcard.h>
-+#elif defined(__FreeBSD__)
-+#include <sys/soundcard.h>
- #else
- #include <machine/soundcard.h> /* JH20010905 */
- #endif
diff --git a/audio/audacity/files/patch-src-effects-ToneGen.cpp b/audio/audacity/files/patch-src-effects-ToneGen.cpp
deleted file mode 100644
index 8e308f8d4d25..000000000000
--- a/audio/audacity/files/patch-src-effects-ToneGen.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- work/audacity-src-1.2.4b/src/effects/ToneGen.cpp.old Sat Feb 11 11:53:25 2006
-+++ src/effects/ToneGen.cpp Sat Feb 11 11:52:07 2006
-@@ -265,7 +265,7 @@
- item2->Add(item3, 0, wxALIGN_CENTRE | wxALL, 5);
-
- wxChoice *item4 = new wxChoice(parent, ID_WAVEFORM, wxDefaultPosition,
-- wxSize(80, -1), 0, NULL);
-+ wxSize(80, -1), 0, NULL, 0);
- item2->Add(item4, 0, wxALIGN_CENTRE | wxALL, 5);
-
- item0->Add(item2, 1, wxALIGN_CENTRE | wxALL, 5);
diff --git a/audio/audacity/files/patch-xlisp.h b/audio/audacity/files/patch-xlisp.h
new file mode 100644
index 000000000000..5ab42206bdfd
--- /dev/null
+++ b/audio/audacity/files/patch-xlisp.h
@@ -0,0 +1,18 @@
+--- lib-src/libnyquist/nyquist/xlisp/xlisp.h 2009-07-15 20:27:36.000000000 -0700
++++ lib-src/libnyquist/nyquist/xlisp/xlisp.h 2009-07-19 00:24:11.000000000 -0700
+@@ -152,6 +152,15 @@
+ #endif
+ #endif
+
++/* FreeBSD */
++#ifdef __FreeBSD__
++#if __BYTE_ORDER == __LITTLE_ENDIAN
++#define XL_LITTLE_ENDIAN
++#else
++#define XL_BIG_ENDIAN
++#endif
++#endif
++
+ /* Apple CC */
+ #ifdef __APPLE__
+ #define NNODES 2000
diff --git a/audio/audacity/pkg-plist b/audio/audacity/pkg-plist
index ea90c2f86020..4f415a457669 100644
--- a/audio/audacity/pkg-plist
+++ b/audio/audacity/pkg-plist
@@ -1,62 +1,160 @@
bin/audacity
+share/applications/audacity.desktop
+%%DATADIR%%/EQDefaultCurves.xml
%%DATADIR%%/nyquist/bug.lsp
%%DATADIR%%/nyquist/dspprims.lsp
+%%DATADIR%%/nyquist/envelopes.lsp
+%%DATADIR%%/nyquist/equalizer.lsp
%%DATADIR%%/nyquist/evalenv.lsp
+%%DATADIR%%/nyquist/fileio.lsp
%%DATADIR%%/nyquist/follow.lsp
%%DATADIR%%/nyquist/init.lsp
%%DATADIR%%/nyquist/misc.lsp
%%DATADIR%%/nyquist/nyinit.lsp
%%DATADIR%%/nyquist/nyqmisc.lsp
+%%DATADIR%%/nyquist/nyquist-plot.txt
%%DATADIR%%/nyquist/nyquist.lsp
%%DATADIR%%/nyquist/printrec.lsp
%%DATADIR%%/nyquist/profile.lsp
+%%DATADIR%%/nyquist/rawwaves/mand1.raw
+%%DATADIR%%/nyquist/rawwaves/mand10.raw
+%%DATADIR%%/nyquist/rawwaves/mand11.raw
+%%DATADIR%%/nyquist/rawwaves/mand12.raw
+%%DATADIR%%/nyquist/rawwaves/mand2.raw
+%%DATADIR%%/nyquist/rawwaves/mand3.raw
+%%DATADIR%%/nyquist/rawwaves/mand4.raw
+%%DATADIR%%/nyquist/rawwaves/mand5.raw
+%%DATADIR%%/nyquist/rawwaves/mand6.raw
+%%DATADIR%%/nyquist/rawwaves/mand7.raw
+%%DATADIR%%/nyquist/rawwaves/mand8.raw
+%%DATADIR%%/nyquist/rawwaves/mand9.raw
+%%DATADIR%%/nyquist/rawwaves/mandpluk.raw
+%%DATADIR%%/nyquist/rawwaves/marmstk1.raw
+%%DATADIR%%/nyquist/rawwaves/sinewave.raw
+%%DATADIR%%/nyquist/sal-parse.lsp
+%%DATADIR%%/nyquist/sal.lsp
%%DATADIR%%/nyquist/seq.lsp
%%DATADIR%%/nyquist/seqfnint.lsp
%%DATADIR%%/nyquist/seqmidi.lsp
%%DATADIR%%/nyquist/sndfnint.lsp
+%%DATADIR%%/nyquist/stk.lsp
%%DATADIR%%/nyquist/system.lsp
-%%DATADIR%%/nyquist/test.lsp
%%DATADIR%%/nyquist/xlinit.lsp
+%%DATADIR%%/nyquist/xm.lsp
%%DATADIR%%/plug-ins/SilenceMarker.ny
+%%DATADIR%%/plug-ins/SoundFinder.ny
+%%DATADIR%%/plug-ins/beat.ny
%%DATADIR%%/plug-ins/clicktrack.ny
+%%DATADIR%%/plug-ins/clipfix.ny
%%DATADIR%%/plug-ins/crossfadein.ny
%%DATADIR%%/plug-ins/crossfadeout.ny
%%DATADIR%%/plug-ins/delay.ny
+%%DATADIR%%/plug-ins/equalabel.ny
%%DATADIR%%/plug-ins/highpass.ny
%%DATADIR%%/plug-ins/lowpass.ny
+%%DATADIR%%/plug-ins/notch.ny
%%DATADIR%%/plug-ins/pluck.ny
+%%DATADIR%%/plug-ins/rissetdrum.ny
%%DATADIR%%/plug-ins/tremolo.ny
-%%DATADIR%%/audacity-1.2-help.htb
+%%DATADIR%%/plug-ins/vocalremover.ny
+%%DATADIR%%/plug-ins/vocoder.ny
+%%PORTDOCS%%/share/doc/audacity/LICENSE.txt
+%%PORTDOCS%%/share/doc/audacity/README.txt
+share/icons/hicolor/16x16/apps/audacity.png
+share/icons/hicolor/22x22/apps/audacity.png
+share/icons/hicolor/24x24/apps/audacity.png
+share/icons/hicolor/32x32/apps/audacity.png
+share/icons/hicolor/48x48/apps/audacity.png
+share/icons/hicolor/scalable/apps/audacity.svg
+share/licenses/audacity-devel-2.0.0/GPLv2
+share/licenses/audacity-devel-2.0.0/LICENSE
+share/licenses/audacity-devel-2.0.0/catalog.mk
+share/locale/af/LC_MESSAGES/audacity.mo
share/locale/ar/LC_MESSAGES/audacity.mo
+share/locale/be/LC_MESSAGES/audacity.mo
share/locale/bg/LC_MESSAGES/audacity.mo
+share/locale/bn/LC_MESSAGES/audacity.mo
+share/locale/bs/LC_MESSAGES/audacity.mo
share/locale/ca/LC_MESSAGES/audacity.mo
+share/locale/ca@valencia/LC_MESSAGES/audacity.mo
share/locale/cs/LC_MESSAGES/audacity.mo
+share/locale/cy/LC_MESSAGES/audacity.mo
share/locale/da/LC_MESSAGES/audacity.mo
share/locale/de/LC_MESSAGES/audacity.mo
share/locale/el/LC_MESSAGES/audacity.mo
share/locale/es/LC_MESSAGES/audacity.mo
share/locale/eu/LC_MESSAGES/audacity.mo
+share/locale/fa/LC_MESSAGES/audacity.mo
share/locale/fi/LC_MESSAGES/audacity.mo
share/locale/fr/LC_MESSAGES/audacity.mo
share/locale/ga/LC_MESSAGES/audacity.mo
+share/locale/gl/LC_MESSAGES/audacity.mo
+share/locale/he/LC_MESSAGES/audacity.mo
+share/locale/hi/LC_MESSAGES/audacity.mo
share/locale/hu/LC_MESSAGES/audacity.mo
+share/locale/id/LC_MESSAGES/audacity.mo
share/locale/it/LC_MESSAGES/audacity.mo
share/locale/ja/LC_MESSAGES/audacity.mo
+share/locale/ka/LC_MESSAGES/audacity.mo
+share/locale/km/LC_MESSAGES/audacity.mo
+share/locale/ko/LC_MESSAGES/audacity.mo
share/locale/lt/LC_MESSAGES/audacity.mo
share/locale/mk/LC_MESSAGES/audacity.mo
+share/locale/my/LC_MESSAGES/audacity.mo
share/locale/nb/LC_MESSAGES/audacity.mo
share/locale/nl/LC_MESSAGES/audacity.mo
+share/locale/oc/LC_MESSAGES/audacity.mo
share/locale/pl/LC_MESSAGES/audacity.mo
share/locale/pt/LC_MESSAGES/audacity.mo
+share/locale/pt_BR/LC_MESSAGES/audacity.mo
+share/locale/ro/LC_MESSAGES/audacity.mo
share/locale/ru/LC_MESSAGES/audacity.mo
+share/locale/sk/LC_MESSAGES/audacity.mo
share/locale/sl/LC_MESSAGES/audacity.mo
+share/locale/sr_RS/LC_MESSAGES/audacity.mo
share/locale/sv/LC_MESSAGES/audacity.mo
+share/locale/tg/LC_MESSAGES/audacity.mo
+share/locale/tr/LC_MESSAGES/audacity.mo
share/locale/uk/LC_MESSAGES/audacity.mo
+share/locale/vi/LC_MESSAGES/audacity.mo
share/locale/zh/LC_MESSAGES/audacity.mo
share/locale/zh_TW/LC_MESSAGES/audacity.mo
-@dirrm %%DATADIR%%/plug-ins
-@dirrm %%DATADIR%%/nyquist
-@dirrm %%DATADIR%%
-%%PORTDOCS%%%%DOCSDIR%%/README.txt
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+share/mime/packages/audacity.xml
+share/pixmaps/audacity.xpm
+share/pixmaps/audacity16.xpm
+share/pixmaps/audacity32.xpm
+share/pixmaps/gnome-mime-application-x-audacity-project.xpm
+@dirrmtry share/mime/packages
+@dirrmtry share/mime
+@dirrmtry share/locale/sr_RS/LC_MESSAGES
+@dirrmtry share/locale/sr_RS
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/my/LC_MESSAGES
+@dirrmtry share/locale/my
+@dirrmtry share/locale/km/LC_MESSAGES
+@dirrmtry share/locale/km
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
+@dirrmtry share/licenses/audacity-devel-2.0.0
+@dirrmtry share/licenses
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/24x24
+@dirrmtry share/icons/hicolor/22x22/apps
+@dirrmtry share/icons/hicolor/22x22
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry %%PORTDOCS%%/share/doc/audacity
+@dirrmtry %%DATADIR%%/plug-ins
+@dirrmtry %%DATADIR%%/nyquist/rawwaves
+@dirrmtry %%DATADIR%%/nyquist
+@dirrmtry %%DATADIR%%
+@dirrmtry share/applications