aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 19:15:04 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 19:15:04 +0000
commit42bb56055858959aeb9e33dd9e648efa62bf8494 (patch)
treea3ada31358a33e8a5c0b3ab904899c20bf1873d2 /audio
parent0d6407e522564c60fcec71fbaebd723b4a945991 (diff)
downloadports-42bb56055858959aeb9e33dd9e648efa62bf8494.tar.gz
ports-42bb56055858959aeb9e33dd9e648efa62bf8494.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/euphoria/Makefile1
-rw-r--r--audio/euphoria/files/patch-lib_playlist_item.rb19
2 files changed, 20 insertions, 0 deletions
diff --git a/audio/euphoria/Makefile b/audio/euphoria/Makefile
index 782fb3beab5b..eaf95df71578 100644
--- a/audio/euphoria/Makefile
+++ b/audio/euphoria/Makefile
@@ -7,6 +7,7 @@
PORTNAME= euphoria
PORTVERSION= 20062006
+PORTREVISON= 1
CATEGORIES= audio
MASTER_SITES= http://mbsd.msk.ru/dist/
DISTNAME= ${PORTNAME}-${PORTVERSION}
diff --git a/audio/euphoria/files/patch-lib_playlist_item.rb b/audio/euphoria/files/patch-lib_playlist_item.rb
new file mode 100644
index 000000000000..8ce8eaefc430
--- /dev/null
+++ b/audio/euphoria/files/patch-lib_playlist_item.rb
@@ -0,0 +1,19 @@
+--- lib/playlist_item.rb.orig Mon Jul 10 11:30:20 2006
++++ lib/playlist_item.rb Mon Jul 10 11:31:08 2006
+@@ -1,4 +1,4 @@
+-# $Id: playlist_item.rb,v 1.17 2005/12/14 20:02:14 tsauerbeck Exp $
++# $Id: playlist_item.rb,v 1.19 2006/07/08 12:25:31 tilman Exp $
+
+ class PlaylistItem
+ attr_reader :id, :edje, :position, :selected, :hilighted
+@@ -23,9 +23,7 @@
+ end
+
+ def method_missing(method)
+- tmp = @props[method]
+-
+- tmp || @props[:server][method] || "default"
++ @props[method] || "default"
+ end
+
+ def duration