aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-04-27 22:20:40 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-04-27 22:20:40 +0000
commit0fb98d3fa13d697a1089b9e09a0a452f960445d3 (patch)
treee71f9fcd59da914b149ddbbcd86943c36620b6fe /audio
parent656d046ab42bb491e68ad812a953a4f6417a93fe (diff)
downloadports-0fb98d3fa13d697a1089b9e09a0a452f960445d3.tar.gz
ports-0fb98d3fa13d697a1089b9e09a0a452f960445d3.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/playumidi/Makefile31
-rw-r--r--audio/playumidi/distinfo3
-rw-r--r--audio/playumidi/pkg-descr12
-rw-r--r--audio/playumidi/pkg-message21
5 files changed, 68 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 8426026c86a2..51eae54a8006 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -632,6 +632,7 @@
SUBDIR += play
SUBDIR += playgsf
SUBDIR += playmidi
+ SUBDIR += playumidi
SUBDIR += pm3umpdl
SUBDIR += pms
SUBDIR += pms-devel
diff --git a/audio/playumidi/Makefile b/audio/playumidi/Makefile
new file mode 100644
index 000000000000..f17ec838d83b
--- /dev/null
+++ b/audio/playumidi/Makefile
@@ -0,0 +1,31 @@
+# Created by: Koine Yuusuke(koinec) <koinec@yahoo.co.jp>
+# $FreeBSD$
+
+PORTNAME= playumidi
+PORTVERSION= 0.8.2
+CATEGORIES= audio
+MASTER_SITES= OSDN/playumidi/71406
+
+MAINTAINER= koinec@users.osdn.me
+COMMENT= Standard MIDI format 0/1 player for FreeBSD USB-MIDI(umidi) device
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PLIST_FILES= bin/playumidi man/man1/playumidi.1.gz
+
+OPTIONS_DEFINE= LIBICONV DEBUG
+OPTIONS_DEFAULT= LIBICONV
+
+LIBICONV_DESC= Enable encoing conversion support with libiconv
+
+DEBUG_MAKE_ARGS= -DWITH_DEBUG
+
+LIBICONV_LIB_DEPENDS= libiconv.so:converters/libiconv
+LIBICONV_MAKE_ARGS= -DWITH_ICONV
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/playumidi ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/playumidi.1.gz ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/audio/playumidi/distinfo b/audio/playumidi/distinfo
new file mode 100644
index 000000000000..6dfc28be96be
--- /dev/null
+++ b/audio/playumidi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1565487633
+SHA256 (playumidi-0.8.2.tar.gz) = d007844d85abc76faa0d4ec37fd2718a61755d586155ac1922a98f909161aa86
+SIZE (playumidi-0.8.2.tar.gz) = 21998
diff --git a/audio/playumidi/pkg-descr b/audio/playumidi/pkg-descr
new file mode 100644
index 000000000000..63022de63d50
--- /dev/null
+++ b/audio/playumidi/pkg-descr
@@ -0,0 +1,12 @@
+"playumidi" is the "SIMPLE" MIDI file player for USB MIDI device on FreeBSD.
+This software is able to direct control for FreeBSD-umidi device(/dev/umidi*.*)
+in the "uaudio" driver.
+Therefore, You don't need to use the "/dev/sequencer" device or the other
+software when listening the MIDI-file music.
+And, Support for auto-judge MIDI-file XG/GS/GM mode & auto add the
+Tone-Generator ReSet code when the ReSet code isn't exist in a MIDI-file.
+
+WWW: https://ja.osdn.net/projects/playumidi/
+
+- Koine Yuusuke (koinec)
+ koinec@users.osdn.me
diff --git a/audio/playumidi/pkg-message b/audio/playumidi/pkg-message
new file mode 100644
index 000000000000..600abd124108
--- /dev/null
+++ b/audio/playumidi/pkg-message
@@ -0,0 +1,21 @@
+playumidi directly opens, writes midi-event data,
+and closes the umidi* device files.
+So, it is necessary to grant the R/W privileges(666)
+to umidi* device file before use playumidi.
+
+Therefore, there is a need to grant permissions to R/W
+prior to use.
+An example of the setting method is shown below.
+
+ 1. Append to devfs.rules (in etc dir.) the following lines.
+ ------------------------------------------
+ [system=10]
+ add path 'umidi*' mode 0666 group wheel
+ ------------------------------------------
+
+ 2. Append to rc.conf (in etc dir.) the following three lines.
+ ------------------------------------------
+ devfs_enable="YES"
+ ------------------------------------------
+
+ 3. Reboot FreeBSD (shutdown -r now)