aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-11-26 19:30:21 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-11-26 19:30:21 +0000
commit4590e077a71dd79b5025126780cdfa552ff4fab5 (patch)
treeee30fa81652446bbf0f7a02727b919c4ffa4a52a /audio
parentf080d1bc6675ea72a9ab3c6334e95abb5c49a3ee (diff)
downloadports-4590e077a71dd79b5025126780cdfa552ff4fab5.tar.gz
ports-4590e077a71dd79b5025126780cdfa552ff4fab5.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/linux-f10-openal/Makefile27
-rw-r--r--audio/linux-f10-openal/distinfo.amd643
-rw-r--r--audio/linux-f10-openal/distinfo.i3863
-rw-r--r--audio/linux-f8-openal/Makefile27
-rw-r--r--audio/linux-f8-openal/distinfo.amd643
-rw-r--r--audio/linux-f8-openal/distinfo.i3863
-rw-r--r--audio/linux-openal/Makefile27
-rw-r--r--audio/linux-openal/distinfo.amd643
-rw-r--r--audio/linux-openal/distinfo.i3863
10 files changed, 100 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index e11ab3bea890..f535d7baad72 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -271,6 +271,7 @@
SUBDIR += linux-libogg
SUBDIR += linux-libvorbis
SUBDIR += linux-mbrola
+ SUBDIR += linux-openal
SUBDIR += linux-vsound
SUBDIR += listener
SUBDIR += liteamp
diff --git a/audio/linux-f10-openal/Makefile b/audio/linux-f10-openal/Makefile
new file mode 100644
index 000000000000..6f9eaabb70d2
--- /dev/null
+++ b/audio/linux-f10-openal/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: linux-openal
+# Date created: 25 Nov 2005
+# Whom: jylefort@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= openal
+DISTVERSION= 0.0-0.2.20040726
+CATEGORIES= audio linux
+MASTER_SITE_SUBDIR= ../extras/3/${LINUX_ARCH}/
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= A 3D positional spatialized sound library (Linux version)
+
+RUN_DEPENDS= ${LINUXBASE}/lib/libasound.so.2:${PORTSDIR}/audio/linux-alsa-lib \
+ ${LINUXBASE}/usr/lib/libartsc.so.0:${PORTSDIR}/audio/linux-arts \
+ ${LINUXBASE}/usr/lib/libglib-2.0.so.0:${PORTSDIR}/devel/linux-glib2 \
+ ${LINUXBASE}/usr/lib/libesd.so.0:${PORTSDIR}/audio/linux-esound \
+ ${LINUXBASE}/usr/lib/libaudiofile.so.0:${PORTSDIR}/audio/linux-libaudiofile \
+ ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
+ ${LINUXBASE}/usr/lib/libvorbis.so.0:${PORTSDIR}/audio/linux-libvorbis
+
+ONLY_FOR_ARCHS= i386 amd64
+INSTALLS_LINUX_SHLIB= yes
+
+.include "${.CURDIR}/../../audio/linux-openal/bsd.linux.mk"
diff --git a/audio/linux-f10-openal/distinfo.amd64 b/audio/linux-f10-openal/distinfo.amd64
new file mode 100644
index 000000000000..1f5fcf224396
--- /dev/null
+++ b/audio/linux-f10-openal/distinfo.amd64
@@ -0,0 +1,3 @@
+MD5 (openal-0.0-0.2.20040726.x86_64.rpm) = e4264926d9ed40caddbcc7f9b39e2c8d
+SHA256 (openal-0.0-0.2.20040726.x86_64.rpm) = 7aef7347bce98d8145156c77cc3864b7fcd18f5e53281ce8e169d4fb3072baf7
+SIZE (openal-0.0-0.2.20040726.x86_64.rpm) = 142119
diff --git a/audio/linux-f10-openal/distinfo.i386 b/audio/linux-f10-openal/distinfo.i386
new file mode 100644
index 000000000000..6dab65756c96
--- /dev/null
+++ b/audio/linux-f10-openal/distinfo.i386
@@ -0,0 +1,3 @@
+MD5 (openal-0.0-0.2.20040726.i386.rpm) = 90eb77535e33d7c35b86d48b4dbfaa5a
+SHA256 (openal-0.0-0.2.20040726.i386.rpm) = fc1899bc52728ec12ae3d45e3d29ccb5de5fc97cc6581cb49fee431650d24f5c
+SIZE (openal-0.0-0.2.20040726.i386.rpm) = 121188
diff --git a/audio/linux-f8-openal/Makefile b/audio/linux-f8-openal/Makefile
new file mode 100644
index 000000000000..6f9eaabb70d2
--- /dev/null
+++ b/audio/linux-f8-openal/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: linux-openal
+# Date created: 25 Nov 2005
+# Whom: jylefort@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= openal
+DISTVERSION= 0.0-0.2.20040726
+CATEGORIES= audio linux
+MASTER_SITE_SUBDIR= ../extras/3/${LINUX_ARCH}/
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= A 3D positional spatialized sound library (Linux version)
+
+RUN_DEPENDS= ${LINUXBASE}/lib/libasound.so.2:${PORTSDIR}/audio/linux-alsa-lib \
+ ${LINUXBASE}/usr/lib/libartsc.so.0:${PORTSDIR}/audio/linux-arts \
+ ${LINUXBASE}/usr/lib/libglib-2.0.so.0:${PORTSDIR}/devel/linux-glib2 \
+ ${LINUXBASE}/usr/lib/libesd.so.0:${PORTSDIR}/audio/linux-esound \
+ ${LINUXBASE}/usr/lib/libaudiofile.so.0:${PORTSDIR}/audio/linux-libaudiofile \
+ ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
+ ${LINUXBASE}/usr/lib/libvorbis.so.0:${PORTSDIR}/audio/linux-libvorbis
+
+ONLY_FOR_ARCHS= i386 amd64
+INSTALLS_LINUX_SHLIB= yes
+
+.include "${.CURDIR}/../../audio/linux-openal/bsd.linux.mk"
diff --git a/audio/linux-f8-openal/distinfo.amd64 b/audio/linux-f8-openal/distinfo.amd64
new file mode 100644
index 000000000000..1f5fcf224396
--- /dev/null
+++ b/audio/linux-f8-openal/distinfo.amd64
@@ -0,0 +1,3 @@
+MD5 (openal-0.0-0.2.20040726.x86_64.rpm) = e4264926d9ed40caddbcc7f9b39e2c8d
+SHA256 (openal-0.0-0.2.20040726.x86_64.rpm) = 7aef7347bce98d8145156c77cc3864b7fcd18f5e53281ce8e169d4fb3072baf7
+SIZE (openal-0.0-0.2.20040726.x86_64.rpm) = 142119
diff --git a/audio/linux-f8-openal/distinfo.i386 b/audio/linux-f8-openal/distinfo.i386
new file mode 100644
index 000000000000..6dab65756c96
--- /dev/null
+++ b/audio/linux-f8-openal/distinfo.i386
@@ -0,0 +1,3 @@
+MD5 (openal-0.0-0.2.20040726.i386.rpm) = 90eb77535e33d7c35b86d48b4dbfaa5a
+SHA256 (openal-0.0-0.2.20040726.i386.rpm) = fc1899bc52728ec12ae3d45e3d29ccb5de5fc97cc6581cb49fee431650d24f5c
+SIZE (openal-0.0-0.2.20040726.i386.rpm) = 121188
diff --git a/audio/linux-openal/Makefile b/audio/linux-openal/Makefile
new file mode 100644
index 000000000000..6f9eaabb70d2
--- /dev/null
+++ b/audio/linux-openal/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: linux-openal
+# Date created: 25 Nov 2005
+# Whom: jylefort@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= openal
+DISTVERSION= 0.0-0.2.20040726
+CATEGORIES= audio linux
+MASTER_SITE_SUBDIR= ../extras/3/${LINUX_ARCH}/
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= A 3D positional spatialized sound library (Linux version)
+
+RUN_DEPENDS= ${LINUXBASE}/lib/libasound.so.2:${PORTSDIR}/audio/linux-alsa-lib \
+ ${LINUXBASE}/usr/lib/libartsc.so.0:${PORTSDIR}/audio/linux-arts \
+ ${LINUXBASE}/usr/lib/libglib-2.0.so.0:${PORTSDIR}/devel/linux-glib2 \
+ ${LINUXBASE}/usr/lib/libesd.so.0:${PORTSDIR}/audio/linux-esound \
+ ${LINUXBASE}/usr/lib/libaudiofile.so.0:${PORTSDIR}/audio/linux-libaudiofile \
+ ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
+ ${LINUXBASE}/usr/lib/libvorbis.so.0:${PORTSDIR}/audio/linux-libvorbis
+
+ONLY_FOR_ARCHS= i386 amd64
+INSTALLS_LINUX_SHLIB= yes
+
+.include "${.CURDIR}/../../audio/linux-openal/bsd.linux.mk"
diff --git a/audio/linux-openal/distinfo.amd64 b/audio/linux-openal/distinfo.amd64
new file mode 100644
index 000000000000..1f5fcf224396
--- /dev/null
+++ b/audio/linux-openal/distinfo.amd64
@@ -0,0 +1,3 @@
+MD5 (openal-0.0-0.2.20040726.x86_64.rpm) = e4264926d9ed40caddbcc7f9b39e2c8d
+SHA256 (openal-0.0-0.2.20040726.x86_64.rpm) = 7aef7347bce98d8145156c77cc3864b7fcd18f5e53281ce8e169d4fb3072baf7
+SIZE (openal-0.0-0.2.20040726.x86_64.rpm) = 142119
diff --git a/audio/linux-openal/distinfo.i386 b/audio/linux-openal/distinfo.i386
new file mode 100644
index 000000000000..6dab65756c96
--- /dev/null
+++ b/audio/linux-openal/distinfo.i386
@@ -0,0 +1,3 @@
+MD5 (openal-0.0-0.2.20040726.i386.rpm) = 90eb77535e33d7c35b86d48b4dbfaa5a
+SHA256 (openal-0.0-0.2.20040726.i386.rpm) = fc1899bc52728ec12ae3d45e3d29ccb5de5fc97cc6581cb49fee431650d24f5c
+SIZE (openal-0.0-0.2.20040726.i386.rpm) = 121188