aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-09-06 21:10:50 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-09-06 21:10:50 +0000
commit5b545e24438890b69da5b8d33dc4e205688cbf33 (patch)
treefa7f43588b1ae9866009ecff3e30c1d6a57cccc8 /audio
parent2d9698d0345d0c95d4f23e7158d4c2d2305b6c4f (diff)
downloadports-5b545e24438890b69da5b8d33dc4e205688cbf33.tar.gz
ports-5b545e24438890b69da5b8d33dc4e205688cbf33.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile3
-rw-r--r--audio/gstreamer-plugins-amrnb/Makefile17
-rw-r--r--audio/gstreamer-plugins-amrwbdec/Makefile17
-rw-r--r--audio/gstreamer-plugins-twolame/Makefile17
4 files changed, 54 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 699e1d63bd18..f2dd901e81cb 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -266,6 +266,8 @@
SUBDIR += gsm
SUBDIR += gspeakers
SUBDIR += gstreamer-plugins-a52dec
+ SUBDIR += gstreamer-plugins-amrnb
+ SUBDIR += gstreamer-plugins-amrwbdec
SUBDIR += gstreamer-plugins-cdaudio
SUBDIR += gstreamer-plugins-cdparanoia
SUBDIR += gstreamer-plugins-esound
@@ -292,6 +294,7 @@
SUBDIR += gstreamer-plugins-spc
SUBDIR += gstreamer-plugins-speex
SUBDIR += gstreamer-plugins-taglib
+ SUBDIR += gstreamer-plugins-twolame
SUBDIR += gstreamer-plugins-vorbis
SUBDIR += gstreamer-plugins-wavpack
SUBDIR += gtick
diff --git a/audio/gstreamer-plugins-amrnb/Makefile b/audio/gstreamer-plugins-amrnb/Makefile
new file mode 100644
index 000000000000..ec38ffb38a37
--- /dev/null
+++ b/audio/gstreamer-plugins-amrnb/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: gstreamer-plugins-amrnb
+# Date created: 6 Sep 2010
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= audio
+
+COMMENT= Gstreamer OpenCore based Adaptive Multi-Rate Narrow-Band plugin
+
+GST_PLUGIN= amrnb
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/audio/gstreamer-plugins-amrwbdec/Makefile b/audio/gstreamer-plugins-amrwbdec/Makefile
new file mode 100644
index 000000000000..c2639ae54e36
--- /dev/null
+++ b/audio/gstreamer-plugins-amrwbdec/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: gstreamer-plugins-amrwbdec
+# Date created: 6 Sep 2010
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= audio
+
+COMMENT= Gstreamer OpenCore based Adaptive Multi-Rate Wide-Band Decoder plugin
+
+GST_PLUGIN= amrwbdec
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/audio/gstreamer-plugins-twolame/Makefile b/audio/gstreamer-plugins-twolame/Makefile
new file mode 100644
index 000000000000..b2315eb85e66
--- /dev/null
+++ b/audio/gstreamer-plugins-twolame/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: gstreamer-plugins-twolame
+# Date created: 6 Sep 2010
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= audio
+
+COMMENT= Gstreamer High-quality free MP2 encoder plugin
+
+GST_PLUGIN= twolame
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"