aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-10-16 12:11:24 +0000
committerWen Heping <wen@FreeBSD.org>2009-10-16 12:11:24 +0000
commit5c94b9e1eae808cd86f50dfd2eb4b6fffc26a69e (patch)
tree619ede1ce9045ce7d9d48fe580a2408278fa3cec /audio
parentc9f412fd8ac79fab60c707ee391f85445e101672 (diff)
downloadports-5c94b9e1eae808cd86f50dfd2eb4b6fffc26a69e.tar.gz
ports-5c94b9e1eae808cd86f50dfd2eb4b6fffc26a69e.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/audacity-devel/Makefile16
-rw-r--r--audio/audacity-devel/distinfo6
-rw-r--r--audio/audacity-devel/files/patch-Makefile.in2
-rw-r--r--audio/audacity-devel/files/patch-cext.h12
-rw-r--r--audio/audacity-devel/files/patch-xlisp.h19
-rw-r--r--audio/audacity-devel/pkg-plist20
6 files changed, 56 insertions, 19 deletions
diff --git a/audio/audacity-devel/Makefile b/audio/audacity-devel/Makefile
index 0d3f3b378634..1c7e8f99b5cb 100644
--- a/audio/audacity-devel/Makefile
+++ b/audio/audacity-devel/Makefile
@@ -5,17 +5,17 @@
# $FreeBSD$
PORTNAME= audacity
-PORTVERSION= 1.3.7
-PORTREVISION= 1
+PORTVERSION= 1.3.9
CATEGORIES= audio
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-unstable/${PORTVERSION}
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMESUFFIX= -devel
-DISTNAME= ${PORTNAME}-fullsrc-${PORTVERSION}
+DISTNAME= ${PORTNAME}-minsrc-${PORTVERSION}
MAINTAINER= xxjack12xx@gmail.com
COMMENT= Audacity is a GUI editor for digital audio waveforms
-BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
+BUILD_DEPENDS+= automake-1.10:${PORTSDIR}/devel/automake110
+BUILD_DEPENDS+= autoconf-2.62:${PORTSDIR}/devel/autoconf262
LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile
CONFLICTS= audacity-[0-9]*
@@ -28,6 +28,7 @@ USE_GCC= 4.2+
USE_GETTEXT= yes
USE_BZIP2= yes
USE_WX= 2.8
+MAKE_JOBS_SAFE= yes
WX_COMPS= wx
PORTDOCS= README.txt LICENSE.txt
@@ -38,6 +39,7 @@ OPTIONS= VORBIS "Use libvorbis for Ogg Vorbis support" on \
MAD "Use libmad for mp2/3 decoding support" on \
FLAC "Use libFLAC for FLAC support" on \
ID3TAG "Use libid3tag for mp3 id3 tag support" on \
+ SAMPLERATE "Use libresample for sample rate conversion" on \
SBSMS "Use libsbsms for pitch and tempo changing" on \
SOUNDTOUCH "Use libSoundTouch for pitch and tempo changing" on\
TWOLAME "Use libtwolame for MP2 export support" on \
@@ -78,6 +80,10 @@ CONFIGURE_ARGS+= --with-libflac
CONFIGURE_ARGS+= --with-libid3tag
.endif
+.if defined(WITH_SAMPLERATE)
+CONFIGURE_ARGS+= --with-libresample
+.endif
+
.if defined(WITH_SBSMS)
CONFIGURE_ARGS+= --with-sbsms
.endif
diff --git a/audio/audacity-devel/distinfo b/audio/audacity-devel/distinfo
index 3b6d7ca2a55a..6347a625bdb8 100644
--- a/audio/audacity-devel/distinfo
+++ b/audio/audacity-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (audacity-fullsrc-1.3.7.tar.bz2) = 29b5c2ad50f58dac01406ccc1f31d40e
-SHA256 (audacity-fullsrc-1.3.7.tar.bz2) = be4a7ae1906e321e94aee35d0a60c332f4920ecd0cdb54a279a519c60c835acd
-SIZE (audacity-fullsrc-1.3.7.tar.bz2) = 13671285
+MD5 (audacity-minsrc-1.3.9.tar.bz2) = 0f2bc8971c6e2c4d39457c28aea16b5c
+SHA256 (audacity-minsrc-1.3.9.tar.bz2) = f47afe8dcf38165d3550160eb7e94694119f5da563674060a93c5bc66e2fa012
+SIZE (audacity-minsrc-1.3.9.tar.bz2) = 6719955
diff --git a/audio/audacity-devel/files/patch-Makefile.in b/audio/audacity-devel/files/patch-Makefile.in
index bfc0e1e6465a..095ebee8bbb9 100644
--- a/audio/audacity-devel/files/patch-Makefile.in
+++ b/audio/audacity-devel/files/patch-Makefile.in
@@ -1,6 +1,6 @@
--- Makefile.in 2008-06-25 09:55:22.000000000 -0300
+++ Makefile.in.new 2008-06-25 09:58:26.000000000 -0300
-@@ -30,11 +30,12 @@
+@@ -31,11 +31,12 @@
$(INSTALL) -m 755 audacity $(DESTDIR)$(BINDIR)/$(AUDACITY_NAME)
# install docs
diff --git a/audio/audacity-devel/files/patch-cext.h b/audio/audacity-devel/files/patch-cext.h
new file mode 100644
index 000000000000..b6da23fd2120
--- /dev/null
+++ b/audio/audacity-devel/files/patch-cext.h
@@ -0,0 +1,12 @@
+--- lib-src/libnyquist/nyquist/cmt/cext.h 2009-07-15 20:27:36.000000000 -0700
++++ lib-src/libnyquist/nyquist/cmt/cext.hcext.h 2009-07-19 00:37:45.000000000 -0700
+
+@@ -58,7 +58,7 @@
+ #include <malloc.h>
+ #endif
+
+-#if NEED_ULONG
++#if NEED_ULONG || __FreeBSD__
+ typedef unsigned long ulong;
+ #endif
+
diff --git a/audio/audacity-devel/files/patch-xlisp.h b/audio/audacity-devel/files/patch-xlisp.h
new file mode 100644
index 000000000000..08478e98ad33
--- /dev/null
+++ b/audio/audacity-devel/files/patch-xlisp.h
@@ -0,0 +1,19 @@
+--- lib-src/libnyquist/nyquist/xlisp/xlisp.h 2009-07-15 20:27:36.000000000 -0700
++++ lib-src/libnyquist/nyquist/xlisp/xlisp.h 2009-07-19 00:24:11.000000000 -0700
+@@ -152,6 +152,15 @@
+ #endif
+ #endif
+
++/* FreeBSD */
++#ifdef __FreeBSD__
++#if __BYTE_ORDER == __LITTLE_ENDIAN
++#define XL_LITTLE_ENDIAN
++#else
++#define XL_BIG_ENDIAN
++#endif
++#endif
++
+ /* Apple CC */
+ #ifdef __APPLE__
+ #define NNODES 2000
+
diff --git a/audio/audacity-devel/pkg-plist b/audio/audacity-devel/pkg-plist
index 87f156155dc4..1de42bbd7644 100644
--- a/audio/audacity-devel/pkg-plist
+++ b/audio/audacity-devel/pkg-plist
@@ -3,7 +3,10 @@ share/applications/audacity.desktop
%%DATADIR%%/audacity.xpm
%%DATADIR%%/nyquist/bug.lsp
%%DATADIR%%/nyquist/dspprims.lsp
+%%DATADIR%%/nyquist/envelopes.lsp
+%%DATADIR%%/nyquist/equalizer.lsp
%%DATADIR%%/nyquist/evalenv.lsp
+%%DATADIR%%/nyquist/fileio.lsp
%%DATADIR%%/nyquist/follow.lsp
%%DATADIR%%/nyquist/init.lsp
%%DATADIR%%/nyquist/misc.lsp
@@ -12,15 +15,17 @@ share/applications/audacity.desktop
%%DATADIR%%/nyquist/nyquist.lsp
%%DATADIR%%/nyquist/printrec.lsp
%%DATADIR%%/nyquist/profile.lsp
+%%DATADIR%%/nyquist/sal-parse.lsp
+%%DATADIR%%/nyquist/sal.lsp
%%DATADIR%%/nyquist/seq.lsp
%%DATADIR%%/nyquist/seqfnint.lsp
%%DATADIR%%/nyquist/seqmidi.lsp
%%DATADIR%%/nyquist/sndfnint.lsp
+%%DATADIR%%/nyquist/stk.lsp
%%DATADIR%%/nyquist/system.lsp
-%%DATADIR%%/nyquist/test.lsp
%%DATADIR%%/nyquist/xlinit.lsp
+%%DATADIR%%/nyquist/xm.lsp
%%DATADIR%%/plug-ins/SilenceMarker.ny
-%%DATADIR%%/plug-ins/analyze.ny
%%DATADIR%%/plug-ins/beat.ny
%%DATADIR%%/plug-ins/clicktrack.ny
%%DATADIR%%/plug-ins/clipfix.ny
@@ -68,6 +73,7 @@ share/locale/nb/LC_MESSAGES/audacity.mo
share/locale/nl/LC_MESSAGES/audacity.mo
share/locale/oc/LC_MESSAGES/audacity.mo
share/locale/pl/LC_MESSAGES/audacity.mo
+share/locale/pt/LC_MESSAGES/audacity.mo
share/locale/pt_BR/LC_MESSAGES/audacity.mo
share/locale/ro/LC_MESSAGES/audacity.mo
share/locale/ru/LC_MESSAGES/audacity.mo
@@ -81,14 +87,8 @@ share/locale/vi/LC_MESSAGES/audacity.mo
share/locale/zh/LC_MESSAGES/audacity.mo
share/locale/zh_TW/LC_MESSAGES/audacity.mo
share/mime/packages/audacity.xml
-@dirrm share/mime/packages
-@dirrm share/mime
-@dirrm share/locale/oc/LC_MESSAGES
-@dirrm share/locale/oc
-@dirrm share/locale/km/LC_MESSAGES
-@dirrm share/locale/km
-@dirrm share/locale/ca@valencia/LC_MESSAGES
-@dirrm share/locale/ca@valencia
+@dirrmtry share/locale/km/LC_MESSAGES
+@dirrmtry share/locale/km
@dirrm share/audacity/plug-ins
@dirrm share/audacity/nyquist
@dirrm share/audacity