aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2009-02-02 09:31:47 +0000
committerBeech Rintoul <beech@FreeBSD.org>2009-02-02 09:31:47 +0000
commit7c1c80dc0cd7a47175a6d6d62a0bcb5ab41962ae (patch)
tree21021497e63ef210e6cd60c4bdbf13925fcf83ca /audio
parentbac811844f175d8ad676bfcc3c0893e8f16096d8 (diff)
downloadports-7c1c80dc0cd7a47175a6d6d62a0bcb5ab41962ae.tar.gz
ports-7c1c80dc0cd7a47175a6d6d62a0bcb5ab41962ae.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/openal-soft/Makefile24
-rw-r--r--audio/openal-soft/distinfo3
-rw-r--r--audio/openal-soft/files/patch-CMakeLists.txt11
-rw-r--r--audio/openal-soft/pkg-descr10
-rw-r--r--audio/openal-soft/pkg-plist9
6 files changed, 58 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 3419d0a3b97d..b2a4c08d97f2 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -478,6 +478,7 @@
SUBDIR += ogg2mp3
SUBDIR += oggsplit
SUBDIR += openal
+ SUBDIR += openal-soft
SUBDIR += openspc
SUBDIR += opmixer
SUBDIR += optimfrog
diff --git a/audio/openal-soft/Makefile b/audio/openal-soft/Makefile
new file mode 100644
index 000000000000..79134a8cdd50
--- /dev/null
+++ b/audio/openal-soft/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: openal-soft
+# Date created: 2009-02-01
+# Whom: Marcus von Appen <mva@sysfault.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openal-soft
+PORTVERSION= 1.6.372
+CATEGORIES= audio
+MASTER_SITES= http://kcat.strangesoft.net/openal-releases/
+
+MAINTAINER= mva@sysfault.org
+COMMENT= A software implementation of the OpenAL specification
+
+CONFLICTS= openal-200[0-9]*
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+CMAKE_USE_PTHREAD= yes
+CMAKE_ARGS= -DALSA:BOOL=OFF
+
+.include <bsd.port.mk>
diff --git a/audio/openal-soft/distinfo b/audio/openal-soft/distinfo
new file mode 100644
index 000000000000..8ae4249b3a49
--- /dev/null
+++ b/audio/openal-soft/distinfo
@@ -0,0 +1,3 @@
+MD5 (openal-soft-1.6.372.tar.bz2) = 8dc255ba24859953335a0402a644c4ca
+SHA256 (openal-soft-1.6.372.tar.bz2) = f69b2ee7768b8b7eff324d9bc6044c903ab40ddc294c4d37d4ccb092adc7c8b8
+SIZE (openal-soft-1.6.372.tar.bz2) = 77568
diff --git a/audio/openal-soft/files/patch-CMakeLists.txt b/audio/openal-soft/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..453324678ad3
--- /dev/null
+++ b/audio/openal-soft/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2008-11-21 17:57:01.000000000 +0100
++++ CMakeLists.txt 2009-02-01 17:28:27.000000000 +0100
+@@ -371,7 +371,7 @@
+ DESTINATION include/AL
+ )
+ INSTALL(FILES "${OpenAL_BINARY_DIR}/admin/pkgconfig/openal.pc"
+- DESTINATION lib/pkgconfig)
++ DESTINATION libdata/pkgconfig)
+
+ IF(EXAMPLES)
+ ADD_EXECUTABLE(openal-info examples/openal-info.c)
diff --git a/audio/openal-soft/pkg-descr b/audio/openal-soft/pkg-descr
new file mode 100644
index 000000000000..3826a68dcd2a
--- /dev/null
+++ b/audio/openal-soft/pkg-descr
@@ -0,0 +1,10 @@
+OpenAL Soft is a software implementation of the OpenAL 3D audio API and an
+alternative to the somewhat outdated reference implementation.
+As stated on the website, OpenAL provides capabilities for playing audio in a
+virtual 3d environment. Distance attenuation, doppler shift, and directional
+sound emitters are among the features handled by the API. More advanced
+effects, including air absorption, low-pass filters, and reverb, are
+available through the EFX extension. It also facilitates streaming audio,
+multi-channel buffers, and audio capture.
+
+WWW: http://kcat.strangesoft.net/openal.html
diff --git a/audio/openal-soft/pkg-plist b/audio/openal-soft/pkg-plist
new file mode 100644
index 000000000000..afbbf2fe43e6
--- /dev/null
+++ b/audio/openal-soft/pkg-plist
@@ -0,0 +1,9 @@
+bin/openal-info
+include/AL/al.h
+include/AL/alc.h
+include/AL/alext.h
+lib/libopenal.so.1.6.372
+lib/libopenal.so.1
+lib/libopenal.so
+libdata/pkgconfig/openal.pc
+@dirrm include/AL