aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-01 19:16:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-01 19:16:24 +0000
commitab885c68d45ffd842196ff45cea031166ab135b3 (patch)
tree5e5c60ce15af76b88ab508dbebbb2dc5764a3153 /audio
parent13d730720fec41a24863914e9b4bc45d941019b1 (diff)
downloadports-ab885c68d45ffd842196ff45cea031166ab135b3.tar.gz
ports-ab885c68d45ffd842196ff45cea031166ab135b3.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/libcddb/Makefile27
-rw-r--r--audio/libcddb/distinfo2
-rw-r--r--audio/libcddb/files/cddb.h-systypes-patch11
-rw-r--r--audio/libcddb/files/cddb_ni.h-systypes-patch10
-rw-r--r--audio/libcddb/pkg-descr6
-rw-r--r--audio/libcddb/pkg-plist14
7 files changed, 71 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 05ae0f0d2e7c..d4af165b25be 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -150,6 +150,7 @@
SUBDIR += libao
SUBDIR += libaudiofile
SUBDIR += libcdaudio
+ SUBDIR += libcddb
SUBDIR += libid3tag
SUBDIR += libmad
SUBDIR += libmikmod
diff --git a/audio/libcddb/Makefile b/audio/libcddb/Makefile
new file mode 100644
index 000000000000..681a565ad7eb
--- /dev/null
+++ b/audio/libcddb/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: libcddb
+# Date created: Mon Mar 1 00:48:58 EST 2004
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+
+PORTNAME= libcddb
+PORTVERSION= 0.9.4
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ahze@ahze.net
+COMMENT= A library to access data on a CDDB server
+
+USE_LIBTOOL= yes
+USE_GNOME= gnomehack pkgconfig
+INSTALL_SHLIBS= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES+= ${PATCHDIR}/cddb.h-systypes-patch \
+ ${PATCHDIR}/cddb_ni.h-systypes-patch
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/libcddb/distinfo b/audio/libcddb/distinfo
new file mode 100644
index 000000000000..706aa943db30
--- /dev/null
+++ b/audio/libcddb/distinfo
@@ -0,0 +1,2 @@
+MD5 (libcddb-0.9.4.tar.gz) = 366095f09e1d89d91915a2dd7c7c1478
+SIZE (libcddb-0.9.4.tar.gz) = 272751
diff --git a/audio/libcddb/files/cddb.h-systypes-patch b/audio/libcddb/files/cddb.h-systypes-patch
new file mode 100644
index 000000000000..1426f6c5be72
--- /dev/null
+++ b/audio/libcddb/files/cddb.h-systypes-patch
@@ -0,0 +1,11 @@
+--- include/cddb/cddb.h.orig Mon Mar 1 04:22:27 2004
++++ include/cddb/cddb.h Mon Mar 1 04:22:47 2004
+@@ -26,7 +26,7 @@
+ extern "C" {
+ #endif
+
+-
++#include <sys/types.h>
+ #include <cddb/cddb_error.h>
+ #include <cddb/cddb_track.h>
+ #include <cddb/cddb_disc.h>
diff --git a/audio/libcddb/files/cddb_ni.h-systypes-patch b/audio/libcddb/files/cddb_ni.h-systypes-patch
new file mode 100644
index 000000000000..60e7c02643b3
--- /dev/null
+++ b/audio/libcddb/files/cddb_ni.h-systypes-patch
@@ -0,0 +1,10 @@
+--- include/cddb/cddb_ni.h.orig Mon Mar 1 04:28:02 2004
++++ include/cddb/cddb_ni.h Mon Mar 1 04:28:16 2004
+@@ -18,6 +18,7 @@
+ Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+ Boston, MA 02111-1307, USA.
+ */
++#include <sys/types.h>
+
+ #ifndef CDDB_NI_H
+ #define CDDB_NI_H 1
diff --git a/audio/libcddb/pkg-descr b/audio/libcddb/pkg-descr
new file mode 100644
index 000000000000..0d5f1d2edd29
--- /dev/null
+++ b/audio/libcddb/pkg-descr
@@ -0,0 +1,6 @@
+Libcddb is a library that implements the different protocols (CDDBP,
+HTTP, SMTP) to access data on a CDDB server (http://freedb.org). It
+tries to be as cross-platform as possible. The initial libary will
+have a C API.
+
+WWW: http://libcddb.sourceforge.net/
diff --git a/audio/libcddb/pkg-plist b/audio/libcddb/pkg-plist
new file mode 100644
index 000000000000..e9c6fe57fea8
--- /dev/null
+++ b/audio/libcddb/pkg-plist
@@ -0,0 +1,14 @@
+bin/cddb_query
+include/cddb/cddb.h
+include/cddb/cddb_cmd.h
+include/cddb/cddb_conn.h
+include/cddb/cddb_disc.h
+include/cddb/cddb_error.h
+include/cddb/cddb_log.h
+include/cddb/cddb_track.h
+lib/libcddb.a
+lib/libcddb.la
+lib/libcddb.so
+lib/libcddb.so.1
+libdata/pkgconfig/libcddb.pc
+@dirrm include/cddb