aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2009-03-27 09:53:36 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2009-03-27 09:53:36 +0000
commitc810fd3c3f9bb23f07b63b0a05f036466ea372f8 (patch)
treec51d6ad6bd61beb985f639056b8f9f4db2a63a5e /audio
parent98e0641ec39c6b99f5ca8a8e6428fe0088ede4b4 (diff)
downloadports-c810fd3c3f9bb23f07b63b0a05f036466ea372f8.tar.gz
ports-c810fd3c3f9bb23f07b63b0a05f036466ea372f8.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/adplay/Makefile1
-rw-r--r--audio/audacious-dumb/Makefile1
-rw-r--r--audio/aylet/Makefile1
-rw-r--r--audio/bmp-fc/Makefile1
-rw-r--r--audio/checkmate/Makefile1
-rw-r--r--audio/libadplug/Makefile1
-rw-r--r--audio/libmodplug/Makefile1
-rw-r--r--audio/malint/Makefile1
-rw-r--r--audio/mikmod/Makefile1
-rw-r--r--audio/modplugplay/Makefile2
-rw-r--r--audio/mp-player/Makefile2
-rw-r--r--audio/mp3guessenc/Makefile1
-rw-r--r--audio/penguinsap/Makefile2
-rw-r--r--audio/resid/Makefile1
-rw-r--r--audio/schism/Makefile1
-rw-r--r--audio/sfront/Makefile3
-rw-r--r--audio/sidplayer/Makefile1
-rw-r--r--audio/wav2cdr/Makefile2
-rw-r--r--audio/xaylet/Makefile1
-rw-r--r--audio/xmms-ahx/Makefile2
-rw-r--r--audio/xmms-nsf/Makefile1
-rw-r--r--audio/xmms-sexypsf/Makefile1
-rw-r--r--audio/xmms-volnorm/Makefile1
-rw-r--r--audio/xmms-xymms/Makefile1
-rw-r--r--audio/yell/Makefile2
25 files changed, 33 insertions, 0 deletions
diff --git a/audio/adplay/Makefile b/audio/adplay/Makefile
index 78b16f20d959..f0e008114194 100644
--- a/audio/adplay/Makefile
+++ b/audio/adplay/Makefile
@@ -22,6 +22,7 @@ LIB_DEPENDS= adplug-2.1:${PORTSDIR}/audio/libadplug
GNU_CONFIGURE= yes
WANT_SDL= yes
+MAKE_JOBS_SAFE= yes
DBFILE= adplug.db
diff --git a/audio/audacious-dumb/Makefile b/audio/audacious-dumb/Makefile
index c77cd43103ad..3b9b75a9beb1 100644
--- a/audio/audacious-dumb/Makefile
+++ b/audio/audacious-dumb/Makefile
@@ -21,5 +21,6 @@ BUILD_DEPENDS= audacious:${PORTSDIR}/multimedia/audacious \
USE_GMAKE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>
diff --git a/audio/aylet/Makefile b/audio/aylet/Makefile
index c3ee291678f4..bc24b562fd9b 100644
--- a/audio/aylet/Makefile
+++ b/audio/aylet/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A command line player for the .ay audio file format
USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
ALL_TARGET?= ${PORTNAME}
CFLAGS+= -DDRIVER_OSS -I${LOCALBASE}/include
diff --git a/audio/bmp-fc/Makefile b/audio/bmp-fc/Makefile
index ed9d2524f696..53f4d51986e4 100644
--- a/audio/bmp-fc/Makefile
+++ b/audio/bmp-fc/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= beep.2:${PORTSDIR}/multimedia/beep-media-player
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
PLIST_FILES= lib/bmp/Input/libfc.so lib/bmp/Input/libfc.la
diff --git a/audio/checkmate/Makefile b/audio/checkmate/Makefile
index 6abaddfe303b..64ef41348341 100644
--- a/audio/checkmate/Makefile
+++ b/audio/checkmate/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A command-line utility for checking mp3 files for errors
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
MAN1= mpck.1
MLINKS= mpck.1 checkmate.1
diff --git a/audio/libadplug/Makefile b/audio/libadplug/Makefile
index c63d1ae0e01c..9cdcfb651731 100644
--- a/audio/libadplug/Makefile
+++ b/audio/libadplug/Makefile
@@ -21,6 +21,7 @@ USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GNOME= pkgconfig
+MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/audio/libmodplug/Makefile b/audio/libmodplug/Makefile
index 92c582f807b4..3951776147b4 100644
--- a/audio/libmodplug/Makefile
+++ b/audio/libmodplug/Makefile
@@ -18,6 +18,7 @@ USE_LDCONFIG= yes
USE_GMAKE= yes
USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
post-patch:
@${REINPLACE_CMD} -e '/^CXXFLAGS=/d' \
diff --git a/audio/malint/Makefile b/audio/malint/Makefile
index f2a20e14c263..65c515960960 100644
--- a/audio/malint/Makefile
+++ b/audio/malint/Makefile
@@ -16,6 +16,7 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT= MPEG Audio stream validator
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
PORTDOCS= README
PLIST_FILES= bin/malint
diff --git a/audio/mikmod/Makefile b/audio/mikmod/Makefile
index 5a2cfc40bf11..98c6071a4408 100644
--- a/audio/mikmod/Makefile
+++ b/audio/mikmod/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= mikmod.2:${PORTSDIR}/audio/libmikmod
USE_GMAKE= yes
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
.ifdef (WITH_COLOR)
CONFIGURE_ARGS+= --enable-color-interface
diff --git a/audio/modplugplay/Makefile b/audio/modplugplay/Makefile
index 39a2596dda57..06ab612afa39 100644
--- a/audio/modplugplay/Makefile
+++ b/audio/modplugplay/Makefile
@@ -18,6 +18,8 @@ COMMENT= A commandline music mod player using libmodplug
LIB_DEPENDS= modplug.0:${PORTSDIR}/audio/libmodplug
+MAKE_JOBS_SAFE= yes
+
MAN1= modplugplay.1
PLIST_FILES= bin/modplugplay
diff --git a/audio/mp-player/Makefile b/audio/mp-player/Makefile
index 4867d7c16722..cae324ff327d 100644
--- a/audio/mp-player/Makefile
+++ b/audio/mp-player/Makefile
@@ -18,6 +18,8 @@ COMMENT= A curses based module tracker using libmikmod
LIB_DEPENDS= mikmod.2:${PORTSDIR}/audio/libmikmod
+MAKE_JOBS_SAFE= yes
+
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lmikmod ${PTHREAD_LIBS} -lncurses -lpanel
DEFINES= -D_REENTRANT
diff --git a/audio/mp3guessenc/Makefile b/audio/mp3guessenc/Makefile
index 1c2946f734ee..655f1ced0eab 100644
--- a/audio/mp3guessenc/Makefile
+++ b/audio/mp3guessenc/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Utility for guessing which encoder was used to encode an mp3 file
USE_ZIP= yes
+MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}
diff --git a/audio/penguinsap/Makefile b/audio/penguinsap/Makefile
index bbb09bcb8f74..69d33c9abd0f 100644
--- a/audio/penguinsap/Makefile
+++ b/audio/penguinsap/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= CRITICAL
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A command line Atari(TM) .sap player
+MAKE_JOBS_SAFE= yes
+
SOURCES= sapPokey pokey1 sapCpu sapEngine main pokey0
CXXFLAGS+= --no-exceptions
diff --git a/audio/resid/Makefile b/audio/resid/Makefile
index 3bbb786ae78a..08166eb6c8bf 100644
--- a/audio/resid/Makefile
+++ b/audio/resid/Makefile
@@ -17,6 +17,7 @@ COMMENT= Cycle-based SID emulator engine
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --enable-shared
diff --git a/audio/schism/Makefile b/audio/schism/Makefile
index 4dcdf8a5b859..782813371374 100644
--- a/audio/schism/Makefile
+++ b/audio/schism/Makefile
@@ -20,6 +20,7 @@ ONLY_FOR_ARCHS= i386 amd64
USE_SDL= yes
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} ${CPPFLAGS}" \
CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}" \
diff --git a/audio/sfront/Makefile b/audio/sfront/Makefile
index 81f0d3e1f0b3..f4a7f2473c2d 100644
--- a/audio/sfront/Makefile
+++ b/audio/sfront/Makefile
@@ -19,7 +19,10 @@ PORTDOCS= book sfman
WRKSRC= ${WRKDIR}/${PORTNAME}/src
USE_BISON= build
+MAKE_JOBS_SAFE= yes
+
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
+
ALL_TARGET= ${PORTNAME}
do-install:
diff --git a/audio/sidplayer/Makefile b/audio/sidplayer/Makefile
index 3a1d82ee8e0b..a0f350c55a61 100644
--- a/audio/sidplayer/Makefile
+++ b/audio/sidplayer/Makefile
@@ -18,6 +18,7 @@ COMMENT= A C64 SID tune player
USE_SDL= yes
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
SDLINCLUDEDIR= SDL
diff --git a/audio/wav2cdr/Makefile b/audio/wav2cdr/Makefile
index ce1dc1933831..7605be3cb131 100644
--- a/audio/wav2cdr/Makefile
+++ b/audio/wav2cdr/Makefile
@@ -14,6 +14,8 @@ MASTER_SITE_SUBDIR= apps/sound/convert
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Converts WAV files into CDR audio file format
+MAKE_JOBS_SAFE= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}
SRC= wav2cdr cmdarg data fileio process
diff --git a/audio/xaylet/Makefile b/audio/xaylet/Makefile
index 3d9043ce9bce..4e9002c35508 100644
--- a/audio/xaylet/Makefile
+++ b/audio/xaylet/Makefile
@@ -14,6 +14,7 @@ ALL_TARGET= xaylet
MASTERDIR= ${.CURDIR}/../aylet
USE_GNOME= gtk12
+MAKE_JOBS_SAFE= yes
DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
diff --git a/audio/xmms-ahx/Makefile b/audio/xmms-ahx/Makefile
index a502dfc5d150..93940b3ce48f 100644
--- a/audio/xmms-ahx/Makefile
+++ b/audio/xmms-ahx/Makefile
@@ -18,6 +18,8 @@ COMMENT= XMMS plugin for playing AHX tunes
BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+MAKE_JOBS_SAFE= yes
+
PLIST_FILES= lib/xmms/Input/libahx.la \
lib/xmms/Input/libahx.so
diff --git a/audio/xmms-nsf/Makefile b/audio/xmms-nsf/Makefile
index d5eb8188e62f..d2eab61846bd 100644
--- a/audio/xmms-nsf/Makefile
+++ b/audio/xmms-nsf/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/audio/xmms-sexypsf/Makefile b/audio/xmms-sexypsf/Makefile
index a95702de547b..f89aba2fd8ea 100644
--- a/audio/xmms-sexypsf/Makefile
+++ b/audio/xmms-sexypsf/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_BZIP2= yes
USE_GNOME= gtk12
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
CFLAGS+= -I${WRKSRC} -fPIC
DEFINES= -DSPSFVERSION=\""${PORTVERSION}\"" -DPSS_STYLE=1
diff --git a/audio/xmms-volnorm/Makefile b/audio/xmms-volnorm/Makefile
index 7833ebde12cd..258ff96d5769 100644
--- a/audio/xmms-volnorm/Makefile
+++ b/audio/xmms-volnorm/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
USE_GNOME= gnometarget gtk12
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
PLIST_FILES= lib/xmms/Effect/libnormvol.so
diff --git a/audio/xmms-xymms/Makefile b/audio/xmms-xymms/Makefile
index 11622c811492..4d39f48b196a 100644
--- a/audio/xmms-xymms/Makefile
+++ b/audio/xmms-xymms/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
GNU_CONFIGURE= yes
USE_GNOME= gtk12
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
diff --git a/audio/yell/Makefile b/audio/yell/Makefile
index 9d51a1c2ffdb..4229511d501c 100644
--- a/audio/yell/Makefile
+++ b/audio/yell/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= CRITICAL
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A command line pc speaker bell
+MAKE_JOBS_SAFE= yes
+
PLIST_FILES= bin/yell
ONLY_FOR_ARCHS= i386 amd64