aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-04-29 04:52:18 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-04-30 08:03:20 +0000
commitca3f925d6eb53ff27e2a49775f6d33f52a587ae4 (patch)
tree8330d02f36a17f334c0d38f6741d0d042f6d6f38 /audio
parentdc8bd44c128467d5b76d40478fa87da62d56d35d (diff)
downloadports-ca3f925d6eb53ff27e2a49775f6d33f52a587ae4.tar.gz
ports-ca3f925d6eb53ff27e2a49775f6d33f52a587ae4.zip
Diffstat (limited to 'audio')
-rw-r--r--audio/exaile/Makefile4
-rw-r--r--audio/faudio/Makefile5
-rw-r--r--audio/gnome-music/Makefile4
-rw-r--r--audio/gnome-podcasts/Makefile4
-rw-r--r--audio/goobox/Makefile3
-rw-r--r--audio/gradio/Makefile4
-rw-r--r--audio/gsequencer/Makefile3
-rw-r--r--audio/gstreamer1-plugins-sndio/Makefile6
-rw-r--r--audio/libcanberra/Makefile2
-rw-r--r--audio/lollypop/Makefile6
-rw-r--r--audio/moodbar/Makefile4
-rw-r--r--audio/mp3splt-gtk/Makefile3
-rw-r--r--audio/mpz/Makefile4
-rw-r--r--audio/pianod2/Makefile4
-rw-r--r--audio/pithos/Makefile4
-rw-r--r--audio/pragha/Makefile4
-rw-r--r--audio/pulseeffects/Makefile4
-rw-r--r--audio/rhythmbox/Makefile4
-rw-r--r--audio/sayonara/Makefile4
-rw-r--r--audio/shortwave/Makefile6
-rw-r--r--audio/sound-juicer/Makefile4
-rw-r--r--audio/strawberry/Makefile3
22 files changed, 41 insertions, 48 deletions
diff --git a/audio/exaile/Makefile b/audio/exaile/Makefile
index b5a59a29ab89..124fd7a3adf1 100644
--- a/audio/exaile/Makefile
+++ b/audio/exaile/Makefile
@@ -16,10 +16,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsddb3>0:databases/py-bsddb3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}gstreamer1>0:multimedia/py-gstreamer1@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mutagen>0:audio/py-mutagen@${PY_FLAVOR}
-USES= desktop-file-utils gmake gnome python:3.6+
+USES= desktop-file-utils gmake gnome gstreamer python:3.6+
USE_GITHUB= yes
USE_GNOME= gtk30 librsvg2 pygobject3
-USE_GSTREAMER1= faad good
+USE_GSTREAMER= faad good
MAKE_ENV= EPREFIX=${PREFIX} \
MANPREFIX=${PREFIX} \
diff --git a/audio/faudio/Makefile b/audio/faudio/Makefile
index 09894023a561..853f6d1ce79c 100644
--- a/audio/faudio/Makefile
+++ b/audio/faudio/Makefile
@@ -21,9 +21,8 @@ OPTIONS_DEFAULT= GSTREAMER
GSTREAMER_DESC= WMA/XMA support via GStreamer
-GSTREAMER_USES= gettext-runtime gnome pkgconfig
-GSTREAMER_USE= GNOME=glib20 \
- GSTREAMER1=yes
+GSTREAMER_USES= gettext-runtime gnome gstreamer pkgconfig
+GSTREAMER_USE= GNOME=glib20
GSTREAMER_CMAKE_BOOL= GSTREAMER
do-test:
diff --git a/audio/gnome-music/Makefile b/audio/gnome-music/Makefile
index e2eb3fbf78cb..9f4722254c3d 100644
--- a/audio/gnome-music/Makefile
+++ b/audio/gnome-music/Makefile
@@ -26,11 +26,11 @@ RUN_DEPENDS= grilo-plugins>0:net/grilo-plugins
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gnome localbase meson pkgconfig \
+USES= desktop-file-utils gettext gnome gstreamer localbase meson pkgconfig \
python:3.4+ shebangfix tar:xz
USE_LDCONFIG= yes
USE_GNOME= cairo gtk40 introspection pygobject3
-USE_GSTREAMER1= mpg123 ogg
+USE_GSTREAMER= mpg123 ogg
SHEBANG_FILES= gnome-music.in
BINARY_ALIAS= python3=${PYTHON_VERSION}
diff --git a/audio/gnome-podcasts/Makefile b/audio/gnome-podcasts/Makefile
index 662bbe9cd77a..f11e8aa8f0c1 100644
--- a/audio/gnome-podcasts/Makefile
+++ b/audio/gnome-podcasts/Makefile
@@ -17,10 +17,10 @@ BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libdbus-1.so:devel/dbus \
libhandy-1.so:x11-toolkits/libhandy
-USES= cargo gettext gnome meson pkgconfig python:build shebangfix sqlite ssl
+USES= cargo gettext gnome gstreamer meson pkgconfig python:build shebangfix sqlite ssl
USE_GITLAB= yes
USE_GNOME= gdkpixbuf2 gtk30
-USE_GSTREAMER1= bad good libav
+USE_GSTREAMER= bad good libav
GL_SITE= https://gitlab.gnome.org
GL_ACCOUNT= World
GL_COMMIT= c86f7bfdef7692bbf20f315a90450321f6ca9ce7
diff --git a/audio/goobox/Makefile b/audio/goobox/Makefile
index ed45d37bd64a..48b69a41ae73 100644
--- a/audio/goobox/Makefile
+++ b/audio/goobox/Makefile
@@ -18,11 +18,10 @@ LIB_DEPENDS= libdiscid.so:audio/libdiscid \
libbrasero-media3.so:sysutils/brasero \
libunique-1.0.so:x11-toolkits/unique
-USES= desktop-file-utils gettext gnome meson pkgconfig \
+USES= desktop-file-utils gettext gnome gstreamer meson pkgconfig \
python:3.5+,build tar:xz xorg
USE_GNOME= glib20 gtk30 intlhack
USE_XORG= x11
-USE_GSTREAMER1= yes
INSTALL_TARGET= install-strip
BINARY_ALIAS= python3=${PYTHON_CMD}
diff --git a/audio/gradio/Makefile b/audio/gradio/Makefile
index 59e98f6988e7..ea6ea67d188b 100644
--- a/audio/gradio/Makefile
+++ b/audio/gradio/Makefile
@@ -15,12 +15,12 @@ BUILD_DEPENDS= valac:lang/vala
LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
libjson-glib-1.0.so:devel/json-glib
-USES= gettext gnome meson pkgconfig python:3.4+,env sqlite
+USES= gettext gnome gstreamer meson pkgconfig python:3.4+,env sqlite
USE_GITHUB= yes
GH_ACCOUNT= haecker-felix
GH_PROJECT= Gradio
USE_GNOME= cairo gdkpixbuf2 glib20 gtk30
-USE_GSTREAMER1= mpg123 soup
+USE_GSTREAMER= mpg123 soup
GLIB_SCHEMAS= de.haeckerfelix.gradio.gschema.xml
diff --git a/audio/gsequencer/Makefile b/audio/gsequencer/Makefile
index c505b845493d..f8b5d282d229 100644
--- a/audio/gsequencer/Makefile
+++ b/audio/gsequencer/Makefile
@@ -24,10 +24,9 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
libwebkit2gtk-4.0.so:www/webkit2-gtk3
RUN_DEPENDS= dssi>0:audio/dssi
-USES= desktop-file-utils gettext-runtime gettext-tools gmake gnome libtool localbase pkgconfig shared-mime-info xorg
+USES= desktop-file-utils gettext-runtime gettext-tools gmake gnome gstreamer libtool localbase pkgconfig shared-mime-info xorg
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 libxml2 pango
USE_XORG= x11
-USE_GSTREAMER1= yes
USE_GCC= yes # the project uses gnu99 extensions, clang fails even with USE_CSTD=gnu99. Suggestions how to build with clang are welcome.
USE_CSTD= gnu99
USE_LDCONFIG= yes
diff --git a/audio/gstreamer1-plugins-sndio/Makefile b/audio/gstreamer1-plugins-sndio/Makefile
index 7f584c7f12ae..e1c085214a9a 100644
--- a/audio/gstreamer1-plugins-sndio/Makefile
+++ b/audio/gstreamer1-plugins-sndio/Makefile
@@ -9,11 +9,9 @@ COMMENT= Sndio audio sink and source for GStreamer
LICENSE= ISCL
-LIB_DEPENDS= libgstaudio-1.0.so:multimedia/gstreamer1-plugins \
- libgstbase-1.0.so:multimedia/gstreamer1 \
- libsndio.so:audio/sndio
+LIB_DEPENDS= libsndio.so:audio/sndio
-USES= gnome pkgconfig
+USES= gnome gstreamer pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= t6
USE_GNOME= glib20
diff --git a/audio/libcanberra/Makefile b/audio/libcanberra/Makefile
index a1b9da87a74a..76b99d7bbe9d 100644
--- a/audio/libcanberra/Makefile
+++ b/audio/libcanberra/Makefile
@@ -50,7 +50,7 @@ PLIST_SUB+= PULSE="@comment "
.endif
.if ${PORT_OPTIONS:MGSTREAMER}
-USE_GSTREAMER1= yes
+USES+= gstreamer
PLIST_SUB+= GSTREAMER=""
.else
CONFIGURE_ARGS+=--disable-gstreamer
diff --git a/audio/lollypop/Makefile b/audio/lollypop/Makefile
index 8c31dee12b4b..cbab38169175 100644
--- a/audio/lollypop/Makefile
+++ b/audio/lollypop/Makefile
@@ -24,14 +24,14 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.7.8:databases/py-sqlite3@${PY_FLA
${PYTHON_PKGNAMEPREFIX}pylast>=1.4.0:audio/py-pylast@${PY_FLAVOR} \
${PY_PILLOW}
-USES= python:3.6+ pkgconfig gnome gettext meson shebangfix sqlite desktop-file-utils
+USES= python:3.6+ pkgconfig gnome gettext gstreamer meson shebangfix sqlite desktop-file-utils
USE_GITLAB= yes
GL_SITE= https://gitlab.gnome.org
GL_ACCOUNT= World
GL_COMMIT= 5b2d95f4f8509d80fa86ab7d65b118326dc82a95
GL_TUPLE= gnumdk:lollypop-po:94a7300004ec15adfd596c7d2b8670bbf5c2e33a:po/subprojects/po
USE_GNOME= glib20 gtk30 pygobject3 introspection:build intltool intlhack
-USE_GSTREAMER1= yes mpg123 ogg flac opus libav faad good speex
+USE_GSTREAMER= mpg123 ogg flac opus libav faad good speex
USE_PYTHON= py3kplist
SHEBANG_FILES= lollypop.in search-provider/lollypop-sp.in meson_post_install.py
@@ -41,6 +41,6 @@ GLIB_SCHEMAS= org.gnome.Lollypop.gschema.xml
BINARY_ALIAS= python3=${PYTHON_VERSION}
OPTIONS_DEFINE= PULSEAUDIO
-PULSEAUDIO_USE= gstreamer1=pulse
+PULSEAUDIO_USE= gstreamer=pulse
.include <bsd.port.mk>
diff --git a/audio/moodbar/Makefile b/audio/moodbar/Makefile
index 95aadc8ffd6c..ab71d4cdbcb2 100644
--- a/audio/moodbar/Makefile
+++ b/audio/moodbar/Makefile
@@ -12,10 +12,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfftw3.so:math/fftw3
TEST_DEPENDS= ${PYNUMPY}
-USES= compiler:c++14-lang gnome meson pkgconfig python:3.5+,test \
+USES= compiler:c++14-lang gnome gstreamer meson pkgconfig python:3.5+,test \
shebangfix tar:xz
USE_GNOME= glib20
-USE_GSTREAMER1= yes good ogg vorbis
+USE_GSTREAMER= good ogg vorbis
PLIST_FILES= bin/moodbar
SHEBANG_FILES= test.py
diff --git a/audio/mp3splt-gtk/Makefile b/audio/mp3splt-gtk/Makefile
index 103bb5c6531d..d594c7c1468a 100644
--- a/audio/mp3splt-gtk/Makefile
+++ b/audio/mp3splt-gtk/Makefile
@@ -21,8 +21,7 @@ LIB_DEPENDS= libmp3splt.so:audio/libmp3splt \
libid3tag.so:audio/libid3tag \
libltdl.so:devel/libltdl
-USES= desktop-file-utils gmake gnome pkgconfig
-USE_GSTREAMER1= yes
+USES= desktop-file-utils gmake gnome gstreamer pkgconfig
USE_GNOME= gtk30
GNU_CONFIGURE= yes
diff --git a/audio/mpz/Makefile b/audio/mpz/Makefile
index b91102d4cebc..b0df07bb32dc 100644
--- a/audio/mpz/Makefile
+++ b/audio/mpz/Makefile
@@ -15,8 +15,8 @@ LIB_DEPENDS= libtag.so:audio/taglib \
USE_GITHUB= yes
GH_ACCOUNT= olegantonyan
-USES= compiler:c++11-lang desktop-file-utils qmake qt:5
-USE_GSTREAMER1= flac libav mpg123 ogg opus vorbis
+USES= compiler:c++11-lang desktop-file-utils gstreamer qmake qt:5
+USE_GSTREAMER= flac libav mpg123 ogg opus vorbis
USE_QT= buildtools_build concurrent core dbus gui multimedia \
network widgets x11extras
diff --git a/audio/pianod2/Makefile b/audio/pianod2/Makefile
index 78eb5f6f6dc8..55c066464145 100644
--- a/audio/pianod2/Makefile
+++ b/audio/pianod2/Makefile
@@ -27,10 +27,10 @@ LIB_DEPENDS= libao.so:audio/libao \
libtag.so:audio/taglib
RUN_DEPENDS= mksh>0:shells/mksh
-USES= autoreconf compiler:c11 gettext gmake gnome pkgconfig shebangfix
+USES= autoreconf compiler:c11 gettext gmake gnome gstreamer pkgconfig shebangfix
USE_GNOME= glib20
-USE_GSTREAMER1= ffmpeg
+USE_GSTREAMER= #ffmpeg
USE_RC_SUBR= pianod
diff --git a/audio/pithos/Makefile b/audio/pithos/Makefile
index 2aaca336e907..ed6eecc6873c 100644
--- a/audio/pithos/Makefile
+++ b/audio/pithos/Makefile
@@ -20,11 +20,11 @@ RUN_DEPENDS= gnome-keyring:security/gnome-keyring \
${PYTHON_PKGNAMEPREFIX}pylast>0:audio/py-pylast@${PY_FLAVOR} \
${PYTHON_SITELIBDIR}/xdg/__init__.py:devel/py-xdg@${PY_FLAVOR}
-USES= pkgconfig:run python:3.6+ gnome meson ninja gettext shebangfix
+USES= pkgconfig:run python:3.6+ gnome gstreamer meson ninja gettext shebangfix
USE_GITHUB= yes
USE_GNOME= glib20
-USE_GSTREAMER1= core good bad soup
+USE_GSTREAMER= core good bad soup
GLIB_SCHEMAS= io.github.Pithos.gschema.xml
diff --git a/audio/pragha/Makefile b/audio/pragha/Makefile
index 553f403f3cca..566cc3c62694 100644
--- a/audio/pragha/Makefile
+++ b/audio/pragha/Makefile
@@ -18,11 +18,11 @@ LIB_DEPENDS= libtag.so:audio/taglib \
libsoup-2.4.so:devel/libsoup \
libtotem-plparser.so:multimedia/totem-pl-parser
-USES= compiler:c11 desktop-file-utils gettext-tools gmake gnome \
+USES= compiler:c11 desktop-file-utils gettext-tools gmake gnome gstreamer \
libtool pkgconfig sqlite tar:bz2
GNU_CONFIGURE= yes
USE_GNOME= glib20 gtk30 intltool intlhack
-USE_GSTREAMER1= yes faad flac libav mpg123 ogg speex
+USE_GSTREAMER= faad flac libav mpg123 ogg speex
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/audio/pulseeffects/Makefile b/audio/pulseeffects/Makefile
index 54af564c3ebc..4f8ac34d41f3 100644
--- a/audio/pulseeffects/Makefile
+++ b/audio/pulseeffects/Makefile
@@ -40,10 +40,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>0:graphics/py-cairo@${PY_FLAVOR} \
zam-plugins-lv2>0:audio/zam-plugins-lv2
USES= compiler:c++17-lang desktop-file-utils libtool \
- localbase:ldflags gettext gnome meson ninja pathfix pkgconfig \
+ localbase:ldflags gettext gnome gstreamer meson ninja pathfix pkgconfig \
python:3.6+ shebangfix
USE_GNOME= cairo gtkmm30 libsigc++20 pygobject3
-USE_GSTREAMER1= bad bs2b good ladspa lv2 pulse webrtcdsp
+USE_GSTREAMER= bad bs2b good ladspa lv2 pulse webrtcdsp
USE_LDCONFIG= yes
USE_GITHUB= yes
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index 61a0e1df2780..f2b7194f10ee 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -29,13 +29,13 @@ LIB_DEPENDS= libmusicbrainz5.so:audio/libmusicbrainz5 \
libgudev-1.0.so:devel/libgudev \
libtdb.so:databases/tdb
-USES= desktop-file-utils gmake gnome libtool localbase \
+USES= desktop-file-utils gmake gnome gstreamer libtool localbase \
pathfix pkgconfig tar:xz xorg
USE_GNOME= cairo intlhack glib20 gnomeprefix gtk30 introspection \
pygobject3 libxml2
USE_XORG= ice x11 xorgproto
GNU_CONFIGURE= yes
-USE_GSTREAMER1= flac lame jpeg cdparanoia vorbis
+USE_GSTREAMER= flac lame jpeg cdparanoia vorbis
CONFIGURE_ARGS= --enable-vala \
--enable-visualizer=no \
--with-python=yes \
diff --git a/audio/sayonara/Makefile b/audio/sayonara/Makefile
index 904a6d0fb0ab..b90275314f82 100644
--- a/audio/sayonara/Makefile
+++ b/audio/sayonara/Makefile
@@ -13,10 +13,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libtag.so:audio/taglib \
libmtp.so:multimedia/libmtp
-USES= cmake compiler:c++11-lib desktop-file-utils gnome pkgconfig \
+USES= cmake compiler:c++11-lib desktop-file-utils gnome gstreamer pkgconfig \
qt:5 python shebangfix
USE_GNOME= glib20
-USE_GSTREAMER1= flac libav mpg123 ogg opus vorbis
+USE_GSTREAMER= flac libav mpg123 ogg opus vorbis
USE_QT= dbus core gui network sql sql-sqlite3_run svg widgets xml \
buildtools_build qmake_build linguisttools_build
diff --git a/audio/shortwave/Makefile b/audio/shortwave/Makefile
index d3bf9c933f28..4feec4d8e46e 100644
--- a/audio/shortwave/Makefile
+++ b/audio/shortwave/Makefile
@@ -13,10 +13,10 @@ IGNORE= crashes with libadwaita >= 1.0
LIB_DEPENDS= libdbus-1.so:devel/dbus
-USES= cargo gettext gnome meson pkgconfig python:build shebangfix sqlite ssl
+USES= cargo gettext gnome gstreamer meson pkgconfig python:build shebangfix sqlite ssl
USE_GITLAB= yes
USE_GNOME= gdkpixbuf2 gtk40 libadwaita
-USE_GSTREAMER1= good libav soup vorbis
+USE_GSTREAMER= good libav soup vorbis
GL_SITE= https://gitlab.gnome.org
GL_ACCOUNT= World
GL_PROJECT= Shortwave
@@ -284,7 +284,7 @@ CARGO_TEST= no
OPTIONS_DEFINE= PULSEAUDIO
OPTIONS_DEFAULT=PULSEAUDIO
-PULSEAUDIO_USE= GSTREAMER1=pulse
+PULSEAUDIO_USE= GSTREAMER=pulse
pre-patch:
# Chase gtk-rs -> gtk3-rs rename for USES=cargo patching
diff --git a/audio/sound-juicer/Makefile b/audio/sound-juicer/Makefile
index 1289d513ecef..44fa97fe3de4 100644
--- a/audio/sound-juicer/Makefile
+++ b/audio/sound-juicer/Makefile
@@ -24,9 +24,9 @@ LIB_DEPENDS= libmusicbrainz5.so:audio/libmusicbrainz5 \
PORTSCOUT= limitw:1,even
-USES= compiler:c11 desktop-file-utils gettext gnome meson \
+USES= compiler:c11 desktop-file-utils gettext gnome gstreamer meson \
pkgconfig tar:xz
-USE_GSTREAMER1= cdparanoia flac good vorbis
+USE_GSTREAMER= cdparanoia flac good vorbis
USE_GNOME= gtk30
INSTALL_TARGET= install-strip
diff --git a/audio/strawberry/Makefile b/audio/strawberry/Makefile
index 382982efdecb..09f1d4514c0e 100644
--- a/audio/strawberry/Makefile
+++ b/audio/strawberry/Makefile
@@ -18,11 +18,10 @@ LIB_DEPENDS= libgnutls.so:security/gnutls \
TEST_DEPENDS= googletest>=0:devel/googletest
USES= compiler:c++11-lang cmake desktop-file-utils gnome \
- gettext-runtime gettext-tools iconv pkgconfig \
+ gettext-runtime gettext-tools gstreamer iconv pkgconfig \
qt:5 sqlite pkgconfig tar:xz xorg
USE_GNOME= glib20
-USE_GSTREAMER1= yes
USE_QT= buildtools_build concurrent core dbus gui network \
linguisttools qmake_build sql sql-sqlite3 testlib_build \
widgets x11extras