aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-06-12 04:23:29 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-06-12 04:23:29 +0000
commitd8648995465a515a2f0bd75b0a0b2477d65aa2a3 (patch)
tree8f1c0a27bdad551340af8f80d98a3a300bde0ebc /audio
parent5183d6d6ee0a225c3e1112e8b3a72ba71e2e03f6 (diff)
downloadports-d8648995465a515a2f0bd75b0a0b2477d65aa2a3.tar.gz
ports-d8648995465a515a2f0bd75b0a0b2477d65aa2a3.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/bristol/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/audio/bristol/Makefile b/audio/bristol/Makefile
index 8383ebd7081f..a52ba86a6e97 100644
--- a/audio/bristol/Makefile
+++ b/audio/bristol/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libjack.so:audio/jack \
USES= libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
QT_COMPONENTS= gui qmake_build moc_build uic_build rcc_build linguist_build
CONFIGURE_ARGS+= --disable-alsa --enable-oss \
@@ -25,12 +26,12 @@ CONFIGURE_ARGS+= --disable-alsa --enable-oss \
--enable-jack-default-midi \
--disable-version-check
-BROKEN_aarch64= Does not build: error: unknown FP unit 'sse'
-BROKEN_armv6= Does not build: error: unknown FP unit 'sse'
-BROKEN_armv7= Does not build: error: unknown FP unit 'sse'
-BROKEN_mips64= Does not build: error: unknown FP unit 'sse'
-BROKEN_powerpc64= Does not build: error: unknown FP unit 'sse'
-
PORTDATA= *
+post-patch:
+ @${REINPLACE_CMD} -e 's|-march=core2 -msse -msse2 -mfpmath=sse||; s|-O3||' \
+ ${WRKSRC}/libbristol/Makefile.in
+ @${REINPLACE_CMD} -e 's|-msse -mfpmath=sse||; s|-O2||' \
+ ${WRKSRC}/bristol/Makefile.in
+
.include <bsd.port.mk>