aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2017-06-11 13:46:40 +0000
committerWen Heping <wen@FreeBSD.org>2017-06-11 13:46:40 +0000
commita561a0d9ea10cf1ca5fa615e1bfc3962d3b724f2 (patch)
treeb722e120a97526c1d863cbc93f9279f53ab0ebd7 /audio
parent1a23fe75967b3cab910b2baf3409b392dfd9beda (diff)
downloadports-a561a0d9ea10cf1ca5fa615e1bfc3962d3b724f2.tar.gz
ports-a561a0d9ea10cf1ca5fa615e1bfc3962d3b724f2.zip
- Update to 1.1.1
PR: 194153 Submitted by: swills@ Approved by: maintainer(timeout, > 2 years)
Notes
Notes: svn path=/head/; revision=443389
Diffstat (limited to 'audio')
-rw-r--r--audio/shairport/Makefile37
-rw-r--r--audio/shairport/distinfo5
-rw-r--r--audio/shairport/files/patch-Makefile22
-rw-r--r--audio/shairport/files/patch-configure31
-rw-r--r--audio/shairport/files/patch-shairport.pl18
-rw-r--r--audio/shairport/files/shairport.in5
6 files changed, 71 insertions, 47 deletions
diff --git a/audio/shairport/Makefile b/audio/shairport/Makefile
index af6440f6d058..22cac4179c73 100644
--- a/audio/shairport/Makefile
+++ b/audio/shairport/Makefile
@@ -2,48 +2,37 @@
# $FreeBSD$
PORTNAME= shairport
-PORTVERSION= 0.05
-PORTREVISION= 1
+PORTVERSION= 1.1.1
CATEGORIES= audio
MAINTAINER= miks.mikelsons@gmail.com
COMMENT= Airtunes emulator
LIB_DEPENDS= libao.so:audio/libao
-RUN_DEPENDS= p5-MIME-Base64>=0:converters/p5-MIME-Base64 \
- p5-Getopt-Long>=0:devel/p5-Getopt-Long \
- p5-URI>=0:net/p5-URI \
- p5-Crypt-OpenSSL-RSA>=0:security/p5-Crypt-OpenSSL-RSA \
- p5-Digest-MD5>=0:security/p5-Digest-MD5 \
- p5-HTTP-Message>=0:www/p5-HTTP-Message \
- avahi-publish-service:net/avahi-app
-
-USES= gmake perl5 pkgconfig ssl
-USE_PERL5= run
+RUN_DEPENDS= avahi-publish-service:net/avahi-app
+
+USES= gmake pkgconfig ssl
USE_GITHUB= yes
-GH_ACCOUNT= miks
-GH_TAGNAME= b1cb9ea
+GH_ACCOUNT= abrasive
USE_RC_SUBR= ${PORTNAME}
SUB_LIST= PERL=${PERL}
-PLIST_FILES= bin/${PORTNAME} bin/hairtunes bin/${PORTNAME}.pl
+PLIST_FILES= bin/${PORTNAME}
PORTDOCS= README.md
OPTIONS_DEFINE= DOCS
post-patch:
- @${REINPLACE_CMD} -e 's|avahi-|${LOCALBASE}/bin/avahi-|g' \
- -e 's|$$FindBin.*|"${PREFIX}/bin/hairtunes";|' \
- -e '/use FindBin;/d;s|/usr/bin/env perl|${PERL}|' \
- ${WRKSRC}/shairport.c ${WRKSRC}/shairport.pl
- @${REINPLACE_CMD} 's/-lssl/-lcrypto/' ${WRKSRC}/Makefile
+ @${ECHO_CMD} '"'${PORTVERSION}'"' > ${WRKSRC}/version.h
+
+do-configure:
+ cd ${WRKSRC} ; ./configure
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${STAGEDIR}${PREFIX}/bin
-.for file in ${PORTNAME} hairtunes
- ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/bin
-.endfor
+ cd ${WRKSRC} ; ${GMAKE} PREFIX=${STAGEDIR}${PREFIX} install
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/shairport
+
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
diff --git a/audio/shairport/distinfo b/audio/shairport/distinfo
index b4afd2c19214..55965e74806f 100644
--- a/audio/shairport/distinfo
+++ b/audio/shairport/distinfo
@@ -1,2 +1,3 @@
-SHA256 (miks-shairport-0.05-b1cb9ea_GH0.tar.gz) = 0e38b57a90c170a8cd798efe6df00beace91fc30a97da9e6f5568a2e06f6499f
-SIZE (miks-shairport-0.05-b1cb9ea_GH0.tar.gz) = 40413
+TIMESTAMP = 1497172386
+SHA256 (abrasive-shairport-1.1.1_GH0.tar.gz) = 1b60df6d40bab874c1220d7daecd68fcff3e47bda7c6d7f91db0a5b5c43c0c72
+SIZE (abrasive-shairport-1.1.1_GH0.tar.gz) = 59487
diff --git a/audio/shairport/files/patch-Makefile b/audio/shairport/files/patch-Makefile
new file mode 100644
index 000000000000..14f8439df956
--- /dev/null
+++ b/audio/shairport/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- Makefile.orig 2014-10-05 01:39:58 UTC
++++ Makefile
+@@ -48,19 +48,9 @@
+ install -m 755 -d $(PREFIX)/bin
+ install -m 755 shairport $(PREFIX)/bin/shairport
+
+-GITREV=$(shell git describe --always)
+-DIRTY:=$(shell if ! git diff --quiet --exit-code; then echo -dirty; fi)
+-VERSION=\"$(GITREV)$(DIRTY)\"
+-__version_file:
+- @if [ ! -f version.h -o "`cat .version 2>/dev/null`" != '$(VERSION)' ]; then \
+- echo $(VERSION) > version.h; \
+- fi
+-
+ %.o: %.c $(DEPS)
+ $(CC) -c $(CFLAGS) $<
+
+-shairport.o: __version_file
+-
+ OBJS := $(SRCS:.c=.o)
+ shairport: $(OBJS)
+ $(CC) $(OBJS) $(LDFLAGS) -o shairport
diff --git a/audio/shairport/files/patch-configure b/audio/shairport/files/patch-configure
new file mode 100644
index 000000000000..044c277b9c97
--- /dev/null
+++ b/audio/shairport/files/patch-configure
@@ -0,0 +1,31 @@
+--- configure.orig 2014-07-01 11:54:43 UTC
++++ configure
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+
+-[ -z "${CC}" ] && CC=gcc
++[ -z "${CC}" ] && CC=cc
+
+ echo Configuring Shairport
+
+@@ -59,7 +59,7 @@
+ fi
+ }
+
+-do_pkg_config OpenSSL openssl
++do_pkg_config OpenSSL openssl CONFIG_OPENSSL
+ do_pkg_config libao ao CONFIG_AO
+ do_pkg_config PulseAudio libpulse-simple CONFIG_PULSE
+ do_pkg_config ALSA alsa CONFIG_ALSA
+@@ -80,9 +80,9 @@
+
+
+ echo "CFLAGS+=${CFLAGS}" >> config.mk
+-echo "LDFLAGS+=${LDFLAGS}" >> config.mk
++echo "LDFLAGS+=${LDFLAGS} -lcrypto" >> config.mk
+
+ echo CFLAGS: ${CFLAGS}
+-echo LDFLAGS: ${LDFLAGS}
++echo LDFLAGS: ${LDFLAGS} -lcrypto
+
+ echo "Configure successful. You may now build with 'make'"
diff --git a/audio/shairport/files/patch-shairport.pl b/audio/shairport/files/patch-shairport.pl
deleted file mode 100644
index 55da5b6bd768..000000000000
--- a/audio/shairport/files/patch-shairport.pl
+++ /dev/null
@@ -1,18 +0,0 @@
---- shairport.pl.orig 2012-01-02 10:57:00 UTC
-+++ shairport.pl
-@@ -270,6 +270,7 @@ $SIG{__DIE__} = sub {
- $avahi_publish = fork();
- my $pw_clause = (length $password) ? "pw=true" : "pw=false";
- if ($avahi_publish==0) {
-+ open STDERR, "/dev/null"; # suppress output from avahi-publish-service
- { exec 'avahi-publish-service',
- join('', map { sprintf "%02X", $_ } @hw_addr) . "\@$apname",
- "_raop._tcp",
-@@ -329,7 +330,6 @@ my $sel = new IO::Select($listen);
-
- if ($daemon) {
- chdir "/" or die "Could not chdir to '/': $!";
-- umask 0;
- open STDIN, "/dev/null" or die "Could not redirect /dev/null to STDIN(0): $!";
- open STDOUT, ">/dev/null" or die "Could not redirect STDOUT(1) to /dev/null: $!";
- defined( my $pid = fork() ) or die "Could not fork: $!";
diff --git a/audio/shairport/files/shairport.in b/audio/shairport/files/shairport.in
index 8113274556c0..aa05d7c31323 100644
--- a/audio/shairport/files/shairport.in
+++ b/audio/shairport/files/shairport.in
@@ -27,11 +27,10 @@ load_rc_config ${name}
: ${shairport_enable="NO"}
: ${shairport_user="nobody"}
-command="%%PREFIX%%/bin/${name}.pl"
+command="%%PREFIX%%/bin/${name}"
pidfile="/var/run/${name}/${name}.pid"
-command_interpreter="%%PERL%%"
-command_args="-d -w ${pidfile}"
+command_args="-d -P ${pidfile}"
start_precmd="install -d -o ${shairport_user} -g wheel -m 755 /var/run/${name}"
run_rc_command "$1"