aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJase Thew <jase@FreeBSD.org>2012-07-09 13:05:07 +0000
committerJase Thew <jase@FreeBSD.org>2012-07-09 13:05:07 +0000
commitfd7aab303ed51a86c56ab80b0347db07e0743b65 (patch)
tree1e8771da7c0f382fa5bccbdb910669b831ca21d8 /audio
parent8f8777c3b07c589b03a2315227a2ccdc7ce8fda5 (diff)
downloadports-fd7aab303ed51a86c56ab80b0347db07e0743b65.tar.gz
ports-fd7aab303ed51a86c56ab80b0347db07e0743b65.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/taglib/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/audio/taglib/Makefile b/audio/taglib/Makefile
index e5dbe88b4ae7..d6c9b3150d99 100644
--- a/audio/taglib/Makefile
+++ b/audio/taglib/Makefile
@@ -19,27 +19,29 @@ LICENSE_COMB= dual
LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING.LGPL
LICENSE_FILE_MPL= ${WRKSRC}/COPYING.MPL
+OPTIONS_DEFINE= RCC
+
+RCC_DESC= Build with RusXMMS librcc patches (experimental)
+
USE_CMAKE= yes
CMAKE_ARGS= -DWITH_ASF:BOOL=ON \
-DWITH_MP4:BOOL=ON
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
-OPTIONS= RCC "Build with RusXMMS librcc patches (experimental)" off
-
.include <bsd.port.options.mk>
-.if defined(WITH_RCC)
+.if ${PORT_OPTIONS:MRCC}
PKGNAMESUFFIX= -rcc
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-rcc
-LIB_DEPENDS+= rcc.2:${PORTSDIR}/devel/librcc
+LIB_DEPENDS+= rcc:${PORTSDIR}/devel/librcc
PLIST_SUB+= RCC=""
.else
PLIST_SUB+= RCC="@comment "
.endif
post-patch:
-.if defined(WITH_RCC)
+.if ${PORT_OPTIONS:MRCC}
@${REINPLACE_CMD} -e 's|-ltag|-ltag -lrcc|g' \
${WRKSRC}/taglib.pc.cmake ${WRKSRC}/taglib-config.cmake \
${WRKSRC}/bindings/c/taglib_c.pc.cmake