aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2005-04-04 01:31:45 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2005-04-04 01:31:45 +0000
commit0bb8b61e9baf0ecf045b1a020b62a249a739b443 (patch)
treebaf36cbe41b7fc5e1810b4bb019f1105c46c5433 /audio
parent088726d0ab44495e316453c504976a652c18525e (diff)
downloadports-0bb8b61e9baf0ecf045b1a020b62a249a739b443.tar.gz
ports-0bb8b61e9baf0ecf045b1a020b62a249a739b443.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/cpige/Makefile21
-rw-r--r--audio/cpige/distinfo2
-rw-r--r--audio/cpige/files/patch-Makefile12
-rw-r--r--audio/cpige/pkg-descr5
5 files changed, 41 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index fe5d4c990eb1..6600df201415 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -67,6 +67,7 @@
SUBDIR += cmp3
SUBDIR += cmt
SUBDIR += coverhunter
+ SUBDIR += cpige
SUBDIR += cplay
SUBDIR += crip
SUBDIR += csound
diff --git a/audio/cpige/Makefile b/audio/cpige/Makefile
new file mode 100644
index 000000000000..692c2bbe46f3
--- /dev/null
+++ b/audio/cpige/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: cpige
+# Date created: 27 March, 2005
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cpige
+PORTVERSION= 1.0
+CATEGORIES= audio
+MASTER_SITES= http://ed.zehome.com/cpige/
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Icecast/Shoutcast stream ripper
+
+PORTFILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/audio/cpige/distinfo b/audio/cpige/distinfo
new file mode 100644
index 000000000000..a5fb330491d8
--- /dev/null
+++ b/audio/cpige/distinfo
@@ -0,0 +1,2 @@
+MD5 (cpige-1.0.tar.gz) = 8e3a704adf5de6918d0606603cab66ff
+SIZE (cpige-1.0.tar.gz) = 16509
diff --git a/audio/cpige/files/patch-Makefile b/audio/cpige/files/patch-Makefile
new file mode 100644
index 000000000000..3c761ef4ffe1
--- /dev/null
+++ b/audio/cpige/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig Sun Mar 27 14:57:32 2005
++++ Makefile Sun Mar 27 14:57:58 2005
+@@ -1,6 +1,6 @@
+-CC=gcc
+-CLIBS=
+-CFLAGS=-Wall
++CC?=gcc
++CLIBS=${LDFLAGS}
++CFLAGS+=-Wall
+
+ all: debug
+ $(CC) $(CLIBS) $(CFLAGS) debug.o cpige.c -o cpige
diff --git a/audio/cpige/pkg-descr b/audio/cpige/pkg-descr
new file mode 100644
index 000000000000..f5175bdb5f1b
--- /dev/null
+++ b/audio/cpige/pkg-descr
@@ -0,0 +1,5 @@
+cPige records an audio stream, separating into individual
+"Artist - Track.mp3" files. It can also record on an
+hour-by-hour basis.
+
+WWW: http://ed.zehome.com/?page=cpige