aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorGlen Barber <gjb@FreeBSD.org>2014-04-17 03:53:32 +0000
committerGlen Barber <gjb@FreeBSD.org>2014-04-17 03:53:32 +0000
commit1742ae482c38a51398f107a964bf9eeb6ebe3f1d (patch)
treea15eb0ed160b9a66b654e50639e60748f6737070 /audio
parentc9e5403827c70cae31384b92bac7d5525232e056 (diff)
downloadports-1742ae482c38a51398f107a964bf9eeb6ebe3f1d.tar.gz
ports-1742ae482c38a51398f107a964bf9eeb6ebe3f1d.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/shout-idjc/Makefile37
-rw-r--r--audio/shout-idjc/distinfo2
-rw-r--r--audio/shout-idjc/pkg-descr3
-rw-r--r--audio/shout-idjc/pkg-plist12
5 files changed, 55 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 6885404edad6..8c489eda8877 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -665,6 +665,7 @@
SUBDIR += shntool
SUBDIR += shorten
SUBDIR += shout
+ SUBDIR += shout-idjc
SUBDIR += shoutcast
SUBDIR += sidplay
SUBDIR += sidplay2
diff --git a/audio/shout-idjc/Makefile b/audio/shout-idjc/Makefile
new file mode 100644
index 000000000000..a30f47509554
--- /dev/null
+++ b/audio/shout-idjc/Makefile
@@ -0,0 +1,37 @@
+# Created by: Sean Bruno <sbruno@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= libshout
+PORTVERSION= 2.3.1
+CATEGORIES= audio python
+MASTER_SITES= SF/idjc/libshout-idjc/
+DISTNAME= ${PORTNAME}-idjc-${PORTVERSION}
+
+MAINTAINER= sbruno@FreeBSD.org
+COMMENT= Shoutcast/Icecast Library for audio/idjc
+
+LICENSE= LGPL20
+
+LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libogg.so:${PORTSDIR}/audio/libogg \
+ libspeex.so:${PORTSDIR}/audio/speex
+
+HAS_CONFIGURE= yes
+USES= pkgconfig pathfix
+USE_LDCONFIG= yes
+
+MAKE_JOBS_UNSAFE= no
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 900000
+BROKEN= audio/shout-idjc IPv6 problem on compile in sock.c
+.endif
+
+# 10 and higer seem to be fine
+.if ${OSVERSION} < 1000000
+USE_GCC= 4.6+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/shout-idjc/distinfo b/audio/shout-idjc/distinfo
new file mode 100644
index 000000000000..24a10c256cb7
--- /dev/null
+++ b/audio/shout-idjc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libshout-idjc-2.3.1.tar.gz) = 188bed3389c43effc7427b68934f70977ce6eb505281a92d31a22deeae26ac47
+SIZE (libshout-idjc-2.3.1.tar.gz) = 454846
diff --git a/audio/shout-idjc/pkg-descr b/audio/shout-idjc/pkg-descr
new file mode 100644
index 000000000000..2c52d6a79923
--- /dev/null
+++ b/audio/shout-idjc/pkg-descr
@@ -0,0 +1,3 @@
+Shoutcast / Icecast Library for IDJC
+
+WWW: http://sourceforge.net/projects/idjc/
diff --git a/audio/shout-idjc/pkg-plist b/audio/shout-idjc/pkg-plist
new file mode 100644
index 000000000000..38715335a942
--- /dev/null
+++ b/audio/shout-idjc/pkg-plist
@@ -0,0 +1,12 @@
+include/shoutidjc/shout.h
+lib/libshout-idjc.a
+lib/libshout-idjc.la
+lib/libshout-idjc.so
+lib/libshout-idjc.so.5
+libdata/pkgconfig/shout-idjc.pc
+%%DOCSDIR%%-idjc/COPYING
+%%DOCSDIR%%-idjc/NEWS
+%%DOCSDIR%%-idjc/README
+@dirrmtry %%DOCSDIR%%-idjc
+@dirrmtry libdata/pkgconfig
+@dirrmtry include/shoutidjc