aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-12-15 16:22:17 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-12-15 16:22:17 +0000
commit1e34739b64d384b87ee2c57027df596b464c79ab (patch)
tree528f950c491cb30f26166e5e23d4b77ad233a5ee /audio
parent875909eef32afaae5809e1ed26797d44a2f7e2b1 (diff)
downloadports-1e34739b64d384b87ee2c57027df596b464c79ab.tar.gz
ports-1e34739b64d384b87ee2c57027df596b464c79ab.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/picard/Makefile1
-rw-r--r--audio/py-eyed3/Makefile10
2 files changed, 7 insertions, 4 deletions
diff --git a/audio/picard/Makefile b/audio/picard/Makefile
index c8f89738dfb2..e9f22428c258 100644
--- a/audio/picard/Makefile
+++ b/audio/picard/Makefile
@@ -45,6 +45,7 @@ RUN_DEPENDS+= metaflac:${PORTSDIR}/audio/flac \
post-patch:
@${REINPLACE_CMD} -e "s|'picard.plugins',|'picard.plugins', 'picard.plugins.lastfm', 'picard.plugins.lastfmplus', 'picard.plugins.replaygain',|" \
+ -e 's,distutils\.command\.install ,setuptools\.command\.install ,' \
${WRKSRC}/setup.py
@${CP} -R ${WRKSRC}/contrib/plugins/ ${WRKSRC}/picard/plugins
diff --git a/audio/py-eyed3/Makefile b/audio/py-eyed3/Makefile
index a166ff4eeff4..b2ae289f2603 100644
--- a/audio/py-eyed3/Makefile
+++ b/audio/py-eyed3/Makefile
@@ -12,7 +12,8 @@ MAINTAINER= rm@FreeBSD.org
COMMENT= Python module for processing ID3 tags
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:${PORTSDIR}/devel/py-setuptools
USE_PYTHON= 2.6-2.7
NO_STAGE= yes
@@ -21,7 +22,8 @@ USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ENV= PYTHON="${PYTHON_CMD}"
MAKE_ENV= SETUP_ARGS_BUILD="${PYDISTUTILS_BUILDARGS}" \
- SETUP_ARGS_INSTALL="${PYDISTUTILS_INSTALLARGS}"
+ SETUP_ARGS_INSTALL="${PYDISTUTILS_INSTALLARGS}" \
+ SETUP_COMMAND="${PYDISTUTILS_SETUP:S,",\",g}"
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
MAN1= eyeD3.1
@@ -34,8 +36,8 @@ post-patch:
${REINPLACE_CMD} -e 's,PYTHON="",,g' -e 's,/usr/local,${LOCALBASE},g' \
-e 's,2\\\.\[23456789\]\\\.,2.[23456789],g' \
${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's,\(setup.py build\),\1 $${SETUP_ARGS_BUILD},g' \
- -e 's,\(setup.py install\),\1 $${SETUP_ARGS_INSTALL} ,g' \
+ ${REINPLACE_CMD} -e 's,\(setup.py build\),$${SETUP_COMMAND} build $${SETUP_ARGS_BUILD},g' \
+ -e 's,\(setup.py install\),$${SETUP_COMMAND} install $${SETUP_ARGS_INSTALL} ,g' \
-e 's,^docdir:=.*,docdir:=${DOCSDIR},g' \
${WRKSRC}/Makefile.in
.if defined(NOPORTDOCS)