aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-08 18:47:25 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-08 18:47:56 +0000
commite27405ef0dbc3ce61bb09a4d66819461cc493347 (patch)
treeb6b4c8fc064240890298aa8dc88617a658e78031 /audio
parentd31a84713b94ab013ed1239b358d845c65a744f3 (diff)
audio/xuidesigner: New port: WYSIWYG LV2 X11UI GUI creator tool
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/xuidesigner/Makefile41
-rw-r--r--audio/xuidesigner/distinfo5
-rw-r--r--audio/xuidesigner/pkg-descr7
-rw-r--r--audio/xuidesigner/pkg-plist75
5 files changed, 129 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 8825688353be..ed2a30858e70 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -865,6 +865,7 @@
SUBDIR += xmradio
SUBDIR += xoscope
SUBDIR += xsynth-dssi
+ SUBDIR += xuidesigner
SUBDIR += xwave
SUBDIR += yell
SUBDIR += ympd
diff --git a/audio/xuidesigner/Makefile b/audio/xuidesigner/Makefile
new file mode 100644
index 000000000000..8dabeb68f8a9
--- /dev/null
+++ b/audio/xuidesigner/Makefile
@@ -0,0 +1,41 @@
+PORTNAME= xuidesigner
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.4-7
+DISTVERSIONSUFFIX= -g47715db
+CATEGORIES= audio
+#MASTER_SITES= https://github.com/brummer10/XUiDesigner/releases/download/v${DISTVERSION}/
+DISTNAME= XUIDesigner_${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= WYSIWYG LV2 X11UI GUI creator tool
+
+LICENSE= BSD0CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= xxd:editors/vim
+LIB_DEPENDS= liblilv-0.so:audio/lilv \
+ libserd-0.so:devel/serd \
+ libsord-0.so:devel/sord \
+ libsratom-0.so:audio/sratom
+
+USES= gmake gnome pkgconfig python shebangfix xorg
+USE_GNOME= cairo
+USE_XORG= x11
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= brummer10
+GH_PROJECT= XUiDesigner
+GH_TUPLE= brummer10:libxputty:d7510f6:brummer10_libxputty/libxputty
+
+SHEBANG_FILES= tools/dsp2cc
+
+BINARY_ALIAS= make=${GMAKE}
+
+post-install:
+ @cd ${STAGEDIR}${PREFIX} && \
+ ${STRIP_CMD} \
+ bin/xuidesigner \
+ lib/libxputty.so.1.0
+
+.include <bsd.port.mk>
diff --git a/audio/xuidesigner/distinfo b/audio/xuidesigner/distinfo
new file mode 100644
index 000000000000..f16cd947df85
--- /dev/null
+++ b/audio/xuidesigner/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1657305345
+SHA256 (brummer10-XUiDesigner-v0.4-7-g47715db_GH0.tar.gz) = 2e6c55c3add0cbf45e51c17f5609177513f4c04f32e6756561469eceb76d7562
+SIZE (brummer10-XUiDesigner-v0.4-7-g47715db_GH0.tar.gz) = 124064
+SHA256 (brummer10-libxputty-d7510f6_GH0.tar.gz) = 98ab0d455cc9560e83cadfe6138e908d408f766446d29335940cc83bb6f86ca4
+SIZE (brummer10-libxputty-d7510f6_GH0.tar.gz) = 548619
diff --git a/audio/xuidesigner/pkg-descr b/audio/xuidesigner/pkg-descr
new file mode 100644
index 000000000000..7b69a52efe68
--- /dev/null
+++ b/audio/xuidesigner/pkg-descr
@@ -0,0 +1,7 @@
+XUiDesigner provides a easy to use GUI generator tool to create
+X11 UI's for LV2 plugins. Currently only libxputty is supported,
+but the generated GUI C file could be used probably with other widget
+tool-kits as well, just a wrapper file is needed to translate the
+generated file to the needs of a toolkit.
+
+WWW: https://github.com/brummer10/XUiDesigner
diff --git a/audio/xuidesigner/pkg-plist b/audio/xuidesigner/pkg-plist
new file mode 100644
index 000000000000..0e47ab39d2bf
--- /dev/null
+++ b/audio/xuidesigner/pkg-plist
@@ -0,0 +1,75 @@
+bin/dsp2cc
+bin/xuidesigner
+include/xputty/b64_encode.h
+include/xputty/nanosvg.h
+include/xputty/xadjustment.h
+include/xputty/xadjustment_private.h
+include/xputty/xasprintf.h
+include/xputty/xbutton.h
+include/xputty/xbutton_private.h
+include/xputty/xchildlist.h
+include/xputty/xchildlist_private.h
+include/xputty/xcolor.h
+include/xputty/xcombobox.h
+include/xputty/xcombobox_private.h
+include/xputty/xdgmime.h
+include/xputty/xdgmimealias.h
+include/xputty/xdgmimecache.h
+include/xputty/xdgmimeglob.h
+include/xputty/xdgmimeicon.h
+include/xputty/xdgmimeint.h
+include/xputty/xdgmimemagic.h
+include/xputty/xdgmimeparent.h
+include/xputty/xdrawing_area.h
+include/xputty/xdrawing_area_private.h
+include/xputty/xfile-dialog.h
+include/xputty/xfilepicker.h
+include/xputty/xframe.h
+include/xputty/xframe_private.h
+include/xputty/xknob.h
+include/xputty/xknob_private.h
+include/xputty/xlabel.h
+include/xputty/xlabel_private.h
+include/xputty/xlistbox.h
+include/xputty/xlistbox_private.h
+include/xputty/xlistview.h
+include/xputty/xlistview_private.h
+include/xputty/xmenu.h
+include/xputty/xmenu_private.h
+include/xputty/xmessage-dialog.h
+include/xputty/xmeter.h
+include/xputty/xmeter_private.h
+include/xputty/xmidi_keyboard.h
+include/xputty/xmultilistview.h
+include/xputty/xmultilistview_private.h
+include/xputty/xplayhead.h
+include/xputty/xplayhead_private.h
+include/xputty/xpngloader.h
+include/xputty/xputty.h
+include/xputty/xresources.h
+include/xputty/xslider.h
+include/xputty/xslider_private.h
+include/xputty/xsvgloader.h
+include/xputty/xtabbox.h
+include/xputty/xtabbox_private.h
+include/xputty/xtooltip.h
+include/xputty/xtooltip_private.h
+include/xputty/xtuner.h
+include/xputty/xtuner_private.h
+include/xputty/xvaluedisplay.h
+include/xputty/xvaluedisplay_private.h
+include/xputty/xwaveview.h
+include/xputty/xwaveview_private.h
+include/xputty/xwidget.h
+include/xputty/xwidget_private.h
+include/xputty/xwidgets.h
+lib/libxputty.a
+lib/libxputty.so
+lib/libxputty.so.1
+lib/libxputty.so.1.0
+share/XUiDesigner/wrapper/libxputty/lv2_plugin.cc
+share/XUiDesigner/wrapper/libxputty/lv2_plugin.h
+share/XUiDesigner/wrapper/libxputty/ui_test.cc
+share/applications/XUiDesigner.desktop
+share/pixmaps/XUiDesigner.svg
+share/pkgconfig/xputty.pc