aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2005-02-18 23:44:49 +0000
committerKris Kennaway <kris@FreeBSD.org>2005-02-18 23:44:49 +0000
commit11ea174ccbc9cebd4134768e8fb92c6a3dc2c559 (patch)
tree1514ed7a486e108239615c1d83319d83bacdbc3d /audio
parent3ab6376b17819778c4697ee2b5cd379257644eae (diff)
downloadports-11ea174ccbc9cebd4134768e8fb92c6a3dc2c559.tar.gz
ports-11ea174ccbc9cebd4134768e8fb92c6a3dc2c559.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile2
-rw-r--r--audio/xmms-arts/Makefile34
-rw-r--r--audio/xmms-arts/distinfo2
-rw-r--r--audio/xmms-arts/files/patch-Makefile.in11
-rw-r--r--audio/xmms-arts/files/patch-init.c25
-rw-r--r--audio/xmms-arts/pkg-descr5
-rw-r--r--audio/xmms-arts/pkg-plist3
-rw-r--r--audio/xmms-arts_output/Makefile28
-rw-r--r--audio/xmms-arts_output/distinfo2
-rw-r--r--audio/xmms-arts_output/files/patch-arts_helper.c12
-rw-r--r--audio/xmms-arts_output/files/patch-configure10
-rw-r--r--audio/xmms-arts_output/pkg-descr5
12 files changed, 0 insertions, 139 deletions
diff --git a/audio/Makefile b/audio/Makefile
index ce397f77ead2..6ebdd77b6ff9 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -440,8 +440,6 @@
SUBDIR += xmixer
SUBDIR += xmmix
SUBDIR += xmms-a52dec
- SUBDIR += xmms-arts
- SUBDIR += xmms-arts_output
SUBDIR += xmms-audiofile
SUBDIR += xmms-bonk
SUBDIR += xmms-cdparanoia
diff --git a/audio/xmms-arts/Makefile b/audio/xmms-arts/Makefile
deleted file mode 100644
index 1a602cf47b9c..000000000000
--- a/audio/xmms-arts/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-# New ports collection makefile for: xmms-arts
-# Date created: 12 Nov 2003
-# Whom: Max Khon <fjoe@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= xmms-arts
-PORTVERSION= 0.4
-PORTREVISION= 3
-CATEGORIES= audio
-MASTER_SITES= http://stukach.com/hosted/m.i.a/xmmsarts/
-DISTNAME= ${PORTNAME:S/-//}-${PORTVERSION}
-
-MAINTAINER= fjoe@FreeBSD.org
-COMMENT= aRts output plugin for XMMS.
-
-LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
- artsc.0:${PORTSDIR}/audio/arts
-
-USE_X_PREFIX= yes
-USE_BZIP2= yes
-USE_GNOME= gtk12
-USE_LIBTOOL_VER= 13
-INSTALLS_SHLIB= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${X11BASE}/include"
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
-IGNORE= will not work until xmms and arts will use the same glib version. Use xmms-arts_output port instead
-EXPIRATION_DATE=2005-02-18
-DEPRECATED= "${IGNORE}"
-
-.include <bsd.port.mk>
diff --git a/audio/xmms-arts/distinfo b/audio/xmms-arts/distinfo
deleted file mode 100644
index 1c51f5bc1b9e..000000000000
--- a/audio/xmms-arts/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (xmmsarts-0.4.tar.bz2) = 1e38bf93f7d2fac6dcdb681f6538491a
-SIZE (xmmsarts-0.4.tar.bz2) = 94742
diff --git a/audio/xmms-arts/files/patch-Makefile.in b/audio/xmms-arts/files/patch-Makefile.in
deleted file mode 100644
index 7010541fe805..000000000000
--- a/audio/xmms-arts/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Tue Nov 25 06:37:11 2003
-+++ Makefile.in Tue Nov 25 06:37:19 2003
-@@ -83,7 +83,7 @@
- lib_LTLIBRARIES = libartsout.la
- CFLAGS = @CFLAGS@ @GTK_CFLAGS@ `artsc-config --cflags`
- LIBS = @LIBS@ @GTK_LIBS@ @PTHREAD_LIBS@
--libartsout_la_LDFLAGS = `artsc-config --libs` -lcmallocc
-+libartsout_la_LDFLAGS = `artsc-config --libs`
- libartsout_la_SOURCES = about.c artsout.c artsout.h audio.c configure.c init.c mixer.c
- libdir = $(xmms_output_plugin_dir)
- XMMSPATH = $(XMMS_PATH)
diff --git a/audio/xmms-arts/files/patch-init.c b/audio/xmms-arts/files/patch-init.c
deleted file mode 100644
index 564b289eaa59..000000000000
--- a/audio/xmms-arts/files/patch-init.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- init.c.orig Fri Sep 1 10:35:03 2000
-+++ init.c Thu Feb 5 02:53:58 2004
-@@ -20,6 +20,7 @@
- */
-
- #include "artsout.h"
-+#include <dlfcn.h>
-
- aRtsConfig arts_cfg;
-
-@@ -39,4 +40,14 @@
- xmms_cfg_read_int(cfgfile, "aRts", "prebuffer", &arts_cfg.prebuffer);
- xmms_cfg_free(cfgfile);
- }
-+
-+ /*
-+ * This is a hack to prevent unloading of libstdc++
-+ * (required by arts libraries) in arts_free() but before
-+ * this thread is terminated. libstdc++ registers thread cleanup
-+ * handler and xmms crashes when this cleanup function is called
-+ * on thread termination.
-+ */
-+ if (dlopen("libstdc++.so", RTLD_NOW | RTLD_GLOBAL) == NULL)
-+ fprintf(stderr, "Failed to preload libstdc++.so\n");
- }
diff --git a/audio/xmms-arts/pkg-descr b/audio/xmms-arts/pkg-descr
deleted file mode 100644
index 54934fd6d426..000000000000
--- a/audio/xmms-arts/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-aRts output plugin for XMMS (www.xmms.org).
-
-Author: Heath Robinson <bheathr@mail.com>
-
-WWW: http://www.xmms.org/plugins.php?category=output
diff --git a/audio/xmms-arts/pkg-plist b/audio/xmms-arts/pkg-plist
deleted file mode 100644
index bf187fae6e3a..000000000000
--- a/audio/xmms-arts/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-lib/xmms/Output/libartsout.a
-lib/xmms/Output/libartsout.so
-lib/xmms/Output/libartsout.so.0
diff --git a/audio/xmms-arts_output/Makefile b/audio/xmms-arts_output/Makefile
deleted file mode 100644
index f3302abdf560..000000000000
--- a/audio/xmms-arts_output/Makefile
+++ /dev/null
@@ -1,28 +0,0 @@
-# New ports collection makefile for: xmms-arts_output
-# Date created: 12 Nov 2003
-# Whom: Max Khon <fjoe@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PKGNAMEPREFIX= xmms-
-PORTNAME= arts_output
-PORTVERSION= 0.7.1
-CATEGORIES= audio
-MASTER_SITES= http://havardk.xmms.org/plugins/arts_output/
-
-MAINTAINER= fjoe@FreeBSD.org
-COMMENT= aRts output plugin for XMMS.
-
-LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
- artsc.0:${PORTSDIR}/audio/arts
-
-USE_X_PREFIX= yes
-USE_GNOME= gtk12
-USE_INC_LIBTOOL_VER= 13
-INSTALLS_SHLIB= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-PLIST_FILES= lib/xmms/Output/libarts.so \
- bin/xmms-arts-helper
-
-.include <bsd.port.mk>
diff --git a/audio/xmms-arts_output/distinfo b/audio/xmms-arts_output/distinfo
deleted file mode 100644
index 2f07b6762341..000000000000
--- a/audio/xmms-arts_output/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (arts_output-0.7.1.tar.gz) = 6d028255ed86e37211bbda0122c14483
-SIZE (arts_output-0.7.1.tar.gz) = 236839
diff --git a/audio/xmms-arts_output/files/patch-arts_helper.c b/audio/xmms-arts_output/files/patch-arts_helper.c
deleted file mode 100644
index f01133c9e5bd..000000000000
--- a/audio/xmms-arts_output/files/patch-arts_helper.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- arts_helper.c.orig Tue Apr 6 02:23:37 2004
-+++ arts_helper.c Tue Apr 6 02:22:32 2004
-@@ -243,7 +243,9 @@
- {
- going = 0;
- arts_close_stream(handle);
-+#if 0
- arts_free();
-+#endif
- }
-
- static int read_all(int fd, void *buf, size_t count)
diff --git a/audio/xmms-arts_output/files/patch-configure b/audio/xmms-arts_output/files/patch-configure
deleted file mode 100644
index 1eb3cd980633..000000000000
--- a/audio/xmms-arts_output/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Thu Aug 21 14:43:13 2003
-+++ configure Thu Feb 5 03:08:04 2004
-@@ -7820,6 +7820,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/xmms-arts_output/pkg-descr b/audio/xmms-arts_output/pkg-descr
deleted file mode 100644
index 437391976a66..000000000000
--- a/audio/xmms-arts_output/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-aRts output plugin for XMMS (www.xmms.org).
-
-Author: Håvard Kvålen <havardk@xmms.org>
-
-WWW: http://www.xmms.org/plugins.php?category=output