aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-09-18 19:32:50 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-09-18 19:32:50 +0000
commit4635720dc75cbe6d28189767fb6281e928928878 (patch)
tree141dccc518062e709db8f1f0bb86df359abb6bec /audio
parentc7acb4aa306c1b324ba8429d0ec5c4fbd80b36d8 (diff)
downloadports-4635720dc75cbe6d28189767fb6281e928928878.tar.gz
ports-4635720dc75cbe6d28189767fb6281e928928878.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/sox/Makefile62
-rw-r--r--audio/sox/distinfo6
-rw-r--r--audio/sox/files/patch-configure11
-rw-r--r--audio/sox/files/patch-formats.c16
-rw-r--r--audio/sox/pkg-plist186
5 files changed, 39 insertions, 242 deletions
diff --git a/audio/sox/Makefile b/audio/sox/Makefile
index 7ad5b93b401b..0333cf7be4d1 100644
--- a/audio/sox/Makefile
+++ b/audio/sox/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sox
-PORTVERSION= 14.2.0
-PORTREVISION= 2
+PORTVERSION= 14.3.0
CATEGORIES= audio
MASTER_SITES= SF
@@ -25,6 +24,7 @@ USE_LDCONFIG= yes
USE_AUTOTOOLS= libltdl
USE_GNOME= pkgconfig
+# Default LAME to off for packages so we don't end up RESTRICTED
.if defined(PACKAGE_BUILDING)
_LAME= off
.else
@@ -37,11 +37,11 @@ OPTIONS= AO "Enable libao output" on \
FFMPEG "Enable ffmpeg en/decoding" on \
FLAC "Enable flac en/decoding with libflac" on \
GSM "Use libgsm from ports (else use bundled lib)" on \
+ ID3TAG "Enable mp3 tagging with libid3tag" on \
LADSPA "Audio plugin support" off \
LAME "Enable mp3 encoding with LAME" ${_LAME} \
MAD "Enable mp3 decoding with MAD" on \
PNG "Enable PNG spectrogram creation" on \
- SAMPLERATE "Enable libsamplerate" on \
SNDFILE "Enable libsndfile" on \
VORBIS "Enable Ogg Vorbis support" on \
WAVPACK "Enable Wavpack support" off
@@ -52,65 +52,48 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS+= --with-pkgconfigdir="${PREFIX}/libdata/pkgconfig"
-
-.if !defined(WITH_LAME) && !defined(WITH_MAD)
-PLIST_SUB+= PLIST_MP3="@comment "
-.else
-PLIST_SUB+= PLIST_MP3=""
-.endif
+CONFIGURE_ARGS+= --with-distro="${CONFIGURE_TARGET} ${PKGNAME}"
.if defined(WITH_AO)
-CONFIGURE_ARGS+= --enable-libao
+CONFIGURE_ARGS+= --with-ao
LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
-PLIST_SUB+= PLIST_AO=""
.else
-CONFIGURE_ARGS+= --disable-libao
-PLIST_SUB+= PLIST_AO="@comment "
+CONFIGURE_ARGS+= --without-ao
.endif
.if defined(WITH_AMRNB)
-CONFIGURE_ARGS+= --with-amr-nb
+CONFIGURE_ARGS+= --with-amrnb
LIB_DEPENDS+= amrnb.3:${PORTSDIR}/audio/libamrnb
-PLIST_SUB+= PLIST_AMRNB=""
.else
-CONFIGURE_ARGS+= --without-amr-nb
-PLIST_SUB+= PLIST_AMRNB="@comment "
+CONFIGURE_ARGS+= --without-amrnb
.endif
.if defined(WITH_AMRWB)
-CONFIGURE_ARGS+= --with-amr-wb
+CONFIGURE_ARGS+= --with-amrwb
LIB_DEPENDS+= amrwb.3:${PORTSDIR}/audio/libamrwb
-PLIST_SUB+= PLIST_AMRWB=""
.else
-CONFIGURE_ARGS+= --without-amr-wb
-PLIST_SUB+= PLIST_AMRWB="@comment "
+CONFIGURE_ARGS+= --without-amrwb
.endif
.if defined(WITH_FFMPEG)
CONFIGURE_ARGS+= --with-ffmpeg
LIB_DEPENDS+= avformat:${PORTSDIR}/multimedia/ffmpeg
-PLIST_SUB+= PLIST_FFMPEG=""
.else
CONFIGURE_ARGS+= --without-ffmpeg
-PLIST_SUB+= PLIST_FFMPEG="@comment "
.endif
.if defined(WITH_VORBIS)
-CONFIGURE_ARGS+= --with-ogg
+CONFIGURE_ARGS+= --with-oggvorbis
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
-PLIST_SUB+= PLIST_VORBIS=""
.else
-CONFIGURE_ARGS+= --without-ogg
-PLIST_SUB+= PLIST_VORBIS="@comment "
+CONFIGURE_ARGS+= --without-oggvorbis
.endif
.if defined(WITH_SNDFILE)
CONFIGURE_ARGS+= --with-sndfile
LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
-PLIST_SUB+= PLIST_SNDFILE=""
.else
CONFIGURE_ARGS+= --without-sndfile
-PLIST_SUB+= PLIST_SNDFILE="@comment "
.endif
.if defined(WITH_LADSPA)
@@ -131,10 +114,8 @@ CONFIGURE_ARGS+= --without-lame
.if defined(WITH_FLAC)
CONFIGURE_ARGS+= --with-flac
LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
-PLIST_SUB+= PLIST_FLAC=""
.else
CONFIGURE_ARGS+= --without-flac
-PLIST_SUB+= PLIST_FLAC="@comment "
.endif
.if defined(WITH_MAD)
@@ -152,30 +133,27 @@ CONFIGURE_ARGS+= --without-png
.endif
.if defined(WITH_GSM)
-CONFIGURE_ARGS+= --with-external-gsm
+CONFIGURE_ARGS+= --with-gsm
LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
-PLIST_SUB+= PLIST_GSM=""
.else
-CONFIGURE_ARGS+= --without-external-gsm
-# Above configure flag does not exist, so workaround with the below line
+CONFIGURE_ARGS+= --with-gsm
+# We cannot ask for gsm to be enabled without it trying to use external gsm,
+# so workaround with the below line
CONFIGURE_ENV+= ac_cv_header_gsm_h=no
-PLIST_SUB+= PLIST_GSM="@comment "
.endif
-.if defined(WITH_SAMPLERATE)
-CONFIGURE_ARGS+= --with-samplerate
-LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
+.if defined(WITH_ID3TAG)
+CONFIGURE_ARGS+= --with-id3tag
+LIB_DEPENDS+= id3tag.0:${PORTSDIR}/audio/libid3tag
.else
-CONFIGURE_ARGS+= --without-samplerate
+CONFIGURE_ARGS+= --without-id3tag
.endif
.if defined(WITH_WAVPACK)
CONFIGURE_ARGS+= --with-wavpack
LIB_DEPENDS+= wavpack.1:${PORTSDIR}/audio/wavpack
-PLIST_SUB+= PLIST_WAVPACK=""
.else
CONFIGURE_ARGS+= --without-wavpack
-PLIST_SUB+= PLIST_WAVPACK="@comment "
.endif
# Tell configure that libgsm's headers are in $LOCALDIR/include
diff --git a/audio/sox/distinfo b/audio/sox/distinfo
index 8de5a25f365c..934ccb6a10d0 100644
--- a/audio/sox/distinfo
+++ b/audio/sox/distinfo
@@ -1,3 +1,3 @@
-MD5 (sox-14.2.0.tar.gz) = 7afc0e85d14be014f08e7d3b7ee8c24e
-SHA256 (sox-14.2.0.tar.gz) = 8d1b8eb33a72a181369475c9da5fdcbe5f6820e6af3d86a0e84f6939e61a9dc1
-SIZE (sox-14.2.0.tar.gz) = 964800
+MD5 (sox-14.3.0.tar.gz) = 8e3509804e6227273ef84092e1a2fea7
+SHA256 (sox-14.3.0.tar.gz) = 9abf411c949366d75c884b368284690b6c8c7d5fb5df0deaf599539b704b2397
+SIZE (sox-14.3.0.tar.gz) = 1007679
diff --git a/audio/sox/files/patch-configure b/audio/sox/files/patch-configure
deleted file mode 100644
index d9c79cf07b27..000000000000
--- a/audio/sox/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2009-02-14 19:08:53.000000000 +0100
-+++ configure 2009-02-14 19:09:06.000000000 +0100
-@@ -20805,7 +20805,7 @@
-
-
-
--if test -r /etc/issue; then
-+if false && test -r /etc/issue; then
- { $as_echo "$as_me:$LINENO: checking distro name" >&5
- $as_echo_n "checking distro name... " >&6; }
- DISTRO=`sed -e "s/.0-90-9;*mJH//g" < /etc/issue|tr "\n" " " | sed -e "s/(\\\\?\\\\\\\\.*//" -e "s/ */ /g" -e "s/^ //" -e "s/ $//"`
diff --git a/audio/sox/files/patch-formats.c b/audio/sox/files/patch-formats.c
new file mode 100644
index 000000000000..38e5426e491d
--- /dev/null
+++ b/audio/sox/files/patch-formats.c
@@ -0,0 +1,16 @@
+Generalize the "rewind on pipes" hack to work with all Torek-based stdio's
+without having to check for each one. Fix will appear in the next release.
+
+http://sourceforge.net/tracker/index.php?func=detail&aid=2847998&group_id=10706&atid=310706
+
+--- src/formats.c 2009-06-14 20:14:53.000000000 -0500
++++ src/formats.c 2009-08-31 13:16:21.440822225 -0500
+@@ -392,7 +392,7 @@
+ * Works by resetting the FILE buffer pointer */
+ static void UNUSED rewind_pipe(FILE * fp)
+ {
+-#if defined _NEWLIB_VERSION || defined __APPLE__
++#if defined _FSTDIO /* Torek stdio (i.e. most BSD-derived libc's) */
+ fp->_p -= AUTO_DETECT_SIZE;
+ fp->_r += AUTO_DETECT_SIZE;
+ #elif defined __GLIBC__
diff --git a/audio/sox/pkg-plist b/audio/sox/pkg-plist
index 3f11cde16fc3..bdc66f58b297 100644
--- a/audio/sox/pkg-plist
+++ b/audio/sox/pkg-plist
@@ -9,191 +9,5 @@ lib/libsox.a
lib/libsox.la
lib/libsox.so
lib/libsox.so.1
-lib/sox/libsox_fmt_aifc.a
-lib/sox/libsox_fmt_aifc.la
-lib/sox/libsox_fmt_aifc.so
-lib/sox/libsox_fmt_aiff.a
-lib/sox/libsox_fmt_aiff.la
-lib/sox/libsox_fmt_aiff.so
-lib/sox/libsox_fmt_al.a
-lib/sox/libsox_fmt_al.la
-lib/sox/libsox_fmt_al.so
-%%PLIST_AMRNB%%lib/sox/libsox_fmt_amr_nb.a
-%%PLIST_AMRNB%%lib/sox/libsox_fmt_amr_nb.la
-%%PLIST_AMRNB%%lib/sox/libsox_fmt_amr_nb.so
-%%PLIST_AMRWB%%lib/sox/libsox_fmt_amr_wb.a
-%%PLIST_AMRWB%%lib/sox/libsox_fmt_amr_wb.la
-%%PLIST_AMRWB%%lib/sox/libsox_fmt_amr_wb.so
-%%PLIST_AO%%lib/sox/libsox_fmt_ao.a
-%%PLIST_AO%%lib/sox/libsox_fmt_ao.la
-%%PLIST_AO%%lib/sox/libsox_fmt_ao.so
-lib/sox/libsox_fmt_au.a
-lib/sox/libsox_fmt_au.la
-lib/sox/libsox_fmt_au.so
-lib/sox/libsox_fmt_avr.a
-lib/sox/libsox_fmt_avr.la
-lib/sox/libsox_fmt_avr.so
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_caf.a
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_caf.la
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_caf.so
-lib/sox/libsox_fmt_cdr.a
-lib/sox/libsox_fmt_cdr.la
-lib/sox/libsox_fmt_cdr.so
-lib/sox/libsox_fmt_cvsd.a
-lib/sox/libsox_fmt_cvsd.la
-lib/sox/libsox_fmt_cvsd.so
-lib/sox/libsox_fmt_dat.a
-lib/sox/libsox_fmt_dat.la
-lib/sox/libsox_fmt_dat.so
-lib/sox/libsox_fmt_dvms.a
-lib/sox/libsox_fmt_dvms.la
-lib/sox/libsox_fmt_dvms.so
-lib/sox/libsox_fmt_f4.a
-lib/sox/libsox_fmt_f4.la
-lib/sox/libsox_fmt_f4.so
-lib/sox/libsox_fmt_f8.a
-lib/sox/libsox_fmt_f8.la
-lib/sox/libsox_fmt_f8.so
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_fap.a
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_fap.la
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_fap.so
-%%PLIST_FFMPEG%%lib/sox/libsox_fmt_ffmpeg.a
-%%PLIST_FFMPEG%%lib/sox/libsox_fmt_ffmpeg.la
-%%PLIST_FFMPEG%%lib/sox/libsox_fmt_ffmpeg.so
-%%PLIST_FLAC%%lib/sox/libsox_fmt_flac.a
-%%PLIST_FLAC%%lib/sox/libsox_fmt_flac.la
-%%PLIST_FLAC%%lib/sox/libsox_fmt_flac.so
-lib/sox/libsox_fmt_gsm.a
-lib/sox/libsox_fmt_gsm.la
-lib/sox/libsox_fmt_gsm.so
-lib/sox/libsox_fmt_hcom.a
-lib/sox/libsox_fmt_hcom.la
-lib/sox/libsox_fmt_hcom.so
-lib/sox/libsox_fmt_htk.a
-lib/sox/libsox_fmt_htk.la
-lib/sox/libsox_fmt_htk.so
-lib/sox/libsox_fmt_ima.a
-lib/sox/libsox_fmt_ima.la
-lib/sox/libsox_fmt_ima.so
-lib/sox/libsox_fmt_la.a
-lib/sox/libsox_fmt_la.la
-lib/sox/libsox_fmt_la.so
-lib/sox/libsox_fmt_lpc10.a
-lib/sox/libsox_fmt_lpc10.la
-lib/sox/libsox_fmt_lpc10.so
-lib/sox/libsox_fmt_lu.a
-lib/sox/libsox_fmt_lu.la
-lib/sox/libsox_fmt_lu.so
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_mat4.a
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_mat4.la
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_mat4.so
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_mat5.a
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_mat5.la
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_mat5.so
-lib/sox/libsox_fmt_maud.a
-lib/sox/libsox_fmt_maud.la
-lib/sox/libsox_fmt_maud.so
-%%PLIST_MP3%%lib/sox/libsox_fmt_mp3.a
-%%PLIST_MP3%%lib/sox/libsox_fmt_mp3.la
-%%PLIST_MP3%%lib/sox/libsox_fmt_mp3.so
-lib/sox/libsox_fmt_nul.a
-lib/sox/libsox_fmt_nul.la
-lib/sox/libsox_fmt_nul.so
-lib/sox/libsox_fmt_oss.a
-lib/sox/libsox_fmt_oss.la
-lib/sox/libsox_fmt_oss.so
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_paf.a
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_paf.la
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_paf.so
-lib/sox/libsox_fmt_prc.a
-lib/sox/libsox_fmt_prc.la
-lib/sox/libsox_fmt_prc.so
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_pvf.a
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_pvf.la
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_pvf.so
-lib/sox/libsox_fmt_raw.a
-lib/sox/libsox_fmt_raw.la
-lib/sox/libsox_fmt_raw.so
-lib/sox/libsox_fmt_s1.a
-lib/sox/libsox_fmt_s1.la
-lib/sox/libsox_fmt_s1.so
-lib/sox/libsox_fmt_s2.a
-lib/sox/libsox_fmt_s2.la
-lib/sox/libsox_fmt_s2.so
-lib/sox/libsox_fmt_s3.a
-lib/sox/libsox_fmt_s3.la
-lib/sox/libsox_fmt_s3.so
-lib/sox/libsox_fmt_s4.a
-lib/sox/libsox_fmt_s4.la
-lib/sox/libsox_fmt_s4.so
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sd2.a
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sd2.la
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sd2.so
-lib/sox/libsox_fmt_sf.a
-lib/sox/libsox_fmt_sf.la
-lib/sox/libsox_fmt_sf.so
-lib/sox/libsox_fmt_smp.a
-lib/sox/libsox_fmt_smp.la
-lib/sox/libsox_fmt_smp.so
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sndfile.a
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sndfile.la
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sndfile.so
-lib/sox/libsox_fmt_sounder.a
-lib/sox/libsox_fmt_sounder.la
-lib/sox/libsox_fmt_sounder.so
-lib/sox/libsox_fmt_soundtool.a
-lib/sox/libsox_fmt_soundtool.la
-lib/sox/libsox_fmt_soundtool.so
-lib/sox/libsox_fmt_sphere.a
-lib/sox/libsox_fmt_sphere.la
-lib/sox/libsox_fmt_sphere.so
-lib/sox/libsox_fmt_svx.a
-lib/sox/libsox_fmt_svx.la
-lib/sox/libsox_fmt_svx.so
-lib/sox/libsox_fmt_txw.a
-lib/sox/libsox_fmt_txw.la
-lib/sox/libsox_fmt_txw.so
-lib/sox/libsox_fmt_u1.a
-lib/sox/libsox_fmt_u1.la
-lib/sox/libsox_fmt_u1.so
-lib/sox/libsox_fmt_u2.a
-lib/sox/libsox_fmt_u2.la
-lib/sox/libsox_fmt_u2.so
-lib/sox/libsox_fmt_u3.a
-lib/sox/libsox_fmt_u3.la
-lib/sox/libsox_fmt_u3.so
-lib/sox/libsox_fmt_u4.a
-lib/sox/libsox_fmt_u4.la
-lib/sox/libsox_fmt_u4.so
-lib/sox/libsox_fmt_ul.a
-lib/sox/libsox_fmt_ul.la
-lib/sox/libsox_fmt_ul.so
-lib/sox/libsox_fmt_voc.a
-lib/sox/libsox_fmt_voc.la
-lib/sox/libsox_fmt_voc.so
-%%PLIST_VORBIS%%lib/sox/libsox_fmt_vorbis.a
-%%PLIST_VORBIS%%lib/sox/libsox_fmt_vorbis.la
-%%PLIST_VORBIS%%lib/sox/libsox_fmt_vorbis.so
-lib/sox/libsox_fmt_vox.a
-lib/sox/libsox_fmt_vox.la
-lib/sox/libsox_fmt_vox.so
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_w64.a
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_w64.la
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_w64.so
-lib/sox/libsox_fmt_wav.a
-lib/sox/libsox_fmt_wav.la
-lib/sox/libsox_fmt_wav.so
-%%PLIST_WAVPACK%%lib/sox/libsox_fmt_wavpack.a
-%%PLIST_WAVPACK%%lib/sox/libsox_fmt_wavpack.la
-%%PLIST_WAVPACK%%lib/sox/libsox_fmt_wavpack.so
-lib/sox/libsox_fmt_wve.a
-lib/sox/libsox_fmt_wve.la
-lib/sox/libsox_fmt_wve.so
-lib/sox/libsox_fmt_xa.a
-lib/sox/libsox_fmt_xa.la
-lib/sox/libsox_fmt_xa.so
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_xi.a
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_xi.la
-%%PLIST_SNDFILE%%lib/sox/libsox_fmt_xi.so
@dirrm lib/sox
libdata/pkgconfig/sox.pc