aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2019-09-23 20:25:38 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2019-09-23 20:25:38 +0000
commit49460ab732bdc403c151e5fd397c7d4019192de9 (patch)
tree0e8a268af61b374bf92d816d49462b132dceecaa /audio
parentb609c33b772de42607b5b9c4e4d89fc5ac55ba19 (diff)
downloadports-49460ab732bdc403c151e5fd397c7d4019192de9.tar.gz
ports-49460ab732bdc403c151e5fd397c7d4019192de9.zip
Three plugins used C89 inline semantics, which resulted in unresolved
symbols with C99 compilers. PR: 239128 Reported by: Marcel Bonnet While here, portlint. Grab back maintainership.
Notes
Notes: svn path=/head/; revision=512672
Diffstat (limited to 'audio')
-rw-r--r--audio/swhplugins/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/audio/swhplugins/Makefile b/audio/swhplugins/Makefile
index 98d40e45d7bb..83e281b1df50 100644
--- a/audio/swhplugins/Makefile
+++ b/audio/swhplugins/Makefile
@@ -3,28 +3,31 @@
PORTNAME= swhplugins
PORTVERSION= 0.4.15
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= audio
MASTER_SITES= http://plugin.org.uk/releases/${PORTVERSION}/
DISTNAME= swh-plugins-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= arved@FreeBSD.org
COMMENT= Steve Harris' huge Collection of LADSPA Plugins
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:audio/ladspa \
${LOCALBASE}/include/fftw3.h:math/fftw3
LIB_DEPENDS= libfftw3f.so:math/fftw3-float
# includes assembler code
-ONLY_FOR_ARCHS= i386 amd64
-
+ONLY_FOR_ARCHS= amd64 i386
USES= gmake libtool pkgconfig
+
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-CFLAGS+= -fPIC -DPIC
+CFLAGS+= -fPIC -DPIC -fgnu89-inline
OPTIONS_DEFINE= NLS 3DNOW SSE
OPTIONS_SUB= yes