aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-09-15 16:15:03 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-09-15 16:15:03 +0000
commit7450130c23cfe76519be8bad69274566c64dc091 (patch)
tree69a47a0deddbe62e2e3ad4aaf3ead6dba659dd3c /audio
parentc39f83e9c817fab023ee3f2d2dba952535e3ab80 (diff)
downloadports-7450130c23cfe76519be8bad69274566c64dc091.tar.gz
ports-7450130c23cfe76519be8bad69274566c64dc091.zip
audio/pulseaudio: update to 13.0
- Connect tests to the framework Changes: https://www.freedesktop.org/wiki/Software/PulseAudio/Notes/13.0/ ABI: https://abi-laboratory.pro/tracker/timeline/pulseaudio/ PR: 240585 Submitted by: lightside@gmx.com
Notes
Notes: svn path=/head/; revision=512113
Diffstat (limited to 'audio')
-rw-r--r--audio/pulseaudio/Makefile17
-rw-r--r--audio/pulseaudio/distinfo6
-rw-r--r--audio/pulseaudio/files/patch-src_pulsecore_atomic.h13
-rw-r--r--audio/pulseaudio/files/patch-src_tests_atomic-test.c14
-rw-r--r--audio/pulseaudio/pkg-plist17
5 files changed, 53 insertions, 14 deletions
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index 795022639b7c..02db0a35d6ae 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -5,8 +5,7 @@
# PORTREVISION bumps of depending ports.
PORTNAME= pulseaudio
-PORTVERSION= 12.2
-PORTREVISION= 6
+PORTVERSION= 13.0
CATEGORIES= audio
MASTER_SITES= http://freedesktop.org/software/pulseaudio/releases/
@@ -16,6 +15,7 @@ COMMENT= Sound server for UNIX
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LGPL
+BUILD_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser
LIB_DEPENDS= libsndfile.so:audio/libsndfile \
libfftw3.so:math/fftw3 \
libfftw3f.so:math/fftw3-float \
@@ -26,7 +26,7 @@ LIB_DEPENDS= libsndfile.so:audio/libsndfile \
USES= compiler:c11 cpe gettext gmake gnome iconv libtool \
pathfix pkgconfig python:run shebangfix ssl tar:xz
-USE_GNOME= glib20 intltool
+USE_GNOME= glib20
USE_XORG= ice sm x11 xcb xtst
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -40,6 +40,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
SHEBANG_FILES= shell-completion/bash/pulseaudio \
+ src/utils/pa-info \
src/utils/qpaeq
bash_CMD= ${SETENV} bash
SUB_FILES= pkg-message
@@ -59,7 +60,7 @@ USERS= pulse
GROUPS= pulse pulse-access pulse-rt
OPTIONS_SUB= yes
-OPTIONS_DEFINE= AVAHI GCONF GSETTINGS SIMD
+OPTIONS_DEFINE= AVAHI GCONF GSETTINGS SIMD TEST
OPTIONS_DEFAULT=AVAHI SIMD SIMPLE SOXR SPEEX WEBRTC_AEC
AVAHI_CONFIGURE_ENABLE= avahi
AVAHI_LIB_DEPENDS= libavahi-client.so:net/avahi-app
@@ -70,6 +71,9 @@ GSETTINGS_CONFIGURE_ENABLE= gsettings
GSETTINGS_VARS= GLIB_SCHEMAS=org.freedesktop.pulseaudio.gschema.xml
SIMD_CONFIGURE_ENABLE= orc
SIMD_LIB_DEPENDS= liborc-0.4.so:devel/orc
+TEST_TEST_TARGET= check
+TEST_CONFIGURE_ENABLE= default-build-tests
+TEST_BUILD_DEPENDS= check>0:devel/check
OPTIONS_GROUP= AUDIO
OPTIONS_GROUP_AUDIO= ALSA JACK SOXR SPEEX WEBRTC_AEC
@@ -105,9 +109,14 @@ PLIST_SUB= PULSE_VERSION=${PULSE_VERSION}
post-patch:
@${REINPLACE_CMD} -e 's|/usr/share|${LOCALBASE}/share|g' \
${WRKSRC}/src/daemon/default.pa.in
+ @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g' \
+ -e 's|--directory|-d|g' \
+ ${WRKSRC}/src/utils/pa-info
@${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
+pre-install-TEST-on: do-test
+
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/pulse
.for ii in default.pa daemon.conf client.conf system.pa
diff --git a/audio/pulseaudio/distinfo b/audio/pulseaudio/distinfo
index 2a0b285e5b03..94d6e430289a 100644
--- a/audio/pulseaudio/distinfo
+++ b/audio/pulseaudio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1531753054
-SHA256 (pulseaudio-12.2.tar.xz) = 809668ffc296043779c984f53461c2b3987a45b7a25eb2f0a1d11d9f23ba4055
-SIZE (pulseaudio-12.2.tar.xz) = 1665092
+TIMESTAMP = 1568380928
+SHA256 (pulseaudio-13.0.tar.xz) = 961b23ca1acfd28f2bc87414c27bb40e12436efcf2158d29721b1e89f3f28057
+SIZE (pulseaudio-13.0.tar.xz) = 1901768
diff --git a/audio/pulseaudio/files/patch-src_pulsecore_atomic.h b/audio/pulseaudio/files/patch-src_pulsecore_atomic.h
index ed042d9c227c..342b1568af0c 100644
--- a/audio/pulseaudio/files/patch-src_pulsecore_atomic.h
+++ b/audio/pulseaudio/files/patch-src_pulsecore_atomic.h
@@ -1,6 +1,15 @@
---- src/pulsecore/atomic.h.orig 2016-08-23 12:50:11 UTC
+--- src/pulsecore/atomic.h.orig 2019-09-13 13:10:23 UTC
+++ src/pulsecore/atomic.h
-@@ -185,39 +185,6 @@ static inline bool pa_atomic_ptr_cmpxchg
+@@ -117,7 +117,7 @@ static inline void* pa_atomic_ptr_load(c
+ }
+
+ static inline void pa_atomic_ptr_store(pa_atomic_ptr_t *a, void* p) {
+- __atomic_store_n(&a->value, p, __ATOMIC_SEQ_CST);
++ __atomic_store_n(&a->value, (uintptr_t)p, __ATOMIC_SEQ_CST);
+ }
+
+ #else
+@@ -218,39 +218,6 @@ static inline bool pa_atomic_ptr_cmpxchg
#include <sys/param.h>
#include <machine/atomic.h>
diff --git a/audio/pulseaudio/files/patch-src_tests_atomic-test.c b/audio/pulseaudio/files/patch-src_tests_atomic-test.c
new file mode 100644
index 000000000000..bc194e7ffe99
--- /dev/null
+++ b/audio/pulseaudio/files/patch-src_tests_atomic-test.c
@@ -0,0 +1,14 @@
+--- src/tests/atomic-test.c.orig 2019-09-13 13:10:23 UTC
++++ src/tests/atomic-test.c
+@@ -51,6 +51,11 @@
+
+ #define MEMORY_SIZE (8 * 2 * 1024 * 1024)
+
++#ifdef __FreeBSD__
++#include <sys/cpuset.h>
++#define cpu_set_t cpuset_t
++#endif
++
+
+ typedef struct io_t {
+ pa_atomic_t *flag;
diff --git a/audio/pulseaudio/pkg-plist b/audio/pulseaudio/pkg-plist
index 037269b92a62..284cba2ab33f 100644
--- a/audio/pulseaudio/pkg-plist
+++ b/audio/pulseaudio/pkg-plist
@@ -1,3 +1,4 @@
+bin/pa-info
bin/pacat
bin/pacmd
bin/pactl
@@ -68,7 +69,7 @@ lib/libpulse-simple.so.0
lib/libpulse-simple.so.0.1.1
lib/libpulse.so
lib/libpulse.so.0
-lib/libpulse.so.0.20.3
+lib/libpulse.so.0.21.1
%%AVAHI%%lib/pulse-%%PULSE_VERSION%%/modules/libavahi-wrap.so
lib/pulse-%%PULSE_VERSION%%/modules/module-allow-passthrough.so
lib/pulse-%%PULSE_VERSION%%/modules/module-device-manager.so
@@ -215,9 +216,12 @@ man/man5/pulse-daemon.conf.5.gz
%%ALSA%%share/pulseaudio/alsa-mixer/paths/hdmi-output-7.conf
%%ALSA%%share/pulseaudio/alsa-mixer/paths/iec958-stereo-input.conf
%%ALSA%%share/pulseaudio/alsa-mixer/paths/iec958-stereo-output.conf
-%%ALSA%%share/pulseaudio/alsa-mixer/paths/steelseries-arctis-input.conf
-%%ALSA%%share/pulseaudio/alsa-mixer/paths/steelseries-arctis-output-mono.conf
-%%ALSA%%share/pulseaudio/alsa-mixer/paths/steelseries-arctis-output-stereo.conf
+%%ALSA%%share/pulseaudio/alsa-mixer/paths/steelseries-arctis-5-output-chat.conf
+%%ALSA%%share/pulseaudio/alsa-mixer/paths/steelseries-arctis-5-output-game.conf
+%%ALSA%%share/pulseaudio/alsa-mixer/paths/steelseries-arctis-7-input.conf
+%%ALSA%%share/pulseaudio/alsa-mixer/paths/steelseries-arctis-7-output-mono.conf
+%%ALSA%%share/pulseaudio/alsa-mixer/paths/steelseries-arctis-7-output-stereo.conf
+%%ALSA%%share/pulseaudio/alsa-mixer/profile-sets/cmedia-high-speed-true-hdaudio.conf
%%ALSA%%share/pulseaudio/alsa-mixer/profile-sets/default.conf
%%ALSA%%share/pulseaudio/alsa-mixer/profile-sets/dell-dock-tb16-usb-audio.conf
%%ALSA%%share/pulseaudio/alsa-mixer/profile-sets/force-speaker-and-int-mic.conf
@@ -232,13 +236,16 @@ man/man5/pulse-daemon.conf.5.gz
%%ALSA%%share/pulseaudio/alsa-mixer/profile-sets/native-instruments-traktor-audio6.conf
%%ALSA%%share/pulseaudio/alsa-mixer/profile-sets/native-instruments-traktorkontrol-s4.conf
%%ALSA%%share/pulseaudio/alsa-mixer/profile-sets/sb-omni-surround-5.1.conf
-%%ALSA%%share/pulseaudio/alsa-mixer/profile-sets/steelseries-arctis-usb-audio.conf
+%%ALSA%%share/pulseaudio/alsa-mixer/profile-sets/steelseries-arctis-5-usb-audio.conf
+%%ALSA%%share/pulseaudio/alsa-mixer/profile-sets/steelseries-arctis-7-usb-audio.conf
share/zsh/site-functions/_pulseaudio
+share/locale/af/LC_MESSAGES/pulseaudio.mo
share/locale/as/LC_MESSAGES/pulseaudio.mo
share/locale/be/LC_MESSAGES/pulseaudio.mo
share/locale/bn_IN/LC_MESSAGES/pulseaudio.mo
share/locale/ca/LC_MESSAGES/pulseaudio.mo
share/locale/cs/LC_MESSAGES/pulseaudio.mo
+share/locale/da/LC_MESSAGES/pulseaudio.mo
share/locale/de/LC_MESSAGES/pulseaudio.mo
share/locale/de_CH/LC_MESSAGES/pulseaudio.mo
share/locale/el/LC_MESSAGES/pulseaudio.mo