aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-06-13 21:32:14 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-06-13 21:32:14 +0000
commitf2b1b51d410865f3abd19e061e2a9f9b37921a10 (patch)
tree90f5fbb5cc1716fcaa8b3a15d1129dc4e44ea6f9 /audio
parentd455aebab6fd2516059cbbcd555e24a21199e1f9 (diff)
downloadports-f2b1b51d410865f3abd19e061e2a9f9b37921a10.tar.gz
ports-f2b1b51d410865f3abd19e061e2a9f9b37921a10.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/pulseaudio/Makefile3
-rw-r--r--audio/pulseaudio/files/patch-src_pulse_util.c21
-rw-r--r--audio/pulseaudio/files/pkg-message.in5
3 files changed, 21 insertions, 8 deletions
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index 1f4109283f5e..0da8421d4490 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -6,7 +6,7 @@
PORTNAME= pulseaudio
PORTVERSION= 6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://freedesktop.org/software/pulseaudio/releases/
@@ -25,7 +25,6 @@ LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile \
libdbus-1.so:${PORTSDIR}/devel/dbus \
libltdl.so:${PORTSDIR}/devel/libltdl \
libck-connector.so:${PORTSDIR}/sysutils/consolekit
-RUN_DEPENDS= freedesktop-sound-theme>=0:${PORTSDIR}/audio/freedesktop-sound-theme
USE_GNOME= glib20 intltool
USE_XORG= x11 sm xtst ice
diff --git a/audio/pulseaudio/files/patch-src_pulse_util.c b/audio/pulseaudio/files/patch-src_pulse_util.c
index 3d8481e0491a..ebad76e19038 100644
--- a/audio/pulseaudio/files/patch-src_pulse_util.c
+++ b/audio/pulseaudio/files/patch-src_pulse_util.c
@@ -1,5 +1,5 @@
---- src/pulse/util.c.orig 2015-02-12 15:10:35.000000000 +0100
-+++ src/pulse/util.c 2015-05-31 17:50:08.221242000 +0200
+--- src/pulse/util.c.orig 2015-02-12 09:10:35.000000000 -0500
++++ src/pulse/util.c 2015-06-13 17:15:14.603153000 -0400
@@ -30,6 +30,10 @@
#include <time.h>
#include <unistd.h>
@@ -11,7 +11,16 @@
#ifdef HAVE_PWD_H
#include <pwd.h>
-@@ -215,13 +219,14 @@ char *pa_get_binary_name(char *s, size_t
+@@ -200,7 +204,7 @@ char *pa_get_binary_name(char *s, size_t
+ }
+ #endif
+
+-#if defined(__linux__) || defined(__FreeBSD_kernel__)
++#if defined(__linux__) || (defined(__FreeBSD_kernel__) && !defined(__FreeBSD__))
+ {
+ char *rp;
+ /* This works on Linux and Debian/kFreeBSD */
+@@ -215,13 +219,17 @@ char *pa_get_binary_name(char *s, size_t
#ifdef __FreeBSD__
{
@@ -21,13 +30,15 @@
- pa_strlcpy(s, pa_path_get_filename(rp), l);
- pa_xfree(rp);
- return s;
-- }
+ int mib[] = { CTL_KERN, KERN_PROC, KERN_PROC_PID, getpid()};
+ struct kinfo_proc kp;
+ size_t sz = sizeof(kp);
+
-+ if (sysctl(mib, 4, &kp, &sz, NULL, 0) == 0)
++ if (sysctl(mib, 4, &kp, &sz, NULL, 0) == 0)
++ {
++ pa_strlcpy(s, kp.ki_comm, l);
+ return kp.ki_comm;
+ }
+ else
+ return NULL;
}
diff --git a/audio/pulseaudio/files/pkg-message.in b/audio/pulseaudio/files/pkg-message.in
index ce3c9ae135d7..87db4f24eaee 100644
--- a/audio/pulseaudio/files/pkg-message.in
+++ b/audio/pulseaudio/files/pkg-message.in
@@ -9,7 +9,10 @@ To change the default sink (output):
To change the default source (input):
# pacmd set-default-source 3
-This can also be set in %%ETCDIR%%/pulse/default.pa
+This can also be set in %%LOCALBASE%%/etc/pulse/default.pa
Replace the number '3' with the new default your want to set.
+
+The audio/freedesktop-sound-theme is needed if the default sound files
+are uncommented in the %%LOCALBASE%%/etc/pulse/default.pa file.