aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-01 18:03:45 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-01 18:03:45 +0000
commit4e0524180c44e3a33760ded734ca0ab30215cb19 (patch)
tree1fe4df2c78f91cecd5919be48f8e20b285122c62 /audio
parentf8cf6a5ec65c5c2957e29510de1da731abf46abd (diff)
downloadports-4e0524180c44e3a33760ded734ca0ab30215cb19.tar.gz
ports-4e0524180c44e3a33760ded734ca0ab30215cb19.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/cmt/Makefile17
-rw-r--r--audio/cmt/distinfo2
-rw-r--r--audio/cmt/files/patch-cmt.cpp15
-rw-r--r--audio/cmt/files/patch-makefile10
4 files changed, 13 insertions, 31 deletions
diff --git a/audio/cmt/Makefile b/audio/cmt/Makefile
index ba35c5d19eae..7a890255f140 100644
--- a/audio/cmt/Makefile
+++ b/audio/cmt/Makefile
@@ -5,28 +5,27 @@
# $FreeBSD$
PORTNAME= cmt
-PORTVERSION= 1.12
-PORTREVISION= 1
+PORTVERSION= 1.14
CATEGORIES= audio
-MASTER_SITES= http://www.ladspa.org/download/
-DISTNAME= ${PORTNAME}_src
-EXTRACT_SUFX= .tgz
+MASTER_SITES= http://www.arved.de/bsd/src/
MAINTAINER= freebsdports@arved.de
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
+USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}/src
-MAKEFILE= makefile
-ALL_TARGET= targets
+INSTALLS_SHLIB= yes
pre-patch:
@${FIND} ${WRKSRC} -name '*.cpp' | ${XARGS} \
${REINPLACE_CMD} -e "s|<malloc.h>|<stdlib.h>|g"
+do-build:
+ cd ${WRKSRC}/src; ${GMAKE} -f makefile targets
+
do-install:
- @${INSTALL_DATA} ${WRKSRC}/../plugins/cmt.so ${LOCALBASE}/lib/ladspa/
+ @${INSTALL_DATA} ${WRKSRC}/plugins/cmt.so ${LOCALBASE}/lib/ladspa/
.include <bsd.port.mk>
diff --git a/audio/cmt/distinfo b/audio/cmt/distinfo
index c7871c314a21..82ff1ec5219a 100644
--- a/audio/cmt/distinfo
+++ b/audio/cmt/distinfo
@@ -1 +1 @@
-MD5 (cmt_src.tgz) = 21c6cbf2a755f9c8a6470b395e9a2792
+MD5 (cmt-1.14.tar.bz2) = 1da6357066394116264339cbabff8358
diff --git a/audio/cmt/files/patch-cmt.cpp b/audio/cmt/files/patch-cmt.cpp
deleted file mode 100644
index 6ff333860387..000000000000
--- a/audio/cmt/files/patch-cmt.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- cmt.cpp.orig Sat Jul 13 20:59:44 2002
-+++ cmt.cpp Sat Jul 13 21:00:21 2002
-@@ -115,9 +115,9 @@
- void CMT_Descriptor::
- addPort(LADSPA_PortDescriptor iPortDescriptor,
- const char * pcPortName,
-- LADSPA_PortRangeHintDescriptor iHintDescriptor = 0,
-- LADSPA_Data fLowerBound = 0,
-- LADSPA_Data fUpperBound = 0) {
-+ LADSPA_PortRangeHintDescriptor iHintDescriptor,
-+ LADSPA_Data fLowerBound,
-+ LADSPA_Data fUpperBound) {
-
- unsigned long lOldPortCount = PortCount;
- unsigned long lNewPortCount = PortCount + 1;
diff --git a/audio/cmt/files/patch-makefile b/audio/cmt/files/patch-makefile
index 8bcb2fc27f52..c302c5df7e1a 100644
--- a/audio/cmt/files/patch-makefile
+++ b/audio/cmt/files/patch-makefile
@@ -1,13 +1,11 @@
---- makefile.orig Sat Jul 13 20:54:06 2002
-+++ makefile Sat Jul 13 20:56:15 2002
-@@ -12,9 +12,9 @@
- # GENERAL
+--- src/makefile.orig Sat May 18 20:27:15 2002
++++ src/makefile Thu Aug 22 12:07:51 2002
+@@ -13,8 +13,8 @@
#
--INCLUDES = -I/usr/local/include/
+ INCLUDES = -I/usr/local/include/
-CFLAGS = $(INCLUDES) -Wall -Werror -O3 -fPIC
-CXXFLAGS = $(CFLAGS)
-+INCLUDES = -I${LOCALBASE}/include/
+CFLAGS += $(INCLUDES) -Wall -Werror -fPIC
+CXXFLAGS += $(CFLAGS)
PLUGIN_LIB = ../plugins/cmt.so