aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2005-02-19 01:59:40 +0000
committerKris Kennaway <kris@FreeBSD.org>2005-02-19 01:59:40 +0000
commit76fefa4a996155f7d4d48a78e794f6e5ad4d5c4e (patch)
tree81513ce6cbc2de93663a9dbdd938c2dd33947972 /audio
parent188acae768bb50ebb0443401fd4dc900f97fa637 (diff)
downloadports-76fefa4a996155f7d4d48a78e794f6e5ad4d5c4e.tar.gz
ports-76fefa4a996155f7d4d48a78e794f6e5ad4d5c4e.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/xmms-arts_output/Makefile28
-rw-r--r--audio/xmms-arts_output/distinfo2
-rw-r--r--audio/xmms-arts_output/files/patch-arts_helper.c12
-rw-r--r--audio/xmms-arts_output/files/patch-configure10
-rw-r--r--audio/xmms-arts_output/pkg-descr5
6 files changed, 58 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 6ebdd77b6ff9..52e080eda210 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -440,6 +440,7 @@
SUBDIR += xmixer
SUBDIR += xmmix
SUBDIR += xmms-a52dec
+ SUBDIR += xmms-arts_output
SUBDIR += xmms-audiofile
SUBDIR += xmms-bonk
SUBDIR += xmms-cdparanoia
diff --git a/audio/xmms-arts_output/Makefile b/audio/xmms-arts_output/Makefile
new file mode 100644
index 000000000000..f3302abdf560
--- /dev/null
+++ b/audio/xmms-arts_output/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: xmms-arts_output
+# Date created: 12 Nov 2003
+# Whom: Max Khon <fjoe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PKGNAMEPREFIX= xmms-
+PORTNAME= arts_output
+PORTVERSION= 0.7.1
+CATEGORIES= audio
+MASTER_SITES= http://havardk.xmms.org/plugins/arts_output/
+
+MAINTAINER= fjoe@FreeBSD.org
+COMMENT= aRts output plugin for XMMS.
+
+LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
+ artsc.0:${PORTSDIR}/audio/arts
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk12
+USE_INC_LIBTOOL_VER= 13
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+PLIST_FILES= lib/xmms/Output/libarts.so \
+ bin/xmms-arts-helper
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-arts_output/distinfo b/audio/xmms-arts_output/distinfo
new file mode 100644
index 000000000000..2f07b6762341
--- /dev/null
+++ b/audio/xmms-arts_output/distinfo
@@ -0,0 +1,2 @@
+MD5 (arts_output-0.7.1.tar.gz) = 6d028255ed86e37211bbda0122c14483
+SIZE (arts_output-0.7.1.tar.gz) = 236839
diff --git a/audio/xmms-arts_output/files/patch-arts_helper.c b/audio/xmms-arts_output/files/patch-arts_helper.c
new file mode 100644
index 000000000000..f01133c9e5bd
--- /dev/null
+++ b/audio/xmms-arts_output/files/patch-arts_helper.c
@@ -0,0 +1,12 @@
+--- arts_helper.c.orig Tue Apr 6 02:23:37 2004
++++ arts_helper.c Tue Apr 6 02:22:32 2004
+@@ -243,7 +243,9 @@
+ {
+ going = 0;
+ arts_close_stream(handle);
++#if 0
+ arts_free();
++#endif
+ }
+
+ static int read_all(int fd, void *buf, size_t count)
diff --git a/audio/xmms-arts_output/files/patch-configure b/audio/xmms-arts_output/files/patch-configure
new file mode 100644
index 000000000000..1eb3cd980633
--- /dev/null
+++ b/audio/xmms-arts_output/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Thu Aug 21 14:43:13 2003
++++ configure Thu Feb 5 03:08:04 2004
+@@ -7820,6 +7820,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/xmms-arts_output/pkg-descr b/audio/xmms-arts_output/pkg-descr
new file mode 100644
index 000000000000..437391976a66
--- /dev/null
+++ b/audio/xmms-arts_output/pkg-descr
@@ -0,0 +1,5 @@
+aRts output plugin for XMMS (www.xmms.org).
+
+Author: Håvard Kvålen <havardk@xmms.org>
+
+WWW: http://www.xmms.org/plugins.php?category=output