aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-02-26 15:22:37 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-02-26 15:22:37 +0000
commitd613b75b1d87505cc967bc6f8b7a419b2d57be5b (patch)
treefb8dfa0620864eed2a359680644745507734b86a /audio
parent448b972896fbb34deed41c2bf9c30b12c6b16bc6 (diff)
downloadports-d613b75b1d87505cc967bc6f8b7a419b2d57be5b.tar.gz
ports-d613b75b1d87505cc967bc6f8b7a419b2d57be5b.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/amarok/Makefile4
-rw-r--r--audio/amarok/files/patch-src-engine-xine-xine-engine.cpp14
-rw-r--r--audio/atunes/Makefile2
-rw-r--r--audio/clementine-player/Makefile4
-rw-r--r--audio/gogglesmm/Makefile4
5 files changed, 21 insertions, 7 deletions
diff --git a/audio/amarok/Makefile b/audio/amarok/Makefile
index e7d142700031..9eaea4344a15 100644
--- a/audio/amarok/Makefile
+++ b/audio/amarok/Makefile
@@ -7,7 +7,7 @@
PORTNAME= amarok
PORTVERSION= 1.4.10
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}/${PORTVERSION}/src
@@ -18,7 +18,7 @@ COMMENT= Media player for KDE
LIB_DEPENDS= tag.1:${PORTSDIR}/audio/taglib \
tunepimp.5:${PORTSDIR}/audio/libtunepimp \
mp4v2.10:${PORTSDIR}/multimedia/mp4v2 \
- xine.1:${PORTSDIR}/multimedia/libxine
+ xine.2:${PORTSDIR}/multimedia/libxine
MIN_OPTIONS_VER= ${PORTNAME}-1.4.1
diff --git a/audio/amarok/files/patch-src-engine-xine-xine-engine.cpp b/audio/amarok/files/patch-src-engine-xine-xine-engine.cpp
new file mode 100644
index 000000000000..83dcbfa62e8d
--- /dev/null
+++ b/audio/amarok/files/patch-src-engine-xine-xine-engine.cpp
@@ -0,0 +1,14 @@
+--- amarok/src/engine/xine/xine-engine.cpp.orig
++++ amarok/src/engine/xine/xine-engine.cpp
+@@ -1131,7 +1131,11 @@ bool XineEngine::metaDataForUrl(const KU
+
+ bool XineEngine::getAudioCDContents(const QString &device, KURL::List &urls)
+ {
++#if XINE_MAJOR_VERSION < 1 || (XINE_MAJOR_VERSION == 1 && XINE_MINOR_VERSION < 2)
+ char **xine_urls = NULL;
++#else
++ const char * const *xine_urls = NULL;
++#endif
+ int num;
+ int i = 0;
+
diff --git a/audio/atunes/Makefile b/audio/atunes/Makefile
index 4f9bd821f9af..5cabe5d61e42 100644
--- a/audio/atunes/Makefile
+++ b/audio/atunes/Makefile
@@ -41,7 +41,7 @@ RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
.endif
.if defined(WITH_XINE)
-RUN_DEPENDS+= xine.1:${PORTSDIR}/multimedia/libxine
+LIB_DEPENDS+= xine.2:${PORTSDIR}/multimedia/libxine
.endif
.if defined(WITH_CDDA2WAV)
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index 429550baf888..9d768acc16dd 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -7,7 +7,7 @@
PORTNAME= clementine
PORTVERSION= 1.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= GOOGLE_CODE
PKGNAMESUFFIX= -player
@@ -19,7 +19,7 @@ LICENSE= GPLv3
LIB_DEPENDS= tag.1:${PORTSDIR}/audio/taglib \
notify.4:${PORTSDIR}/devel/libnotify \
- xine.1:${PORTSDIR}/multimedia/libxine \
+ xine.2:${PORTSDIR}/multimedia/libxine \
qjson.0:${PORTSDIR}/devel/qjson
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
diff --git a/audio/gogglesmm/Makefile b/audio/gogglesmm/Makefile
index 3c3a51f4e7db..979ae96d34b7 100644
--- a/audio/gogglesmm/Makefile
+++ b/audio/gogglesmm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gogglesmm
PORTVERSION= 0.12.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= GOOGLE_CODE
@@ -17,7 +17,7 @@ COMMENT= Music collection manager and player
LICENSE= GPLv3
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
-LIB_DEPENDS= xine.1:${PORTSDIR}/multimedia/libxine \
+LIB_DEPENDS= xine.2:${PORTSDIR}/multimedia/libxine \
tag.1:${PORTSDIR}/audio/taglib \
sqlite3.8:${PORTSDIR}/databases/sqlite3