aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2006-04-06 18:55:51 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2006-04-06 18:55:51 +0000
commit17a13f66c2e8d84262d2cd9e68cf693c3eb0af80 (patch)
tree7f09d9d2f959eb0d0918ff3396c31bf4b2a5ab72 /audio
parent8f7adbf1d663addbd416d1e5b085d44425e17b0d (diff)
downloadports-17a13f66c2e8d84262d2cd9e68cf693c3eb0af80.tar.gz
ports-17a13f66c2e8d84262d2cd9e68cf693c3eb0af80.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/cmus/Makefile16
-rw-r--r--audio/cmus/distinfo6
-rw-r--r--audio/cmus/pkg-plist9
3 files changed, 24 insertions, 7 deletions
diff --git a/audio/cmus/Makefile b/audio/cmus/Makefile
index 3facc7b42c44..bd3079e681e7 100644
--- a/audio/cmus/Makefile
+++ b/audio/cmus/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= cmus
-PORTVERSION= 1.6.8
+PORTVERSION= 2.0.0
CATEGORIES= audio
-MASTER_SITES= http://onion.dynserv.net/~timo/files/
+MASTER_SITES= http://onion.dynserv.net/~timo/files/ \
+ http://mirror.greaterscope.net/cmus/
MAINTAINER= adamw@FreeBSD.org
COMMENT= Console-based music player with really cool features
@@ -40,6 +41,9 @@ WITH_TREMOR= yes
.if exists(${LOCALBASE}/lib/libmpcdec.so)
WITH_MUSEPACK= yes
.endif
+.if exists(${LOCALBASE}/lib/libao.so)
+WITH_LIBAO= yes
+.endif
.if exists(${LOCALBASE}/lib/libartsc.so)
WITH_ARTS= yes
.endif
@@ -77,6 +81,14 @@ PLIST_SUB+= MPC="@comment "
PREMSG+= Define WITH_MUSEPACK=yes to enable musepack support.\n
.endif
+.if defined(WITH_LIBAO)
+LIB_DEPENDS+= ao:${PORTSDIR}/audio/libao
+PLIST_SUB+= AO=""
+.else
+PLIST_SUB+= AO="@comment "
+PREMSG+= Define WITH_LIBAO=yes to enable the libao output library.\n
+.endif
+
.if defined(WITH_ARTS)
LIB_DEPENDS+= artsc:${PORTSDIR}/audio/arts
PLIST_SUB+= ARTS=""
diff --git a/audio/cmus/distinfo b/audio/cmus/distinfo
index bfaedc9d9ead..472ca7756cb1 100644
--- a/audio/cmus/distinfo
+++ b/audio/cmus/distinfo
@@ -1,3 +1,3 @@
-MD5 (cmus-1.6.8.tar.bz2) = 385f73b17d2a4d107d0fa05281f7958e
-SHA256 (cmus-1.6.8.tar.bz2) = e9594de4c0cc2ed845923f5b65d09834eab82a88555dcf4011985033ba211629
-SIZE (cmus-1.6.8.tar.bz2) = 142420
+MD5 (cmus-2.0.0.tar.bz2) = 181704377e17dc3d8ca9e69e7a004c14
+SHA256 (cmus-2.0.0.tar.bz2) = 88d85c68a143fba4fcffc9f148d1c0a818b6f9030da49528b8abd83c11cecb5c
+SIZE (cmus-2.0.0.tar.bz2) = 143942
diff --git a/audio/cmus/pkg-plist b/audio/cmus/pkg-plist
index 4f7f6f65bcb5..1ea4e76d1482 100644
--- a/audio/cmus/pkg-plist
+++ b/audio/cmus/pkg-plist
@@ -6,10 +6,15 @@ lib/cmus/ip/mad.so
%%MPC%%lib/cmus/ip/mpc.so
%%VORBIS%%lib/cmus/ip/vorbis.so
lib/cmus/ip/wav.so
+%%AO%%lib/cmus/op/ao.so
%%ARTS%%lib/cmus/op/arts.so
lib/cmus/op/oss.so
-%%DATADIR%%/keybindings
-%%DOCSDIR%%/cmus.html
+%%DATADIR%%/cyan.theme
+%%DATADIR%%/cyan.theme.bak
+%%DATADIR%%/default.theme
+%%DATADIR%%/default.theme.bak
+%%DATADIR%%/rc
+%%DATADIR%%/rc.bak
%%DOCSDIR%%/examples/cmus-status-display
@dirrm %%DOCSDIR%%/examples
@dirrm %%DOCSDIR%%