aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-12-02 19:21:09 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-12-02 19:21:09 +0000
commit2841f61ea11d059de0ea50bd31553a0e48e9c6f5 (patch)
tree22333e8ba37f35e14402fb258fd45d17161ba7be /audio
parente6e44a680e83a336621efc1f2ea843d6bce30e66 (diff)
downloadports-2841f61ea11d059de0ea50bd31553a0e48e9c6f5.tar.gz
ports-2841f61ea11d059de0ea50bd31553a0e48e9c6f5.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/x11amp/Makefile5
-rw-r--r--audio/x11amp/files/patch-x11amp__controlsocket.c11
-rw-r--r--audio/x11amp/files/patch-x11amp__playlist.c11
3 files changed, 25 insertions, 2 deletions
diff --git a/audio/x11amp/Makefile b/audio/x11amp/Makefile
index fa14233cfccd..2aee567e27dd 100644
--- a/audio/x11amp/Makefile
+++ b/audio/x11amp/Makefile
@@ -9,11 +9,12 @@ MASTER_SITES= LOCAL
MASTER_SITE_SUBDIR= hrs
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/-beta/}
-MAINTAINER= turutani@scphys.kyoto-u.ac.jp
+MAINTAINER= ports@FreeBSD.org
COMMENT= X11-based MP3 player with nice graphical interface
+LICENSE= GPLv2
+
USE_GNOME= gtk12 esound
-NO_STAGE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static
diff --git a/audio/x11amp/files/patch-x11amp__controlsocket.c b/audio/x11amp/files/patch-x11amp__controlsocket.c
new file mode 100644
index 000000000000..b14ccc687bd7
--- /dev/null
+++ b/audio/x11amp/files/patch-x11amp__controlsocket.c
@@ -0,0 +1,11 @@
+--- ./x11amp/controlsocket.c.orig 1999-04-11 23:26:04.000000000 +0000
++++ ./x11amp/controlsocket.c 2013-12-02 19:13:07.000000000 +0000
+@@ -178,7 +178,7 @@
+ if(!select(fd+1,&set,NULL,NULL,&tv))
+ {
+ close(fd);
+- return;
++ pthread_exit(NULL);
+ }
+ pkt = g_malloc0(sizeof(PacketNode));
+ read(fd,&pkt->hdr,sizeof(ClientPktHeader));
diff --git a/audio/x11amp/files/patch-x11amp__playlist.c b/audio/x11amp/files/patch-x11amp__playlist.c
new file mode 100644
index 000000000000..d60ee4e72de1
--- /dev/null
+++ b/audio/x11amp/files/patch-x11amp__playlist.c
@@ -0,0 +1,11 @@
+--- ./x11amp/playlist.c.orig 1999-04-13 20:26:35.000000000 +0000
++++ ./x11amp/playlist.c 2013-12-02 19:12:21.000000000 +0000
+@@ -224,7 +224,7 @@
+ }
+ g_list_free(list);
+ playlist_generate_shuffle_list();
+- return;
++ return 0;
+ }
+ g_free(temp);
+ if(dir=opendir(path))