aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-04-17 00:18:05 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-04-17 00:18:05 +0000
commit877b8a533b44bb6324ebbaf65cd80a60d1572003 (patch)
treee1a018208ceade04ca56a70c5184978cac51853e /audio
parentd12f14432cc492205cefb505a3c1320dd0f4e31a (diff)
downloadports-877b8a533b44bb6324ebbaf65cd80a60d1572003.tar.gz
ports-877b8a533b44bb6324ebbaf65cd80a60d1572003.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/aumix/Makefile6
-rw-r--r--audio/cdrdao/Makefile13
-rw-r--r--audio/lame/Makefile4
-rw-r--r--audio/lame/files/patch-aa2
-rw-r--r--audio/replay/Makefile6
-rw-r--r--audio/sox/Makefile2
-rw-r--r--audio/timidity++/Makefile10
-rw-r--r--audio/wmtune/Makefile4
8 files changed, 23 insertions, 24 deletions
diff --git a/audio/aumix/Makefile b/audio/aumix/Makefile
index b68ef02ef003..6961c8cf5b0d 100644
--- a/audio/aumix/Makefile
+++ b/audio/aumix/Makefile
@@ -17,7 +17,7 @@ MASTER_SITE_SUBDIR= apps/sound/mixers
MAINTAINER= cpiazza@FreeBSD.org
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
-.if !defined(NO_X11)
+.if !defined(WITHOUT_X11)
LIB_DEPENDS+= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
GLIB_CONFIG= ${LOCALBASE}/bin/glib12-config
@@ -35,12 +35,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GLIB_CONFIG="${GLIB_CONFIG}" \
GTK_CONFIG="${GTK_CONFIG}" \
LDFLAGS="-L${LOCALBASE}/lib"
-.if defined(NO_X11)
+.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --without-gtk
.else
pre-fetch:
@${ECHO_MSG} -n "To build this port without X11 (and without the GUI),"
- @${ECHO_MSG} " define \"NO_X11\"."
+ @${ECHO_MSG} " define \"WITHOUT_X11\"."
.endif
.include <bsd.port.mk>
diff --git a/audio/cdrdao/Makefile b/audio/cdrdao/Makefile
index 7eace10ec83b..4cff53d52605 100644
--- a/audio/cdrdao/Makefile
+++ b/audio/cdrdao/Makefile
@@ -4,10 +4,6 @@
#
# $FreeBSD$
#
-# If you don't want to use Joerg Schilling's SCSI library,
-# set DONT_USE_SCGLIB = yes
-# If you don't want to use pthreads, set DONT_USE_PTHREADS = yes
-# If you want the graphical X toc file editor, set XCDRDAO = yes
PORTNAME= cdrdao
PORTVERSION= 1.1.3
@@ -45,18 +41,21 @@ PLIST=${PKGDIR}/PLIST.xcdrdao
CONFIGURE_ARGS= --disable-gtkmmtest
.endif
-.if defined(DONT_USE_SCGLIB) && ${OSVERSION} > 300000
+.if defined(WITHOUT_SCGLIB) && ${OSVERSION} > 300000
CONFIGURE_ARGS+= --without-scglib
.endif
-.if defined(DONT_USE_PTHREADS) && ${OSVERSION} > 320000
+.if defined(WITHOUT_PTHREADS) && ${OSVERSION} > 320000
CONFIGURE_ARGS+= --without-posix-threads
.endif
pre-fetch:
+ @${ECHO_MSG} "If you don't want to use Joerg Schilling's SCSI library,"
+ @${ECHO_MSG} "set WITHOUT_SCGLIB=yes."
+ @${ECHO_MSG} "If you don't want to use pthreads, set WITHOUT_PTHREADS=yes."
.if !defined(XCDRDAO)
@${ECHO_MSG} "To build the graphical X toc file editor, xcdrdao, type:"
- @${ECHO_MSG} " make XCDRDAO=yes"
+ @${ECHO_MSG} " make XCDRDAO=yes."
.else
@${ECHO_MSG} "Building with xcdrdao"
.endif
diff --git a/audio/lame/Makefile b/audio/lame/Makefile
index 3316929728b8..9961f416ce3a 100644
--- a/audio/lame/Makefile
+++ b/audio/lame/Makefile
@@ -16,7 +16,7 @@ PATCHFILES= lame3.51.patch.gz
MAINTAINER= yoshiaki@kt.rim.or.jp
-.if !defined(NO_X11)
+.if !defined(WITHOUT_X11)
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
.endif
@@ -24,7 +24,7 @@ PATCH_DIST_STRIP = -p1
WRKSRC= ${WRKDIR}/dist10/lsf/encoder/
USE_GMAKE= YES
-MAKE_ENV= NO_X11=${NO_X11}
+MAKE_ENV= WITHOUT_X11=${WITHOUT_X11}
ALL_TARGET= lame
RESTRICTED= Condition is not clear
diff --git a/audio/lame/files/patch-aa b/audio/lame/files/patch-aa
index 4bd8ef8510c0..779df763a85d 100644
--- a/audio/lame/files/patch-aa
+++ b/audio/lame/files/patch-aa
@@ -13,7 +13,7 @@
##########################################################################
ifeq ($(UNAME),FreeBSD)
# remove if you do not have GTK or do not want the GTK frame analyzer
-+ifndef NO_X11
++ifndef WITHOUT_X11
GTK = -DHAVEGTK `gtk12-config --cflags`
GTKLIBS = `gtk12-config --libs`
+endif
diff --git a/audio/replay/Makefile b/audio/replay/Makefile
index 6413ab593e0d..90d051c9ba50 100644
--- a/audio/replay/Makefile
+++ b/audio/replay/Makefile
@@ -26,15 +26,15 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
-.if defined(USE_I18N)
+.if defined(WITH_I18N)
CONFIGURE_ARGS+= --enable-i18n=JAPANESE
.endif
pre-configure:
-.if !defined(USE_I18N)
+.if !defined(WITH_I18N)
@${ECHO_MSG}
@${ECHO_MSG} "If you would like build replay with I18N support"
- @${ECHO_MSG} "you must set the variable USE_I18N"
+ @${ECHO_MSG} "you must set the variable WITH_I18N"
@${ECHO_MSG} "(Now JAPANESE only)"
@${ECHO_MSG}
.else
diff --git a/audio/sox/Makefile b/audio/sox/Makefile
index c28f15fb2123..986d1f406775 100644
--- a/audio/sox/Makefile
+++ b/audio/sox/Makefile
@@ -18,7 +18,7 @@ MLINKS= play.1 rec.1
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-fast-ulaw --enable-fast-alaw --with-oss-dsp
-.if defined(USE_GSM)
+.if defined(WITH_GSM)
CONFIGURE_ARGS+= --with-gsmlib=${PREFIX}/lib --with-gsminc=${PREFIX}/include
LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
.endif
diff --git a/audio/timidity++/Makefile b/audio/timidity++/Makefile
index b1aafdfdc920..7b22d0f903e6 100644
--- a/audio/timidity++/Makefile
+++ b/audio/timidity++/Makefile
@@ -13,12 +13,12 @@ DISTNAME= TiMidity++-${PORTVERSION}
MAINTAINER= yatt@msc.biglobe.ne.jp
-# If you don't have X11, type "make -DNO_X11" or uncomment this.
-#NO_X11= yes
+# If you don't have X11, type "make -DWITHOUT_X11" or uncomment this.
+#WITHOUT_X11= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
-.if !defined(NO_X11)
+.if !defined(WITHOUT_X11)
USE_XLIB= yes
LIB_DEPENDS+= png.3:${PORTSDIR}/graphics/png
.endif
@@ -26,7 +26,7 @@ LIB_DEPENDS+= png.3:${PORTSDIR}/graphics/png
DIST_SUBDIR= timidity
INSTALL_TARGET= install install.man
-.if !defined(NO_X11)
+.if !defined(WITHOUT_X11)
CONFIGURE_ARGS= --with-x --enable-ncurses --enable-vt100 \
--enable-dynamic --enable-server \
--enable-network --enable-spectrogram --enable-wrd
@@ -35,7 +35,7 @@ CONFIGURE_ARGS= --enable-ncurses --enable-vt100 \
--enable-network --disable-spectrogram --disable-wrd
.endif
-.if defined(USE_ESOUND)
+.if defined(WITH_ESOUND)
LIB_DEPENDS+= esd.2:${PORTSDIR}/audio/esound
CONFIGURE_ARGS+= --enable-audio=oss,esd
.else
diff --git a/audio/wmtune/Makefile b/audio/wmtune/Makefile
index e5bec7a8acb9..7defa3434314 100644
--- a/audio/wmtune/Makefile
+++ b/audio/wmtune/Makefile
@@ -26,12 +26,12 @@ PATCH_ARGS =-p0 -d ${WRKDIR}
.include <bsd.port.pre.mk>
-.if !defined(USE_RADIOTRACK)
+.if !defined(WITH_RADIOTRACK)
WMTUNE_DIFF= wmtune.diff.gz
pre-fetch:
@${ECHO}
@${ECHO} "To enable support for RadioTrack radio cards,"
- @${ECHO} "define USE_RADIOTRACK (make USE_RADIOTRACK=yes)."
+ @${ECHO} "define WITH_RADIOTRACK (make WITH_RADIOTRACK=yes)."
@${ECHO}
@sleep 3
.else