aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-03 05:29:03 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-03 05:29:03 +0000
commit7bdd28e66b86ac980e6337384692a1bba8487b25 (patch)
tree0675aea55c8c6a4e61e0d048e5591cb915606a42 /audio
parent04e0e62a3b6274dfde45943956cabfe283cdb925 (diff)
downloadports-7bdd28e66b86ac980e6337384692a1bba8487b25.tar.gz
ports-7bdd28e66b86ac980e6337384692a1bba8487b25.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gdcd/Makefile32
-rw-r--r--audio/gdcd/distinfo3
-rw-r--r--audio/gdcd/pkg-comment1
-rw-r--r--audio/gdcd/pkg-descr5
-rw-r--r--audio/gdcd/pkg-plist13
6 files changed, 55 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 39feca42b385..e1ebc2cd7788 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -18,6 +18,7 @@
SUBDIR += dap
SUBDIR += esound
SUBDIR += extace
+ SUBDIR += gdcd
SUBDIR += gmixer
SUBDIR += gnapster
SUBDIR += gnomeaudio
diff --git a/audio/gdcd/Makefile b/audio/gdcd/Makefile
new file mode 100644
index 000000000000..a981b4beba67
--- /dev/null
+++ b/audio/gdcd/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gdcd
+# Date created: Sat 3 June 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdcd
+PORTVERSION= 0.0.2
+CATEGORIES= audio
+MASTER_SITES= http://cdcd.undergrid.net/gdcd/source_archive/
+
+MAINTAINER= will@FreeBSD.org
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ cdaudio.1:${PORTSDIR}/audio/libcdaudio \
+ Imlib.5:${PORTSDIR}/graphics/imlib
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
+
+# for libcdaudio
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -Wl,-R${LOCALBASE}/lib -L${LOCALBASE}/lib
+
+post-install:
+ @${ECHO}
+ @${ECHO} "Don't forget to make a symlink from your CDROM device to /dev/cdrom!"
+ @${ECHO}
+
+.include <bsd.port.mk>
diff --git a/audio/gdcd/distinfo b/audio/gdcd/distinfo
new file mode 100644
index 000000000000..ee0768be90ab
--- /dev/null
+++ b/audio/gdcd/distinfo
@@ -0,0 +1,3 @@
+$NetBSD: md5,v 1.1.1.1 1999/09/03 22:15:46 rh Exp $
+
+MD5 (gdcd-0.0.2.tar.gz) = 2c2fee796bd05fcdbacceab099826962
diff --git a/audio/gdcd/pkg-comment b/audio/gdcd/pkg-comment
new file mode 100644
index 000000000000..66db9a5afc1e
--- /dev/null
+++ b/audio/gdcd/pkg-comment
@@ -0,0 +1 @@
+CD player for the X Window System using the GIMP Tool Kit (GTK)
diff --git a/audio/gdcd/pkg-descr b/audio/gdcd/pkg-descr
new file mode 100644
index 000000000000..0270076c17e9
--- /dev/null
+++ b/audio/gdcd/pkg-descr
@@ -0,0 +1,5 @@
+ gdcd is a CD player for the X Window System which uses the GIMP Tool
+Kit (GTK) and libcdaudio. It is in quite early development at this point,
+but should become quite a bit more functional as time goes on.
+
+WWW: http://cdcd.undergrid.net/gdcd/
diff --git a/audio/gdcd/pkg-plist b/audio/gdcd/pkg-plist
new file mode 100644
index 000000000000..7da80cc91ada
--- /dev/null
+++ b/audio/gdcd/pkg-plist
@@ -0,0 +1,13 @@
+bin/gdcd
+share/pixmaps/gdcd/blues.png
+share/pixmaps/gdcd/data.png
+share/pixmaps/gdcd/folk.png
+share/pixmaps/gdcd/jazz.png
+share/pixmaps/gdcd/misc.png
+share/pixmaps/gdcd/newage.png
+share/pixmaps/gdcd/nodisc.png
+share/pixmaps/gdcd/reggae.png
+share/pixmaps/gdcd/rock.png
+share/pixmaps/gdcd/soundtrack.png
+share/pixmaps/gdcd/unknown.png
+@dirrm share/pixmaps/gdcd