aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/dbs
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-21 03:10:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-21 03:10:02 +0000
commit90c22c44a47ed7098e786628fcf62083e94f017f (patch)
treeee1639374553007c1de41188a13c824592cf587f /benchmarks/dbs
parent99bae5eaf7599df3385b1a42cc3ed0701334271b (diff)
downloadports-90c22c44a47ed7098e786628fcf62083e94f017f.tar.gz
ports-90c22c44a47ed7098e786628fcf62083e94f017f.zip
Notes
Diffstat (limited to 'benchmarks/dbs')
-rw-r--r--benchmarks/dbs/Makefile51
-rw-r--r--benchmarks/dbs/files/patch-aa2
-rw-r--r--benchmarks/dbs/files/patch-af12
-rw-r--r--benchmarks/dbs/files/patch-src__record.h12
-rw-r--r--benchmarks/dbs/pkg-plist11
5 files changed, 44 insertions, 44 deletions
diff --git a/benchmarks/dbs/Makefile b/benchmarks/dbs/Makefile
index 2fd6ced0a1a7..5cb164b2323b 100644
--- a/benchmarks/dbs/Makefile
+++ b/benchmarks/dbs/Makefile
@@ -7,40 +7,51 @@
PORTNAME= dbs
PORTVERSION= 1.1.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= benchmarks
MASTER_SITES= http://www.kusa.ac.jp/~yukio-m/dbs/software1.1.5/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= jkoshy
+ LOCAL/jkoshy
MAINTAINER= ports@FreeBSD.org
COMMENT= A distributed network benchmarking system
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
-DOCDIR= ${PREFIX}/share/doc/dbs/
-DOCS= dbs.man dbs.man.jis dbs_paper.ps Copyright
-EXDIR= ${PREFIX}/share/examples/dbs/
-EXS= TCP2.cmd TCPvsMPEG.cmd
+BUILD_WRKSRC= ${WRKSRC}/obj/${OPSYS}
+INSTALL_WRKSRC= ${WRKSRC}/obj/${OPSYS}
-.include <bsd.port.pre.mk>
+USE_PERL5_RUN= yes
+MAKEFILE= makefile
-.if ${OSVERSION} >= 900000
-BROKEN= does not compile on FreeBSD 9.X
-.endif
+PORTDOCS= *
+PORTEXAMPLES= *
+PLIST_FILES= bin/dbs_view bin/dbsc bin/dbsd
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|/usr/local/bin/perl|${PERL}|' ${WRKSRC}/script/dbs_view
-do-build:
+pre-build:
cd ${WRKSRC}/src; ${MAKE} dir
- cd ${WRKSRC}/obj/${OPSYS}; ${MAKE} ${ALL_TARGET} PREFIX=${PREFIX}
do-install:
- cd ${WRKSRC}/obj/${OPSYS}; ${MAKE} ${INSTALL_TARGET} PREFIX=${PREFIX}
- ${STRIP_CMD} ${PREFIX}/bin/dbsc ${PREFIX}/bin/dbsd
- ${MKDIR} ${EXDIR}
- cd ${WRKSRC}/sample; ${CP} -p ${EXS} ${EXDIR}
+.for bin in dbsc dbsd
+ cd ${INSTALL_WRKSRC}; ${INSTALL_PROGRAM} ${bin} ${PREFIX}/bin
+.endfor
+.for bin in dbs_view
+ cd ${WRKSRC}/script; ${INSTALL_SCRIPT} ${bin} ${PREFIX}/bin
+.endfor
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCDIR}
- cd ${WRKSRC}/doc; ${CP} -p ${DOCS} ${DOCDIR}
+ @${MKDIR} ${DOCSDIR}
+.for doc in Copyright dbs.man dbs.man.jis dbs_paper.ps
+ cd ${WRKSRC}/doc; ${INSTALL_DATA} ${doc} ${DOCSDIR}
+.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for ex in TCP2.cmd TCPvsMPEG.cmd
+ cd ${WRKSRC}/sample; ${INSTALL_DATA} ${ex} ${EXAMPLESDIR}
+.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/benchmarks/dbs/files/patch-aa b/benchmarks/dbs/files/patch-aa
index 4ba0a4562e46..f533d8c59b3d 100644
--- a/benchmarks/dbs/files/patch-aa
+++ b/benchmarks/dbs/files/patch-aa
@@ -9,7 +9,7 @@
#CC =gcc
-CFLAGS =-O
-+CFLAGS =-O -DHAVE_SYS_PARAM_H
++CFLAGS +=-DHAVE_SYS_PARAM_H
#CFLAGS =-g # debug
#CFLAGS =-g -DDEBUGMODE
diff --git a/benchmarks/dbs/files/patch-af b/benchmarks/dbs/files/patch-af
deleted file mode 100644
index ce6f82b61fef..000000000000
--- a/benchmarks/dbs/files/patch-af
+++ /dev/null
@@ -1,12 +0,0 @@
---- script/dbs_view-- Fri Jul 11 00:53:57 1997
-+++ script/dbs_view Sat Aug 1 20:44:46 1998
-@@ -1,7 +1,7 @@
--#!/usr/local/bin/perl
--#!/usr/local/bin/perl -d
- #!/usr/bin/perl
- #!/usr/bin/perl -d
-+#!/usr/local/bin/perl
-+#!/usr/local/bin/perl -d
-
- ######################################################################
- # DBS: Distributed Benchmark System
diff --git a/benchmarks/dbs/files/patch-src__record.h b/benchmarks/dbs/files/patch-src__record.h
new file mode 100644
index 000000000000..af6f763eb9f0
--- /dev/null
+++ b/benchmarks/dbs/files/patch-src__record.h
@@ -0,0 +1,12 @@
+--- src/record.h.orig 1997-10-13 09:36:38.000000000 +0900
++++ src/record.h 2012-04-29 03:08:53.000000000 +0900
+@@ -69,7 +69,9 @@
+ #include <netinet/tcp.h>
+
+ #ifndef __linux__
++#ifndef __FreeBSD__
+ #include <netinet/in_pcb.h>
++#endif
+ #include <netinet/ip_var.h>
+ #include <netinet/tcpip.h>
+ /*#define TCPSTATES*/
diff --git a/benchmarks/dbs/pkg-plist b/benchmarks/dbs/pkg-plist
deleted file mode 100644
index c84214ca4dc2..000000000000
--- a/benchmarks/dbs/pkg-plist
+++ /dev/null
@@ -1,11 +0,0 @@
-bin/dbs_view
-bin/dbsc
-bin/dbsd
-%%PORTDOCS%%%%DOCSDIR%%/Copyright
-%%PORTDOCS%%%%DOCSDIR%%/dbs.man
-%%PORTDOCS%%%%DOCSDIR%%/dbs.man.jis
-%%PORTDOCS%%%%DOCSDIR%%/dbs_paper.ps
-%%EXAMPLESDIR%%/TCP2.cmd
-%%EXAMPLESDIR%%/TCPvsMPEG.cmd
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%EXAMPLESDIR%%