aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/fhourstones/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-23 11:56:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-23 11:56:19 +0000
commitfb483d9c58812cdf24dc4be8ecca67c19398af56 (patch)
treed09f290823e2137318f782464b0b31ae8a24ffc4 /benchmarks/fhourstones/Makefile
parent11fb80b76fb3ac7f48ccd000111d5a4cac55d361 (diff)
Notes
Diffstat (limited to 'benchmarks/fhourstones/Makefile')
-rw-r--r--benchmarks/fhourstones/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/benchmarks/fhourstones/Makefile b/benchmarks/fhourstones/Makefile
new file mode 100644
index 000000000000..ddb713d14d79
--- /dev/null
+++ b/benchmarks/fhourstones/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: fhourstones
+# Date created: 2006-11-23
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fhourstones
+PORTVERSION= 3.1
+CATEGORIES= benchmarks
+MASTER_SITES= http://homepages.cwi.nl/~tromp/c4/
+DISTNAME= Fhourstones
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= The Fhourstones Benchmark
+
+NO_WRKSUBDIR= yes
+PLIST_FILES= bin/fhourstones lib/fhourstones/SearchGame lib/fhourstones/inputs
+PLIST_DIRS= lib/fhourstones
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/fhourstones
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/fhourstones
+ ${INSTALL_SCRIPT} ${WRKDIR}/fhourstones ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKDIR}/SearchGame ${PREFIX}/lib/fhourstones/
+ ${INSTALL_DATA} ${WRKDIR}/inputs ${PREFIX}/lib/fhourstones
+
+.include <bsd.port.mk>