aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/filebench
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2011-01-09 08:08:50 +0000
committerFlorian Smeets <flo@FreeBSD.org>2011-01-09 08:08:50 +0000
commit956807065a8e10642393f9b58330c5c732c3a9c9 (patch)
treed01692b48089e884a7e5d4e4ac9e062ec6fc3aca /benchmarks/filebench
parent35474c1cf355ea9efc54884b9ef10fad0b289192 (diff)
downloadports-956807065a8e10642393f9b58330c5c732c3a9c9.tar.gz
ports-956807065a8e10642393f9b58330c5c732c3a9c9.zip
Notes
Diffstat (limited to 'benchmarks/filebench')
-rw-r--r--benchmarks/filebench/Makefile28
-rw-r--r--benchmarks/filebench/distinfo2
-rw-r--r--benchmarks/filebench/pkg-descr14
-rw-r--r--benchmarks/filebench/pkg-plist48
4 files changed, 92 insertions, 0 deletions
diff --git a/benchmarks/filebench/Makefile b/benchmarks/filebench/Makefile
new file mode 100644
index 000000000000..1256d7d9eb9e
--- /dev/null
+++ b/benchmarks/filebench/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: filebench
+# Date created: Jan 6, 2011
+# Whom: Tom Judge <tom@tomjudge.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= filebench
+PORTVERSION= 1.4.8.0.8
+CATEGORIES= benchmarks
+MASTER_SITES= http://www.fsl.cs.sunysb.edu/~vass/filebench/
+DISTNAME= go_filebench-1.4.8.fsl.0.8
+
+MAINTAINER= tom@tomjudge.com
+COMMENT= Performance Test of Filesystem I/O
+
+ONLY_FOR_ARCHS= amd64 i386 ia64 ppc
+
+GNU_CONFIGURE= yes
+LICENSE= CDDL
+
+do-install:
+ ( cd ${WRKSRC} && make install-binPROGRAMS )
+.if !defined(NOPORTDATA)
+ (cd ${WRKSRC} && make install-data )
+.endif
+
+.include <bsd.port.mk>
diff --git a/benchmarks/filebench/distinfo b/benchmarks/filebench/distinfo
new file mode 100644
index 000000000000..2ae91bb422e7
--- /dev/null
+++ b/benchmarks/filebench/distinfo
@@ -0,0 +1,2 @@
+SHA256 (go_filebench-1.4.8.fsl.0.8.tar.gz) = b196ae6bf0452e2a0b6cf4a77873ea298678186e7ad416beeb91f4b762fb3a3e
+SIZE (go_filebench-1.4.8.fsl.0.8.tar.gz) = 350332
diff --git a/benchmarks/filebench/pkg-descr b/benchmarks/filebench/pkg-descr
new file mode 100644
index 000000000000..6468f55b69b7
--- /dev/null
+++ b/benchmarks/filebench/pkg-descr
@@ -0,0 +1,14 @@
+Filebench is quick to set up and use unlike many of the commercial
+benchmarks which it can emulate. It is also a handy tool for
+micro-benchmarking storage subsystems and studying the relationships of
+complex applications such as relational databases with their storage
+without having to incur the costs of setting up those applications,
+loading data and so forth.
+
+Filebench uses loadable workload personalities in a common framework to
+allow easy emulation of complex applications upon file systems. The
+workload personalities use a Workload Definition Language to define the
+workload's model.
+
+WWW: http://www.solarisinternals.com/wiki/index.php/FileBench
+WWW: http://www.fsl.cs.sunysb.edu/~vass/filebench/
diff --git a/benchmarks/filebench/pkg-plist b/benchmarks/filebench/pkg-plist
new file mode 100644
index 000000000000..a0e237276b1d
--- /dev/null
+++ b/benchmarks/filebench/pkg-plist
@@ -0,0 +1,48 @@
+bin/go_filebench
+%%PORTDATA%%%%DATADIR%%/workloads/compflow_demo.f
+%%PORTDATA%%%%DATADIR%%/workloads/copyfiles.f
+%%PORTDATA%%%%DATADIR%%/workloads/createfiles.f
+%%PORTDATA%%%%DATADIR%%/workloads/filemicro_create.f
+%%PORTDATA%%%%DATADIR%%/workloads/filemicro_createfiles.f
+%%PORTDATA%%%%DATADIR%%/workloads/filemicro_createrand.f
+%%PORTDATA%%%%DATADIR%%/workloads/filemicro_delete.f
+%%PORTDATA%%%%DATADIR%%/workloads/filemicro_rread.f
+%%PORTDATA%%%%DATADIR%%/workloads/filemicro_rwritedsync.f
+%%PORTDATA%%%%DATADIR%%/workloads/filemicro_rwrite.f
+%%PORTDATA%%%%DATADIR%%/workloads/filemicro_rwritefsync.f
+%%PORTDATA%%%%DATADIR%%/workloads/filemicro_seqread.f
+%%PORTDATA%%%%DATADIR%%/workloads/filemicro_seqwrite.f
+%%PORTDATA%%%%DATADIR%%/workloads/filemicro_seqwriterand.f
+%%PORTDATA%%%%DATADIR%%/workloads/filemicro_seqwriterandvargam.f
+%%PORTDATA%%%%DATADIR%%/workloads/filemicro_seqwriterandvartab.f
+%%PORTDATA%%%%DATADIR%%/workloads/filemicro_statfile.f
+%%PORTDATA%%%%DATADIR%%/workloads/filemicro_writefsync.f
+%%PORTDATA%%%%DATADIR%%/workloads/fileserver.f
+%%PORTDATA%%%%DATADIR%%/workloads/listdirs.f
+%%PORTDATA%%%%DATADIR%%/workloads/makedirs.f
+%%PORTDATA%%%%DATADIR%%/workloads/mongo.f
+%%PORTDATA%%%%DATADIR%%/workloads/multistreamreaddirect.f
+%%PORTDATA%%%%DATADIR%%/workloads/multistreamread.f
+%%PORTDATA%%%%DATADIR%%/workloads/multistreamwritedirect.f
+%%PORTDATA%%%%DATADIR%%/workloads/multistreamwrite.f
+%%PORTDATA%%%%DATADIR%%/workloads/netsfs.f
+%%PORTDATA%%%%DATADIR%%/workloads/networkfs.f
+%%PORTDATA%%%%DATADIR%%/workloads/oltp.f
+%%PORTDATA%%%%DATADIR%%/workloads/openfiles.f
+%%PORTDATA%%%%DATADIR%%/workloads/randomfileaccess.f
+%%PORTDATA%%%%DATADIR%%/workloads/randomread.f
+%%PORTDATA%%%%DATADIR%%/workloads/randomrw.f
+%%PORTDATA%%%%DATADIR%%/workloads/randomwrite.f
+%%PORTDATA%%%%DATADIR%%/workloads/ratelimcopyfiles.f
+%%PORTDATA%%%%DATADIR%%/workloads/removedirs.f
+%%PORTDATA%%%%DATADIR%%/workloads/tpcso.f
+%%PORTDATA%%%%DATADIR%%/workloads/singlestreamreaddirect.f
+%%PORTDATA%%%%DATADIR%%/workloads/singlestreamread.f
+%%PORTDATA%%%%DATADIR%%/workloads/singlestreamwritedirect.f
+%%PORTDATA%%%%DATADIR%%/workloads/singlestreamwrite.f
+%%PORTDATA%%%%DATADIR%%/workloads/varmail.f
+%%PORTDATA%%%%DATADIR%%/workloads/videoserver.f
+%%PORTDATA%%%%DATADIR%%/workloads/webproxy.f
+%%PORTDATA%%%%DATADIR%%/workloads/webserver.f
+%%PORTDATA%%@dirrm %%DATADIR%%/workloads
+%%PORTDATA%%@dirrm %%DATADIR%%