aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/fio
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-05 01:08:22 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-05 01:08:22 +0000
commitf212e8c1e62c6a30de2e815f99c35a2880a5d187 (patch)
treebf2edb3c3a12bee5fa31a4ead4de4a1be698db60 /benchmarks/fio
parent905a009ac4e644ef4a5a52ed1b16c39d90fd8206 (diff)
downloadports-f212e8c1e62c6a30de2e815f99c35a2880a5d187.tar.gz
ports-f212e8c1e62c6a30de2e815f99c35a2880a5d187.zip
Notes
Diffstat (limited to 'benchmarks/fio')
-rw-r--r--benchmarks/fio/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/benchmarks/fio/Makefile b/benchmarks/fio/Makefile
index d40039cadfed..b79811a3e9b9 100644
--- a/benchmarks/fio/Makefile
+++ b/benchmarks/fio/Makefile
@@ -18,6 +18,18 @@ GNUPLOT_DESC= Support for plotting graphs
GNUPLOT_BUILD_DEPENDS= ${LOCALBASE}/bin/gnuplot:${PORTSDIR}/math/gnuplot
+.include <bsd.port.options.mk>
+
+if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000013
+USES+= bison
+MAKE_ARGS+= YACC=${LOCALBASE}/bin/bison
+.endif
+
+if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000033
+BUILD_DEPENDS+= flex>0:${PORTSDIR}/textproc/flex
+MAKE_ARGS+= LEX=${LOCALBASE}/bin/flex
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fio ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/tools/fio_generate_plots ${STAGEDIR}${PREFIX}/bin