aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/iozone
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2007-06-15 08:11:40 +0000
committerXin LI <delphij@FreeBSD.org>2007-06-15 08:11:40 +0000
commitc84165d51d9ffa7b19c3e110fb4250898d93c117 (patch)
tree87d28f9563fc66d80c8d8ddd50047ba1888e1878 /benchmarks/iozone
parent916ef11b095e5ee0c667b687358a4a84c78e7c43 (diff)
downloadports-c84165d51d9ffa7b19c3e110fb4250898d93c117.tar.gz
ports-c84165d51d9ffa7b19c3e110fb4250898d93c117.zip
Notes
Diffstat (limited to 'benchmarks/iozone')
-rw-r--r--benchmarks/iozone/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/benchmarks/iozone/Makefile b/benchmarks/iozone/Makefile
index 221ced1a880d..69dbfebb5646 100644
--- a/benchmarks/iozone/Makefile
+++ b/benchmarks/iozone/Makefile
@@ -7,7 +7,7 @@
PORTNAME= iozone
PORTVERSION= 3.283
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= benchmarks
MASTER_SITES= http://www.iozone.org/src/current/
DISTNAME= ${PORTNAME}${PORTVERSION:S/./_/}
@@ -27,7 +27,8 @@ ALL_TARGET=
MAN1= iozone.1
PLIST_FILES= bin/iozone
-OPTIONS= THREADS "Enable threading (uses pthreads)" on
+OPTIONS= THREADS "Enable threading (uses pthreads)" on \
+ SSH "Use ssh in distributed measurement" on
.include <bsd.port.pre.mk>
@@ -38,6 +39,9 @@ MAKE_ENV= LDFLAGS=${PTHREAD_LIBS}
CFLAGS+=-DNO_THREADS
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|shell\,\"rsh\"|shell\,\"ssh\"|' ${WRKSRC}/iozone.c
+
do-install:
${STRIP_CMD} ${WRKSRC}/iozone
${INSTALL_PROGRAM} ${WRKSRC}/iozone ${PREFIX}/bin