aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/iperf/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-25 11:33:41 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-25 11:33:41 +0000
commit8d704990d25609c64f9c1c2e1981045ae800aea0 (patch)
tree024c75c2e7a43d7bc22d469ecd9637f2297e220d /benchmarks/iperf/Makefile
parent93c013d44b2d6c09ad9378763be97fb64ccd79c2 (diff)
- Convert to new options helper
- Remove deprecated PTHREAD_* - Support STAGEDIR
Notes
Notes: svn path=/head/; revision=334835
Diffstat (limited to 'benchmarks/iperf/Makefile')
-rw-r--r--benchmarks/iperf/Makefile28
1 files changed, 9 insertions, 19 deletions
diff --git a/benchmarks/iperf/Makefile b/benchmarks/iperf/Makefile
index 8a1332c4090e..3407402f5746 100644
--- a/benchmarks/iperf/Makefile
+++ b/benchmarks/iperf/Makefile
@@ -16,31 +16,21 @@ OPTIONS_DEFAULT=THREADS
GNU_CONFIGURE= yes
-MAN1= iperf.1
-PLIST_FILES= bin/iperf
+PLIST_FILES= bin/iperf \
+ man/man1/iperf.1.gz
PORTDOCS= *
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MIPV6}
-CATEGORIES+= ipv6
-CONFIGURE_ARGS+=--enable-ipv6
-.else
-CONFIGURE_ARGS+=--disable-ipv6
-.endif
+IPV6_CATEGORIES= ipv6
+IPV6_CONFIGURE_ENABLE= ipv6
+THREADS_CONFIGURE_ENABLE= threads
+THREADS_LDFLAGS= -pthread
-.if ${PORT_OPTIONS:MTHREADS}
-CONFIGURE_ARGS+=--enable-threads
-LDFLAGS+= ${PTHREAD_LIBS}
-.else
-CONFIGURE_ARGS+=--disable-threads
-.endif
+.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
- cd ${WRKSRC}/ && ${INSTALL_DATA} README doc/*.gif doc/*.html ${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} README doc/*.gif doc/*.html ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.mk>