aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/iperf/files
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-27 17:42:23 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-27 17:42:23 +0000
commiteaef815e2a8b63f6efd9a683c5c6be73810d5f68 (patch)
treee6689817d04a128afc77ed6f8aaadc31446b8cd1 /benchmarks/iperf/files
parent0ed6d16f6ec9b867f2e52dadd75734403c48c6a9 (diff)
downloadports-eaef815e2a8b63f6efd9a683c5c6be73810d5f68.tar.gz
ports-eaef815e2a8b63f6efd9a683c5c6be73810d5f68.zip
Notes
Diffstat (limited to 'benchmarks/iperf/files')
-rw-r--r--benchmarks/iperf/files/patch-cfg::Makefile11
-rw-r--r--benchmarks/iperf/files/patch-cfg::configure40
2 files changed, 51 insertions, 0 deletions
diff --git a/benchmarks/iperf/files/patch-cfg::Makefile b/benchmarks/iperf/files/patch-cfg::Makefile
new file mode 100644
index 000000000000..01ab09ce0e2c
--- /dev/null
+++ b/benchmarks/iperf/files/patch-cfg::Makefile
@@ -0,0 +1,11 @@
+--- cfg/Makefile.orig Sat May 19 23:54:00 2001
++++ cfg/Makefile Sat May 19 23:54:12 2001
+@@ -31,7 +31,7 @@
+ #
+
+ all: configure
+- ./configure
++ ./configure --cc=${CC} --cxx=${CXX}
+
+ clean:
+ -rm -f $(CLEAN_FILES)
diff --git a/benchmarks/iperf/files/patch-cfg::configure b/benchmarks/iperf/files/patch-cfg::configure
new file mode 100644
index 000000000000..92c8a2e87637
--- /dev/null
+++ b/benchmarks/iperf/files/patch-cfg::configure
@@ -0,0 +1,40 @@
+--- cfg/configure.orig Sat May 19 23:45:26 2001
++++ cfg/configure Sat May 19 23:54:28 2001
+@@ -90,6 +90,12 @@
+ | --cache-f=* | --cache-=* | --cache=* | --cach=* | --cac=* | --ca=* | --c=*)
+ cache_file="$ac_optarg" ;;
+
++ --cc=*)
++ ac_cv_prog_CC="$ac_optarg" ;;
++
++ --cxx=*)
++ ac_cv_prog_CXX="$ac_optarg" ;;
++
+ -datadir | --datadir | --datadi | --datad | --data | --dat | --da)
+ ac_prev=datadir ;;
+ -datadir=* | --datadir=* | --datadi=* | --datad=* | --data=* | --dat=* \
+@@ -952,7 +958,7 @@
+ echo $ac_n "checking whether the C++ compiler ($CXX $CXXFLAGS $LDFLAGS) is a cross-compiler""... $ac_c" 1>&6
+ echo "configure:954: checking whether the C++ compiler ($CXX $CXXFLAGS $LDFLAGS) is a cross-compiler" >&5
+ echo "$ac_t""$ac_cv_prog_cxx_cross" 1>&6
+-cross_compiling=$ac_cv_prog_cxx_cross
++cross_compiling="no"
+
+ echo $ac_n "checking whether we are using GNU C++""... $ac_c" 1>&6
+ echo "configure:959: checking whether we are using GNU C++" >&5
+@@ -1065,14 +1071,7 @@
+ echo
+
+
+-if test -z "$ac_cv_use_pthread"; then
+- ac_cv_use_pthread="yes"
+-fi
+-echo "Make iperf multi-threaded (using pthreads)? [$ac_cv_use_pthread] "
+-read tmp
+-if test -n "$tmp"; then
+- ac_cv_use_pthread="$tmp"
+-fi
++ac_cv_use_pthread="no"
+
+
+ if test "$ac_cv_use_pthread" = yes ; then