aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/nbench
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-01-03 15:34:13 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-01-03 15:34:13 +0000
commit58848c550bf7029a7c353fcfb5d561f730a4a04e (patch)
treebda726dcf401a0a3088ac3e3520896cd590c1cec /benchmarks/nbench
parent49bf36d52771ccccdeacb84f6e4f3406a8814618 (diff)
downloadports-58848c550bf7029a7c353fcfb5d561f730a4a04e.tar.gz
ports-58848c550bf7029a7c353fcfb5d561f730a4a04e.zip
Notes
Diffstat (limited to 'benchmarks/nbench')
-rw-r--r--benchmarks/nbench/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/benchmarks/nbench/Makefile b/benchmarks/nbench/Makefile
index 34b2c4d415f8..53536964fd86 100644
--- a/benchmarks/nbench/Makefile
+++ b/benchmarks/nbench/Makefile
@@ -13,16 +13,13 @@ COMMENT= BYTE Magazine's native benchmarks
ALL_TARGET= # empty
MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/nbench ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/NNET.DAT ${DATADIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/nbench ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/NNET.DAT ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in README README.submit RESULTS bdoc.txt
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>