aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/netperf
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2012-05-15 06:47:10 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2012-05-15 06:47:10 +0000
commitdb38baefd003e3e65fd5b5b59e3484a6c4c69e1f (patch)
treea32db9cf3ea4903a070d10c2c3742a54eef892f5 /benchmarks/netperf
parent445960e818c9daed9b2be4bc04404b5c1033a9cf (diff)
downloadports-db38baefd003e3e65fd5b5b59e3484a6c4c69e1f.tar.gz
ports-db38baefd003e3e65fd5b5b59e3484a6c4c69e1f.zip
1) Add OPTIONS support for:
- SOCKETS - Unix domain socket support and tests - SCTP - Stream Control Transmission Protocol support and tests - EXS - ICSC async socket support - HISTOGRAM - Optional histogram output - OMNI - Enable OMNI tests 2) Patch to $WRKSRC/configure which fixes CPU measurement and ROUTE lookup routines in netperf, which result in this output: ------------- checking which CPU utilization measurement type to use... "none. Consider teaching configure about your platform." checking which route lookup type to use... "none. Consider teaching configure about your platform." -------------- 3) Add to default configure_args --enable-dirty --enable-demo --enable-burst --enable-intervals Note: these just add additional command arguments and options, and are not globally enabled in netperf so wont affect existing users/tests. Submitted by: koobs (No email address by the request)
Notes
Notes: svn path=/head/; revision=296647
Diffstat (limited to 'benchmarks/netperf')
-rw-r--r--benchmarks/netperf/Makefile48
-rw-r--r--benchmarks/netperf/files/patch-configure29
2 files changed, 73 insertions, 4 deletions
diff --git a/benchmarks/netperf/Makefile b/benchmarks/netperf/Makefile
index f9666e7d3ec7..2d732c06f402 100644
--- a/benchmarks/netperf/Makefile
+++ b/benchmarks/netperf/Makefile
@@ -7,18 +7,58 @@
PORTNAME= netperf
PORTVERSION= 2.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= benchmarks ipv6
-MASTER_SITES= ftp://ftp.netperf.org/netperf/
+MASTER_SITES= ftp://ftp.netperf.org/netperf/ \
+ http://fossies.org/unix/misc/
MAINTAINER= sumikawa@FreeBSD.org
COMMENT= Network performance benchmarking package
+OPTIONS= SOCKETS "Enable Unix Domain socket support" On \
+ SCTP "Enable SCTP support" On \
+ EXS "Enable ICSC async socket support" On \
+ HISTOGRAM "Enable optional histogram output" On \
+ OMNI "Enable OMNI tests" Off \
+
+.include <bsd.port.options.mk>
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= "transform="
-CONFIGURE_ARGS= --program-prefix="" --program-suffix=""
-MAN1= netperf.1 netserver.1
+CONFIGURE_ARGS= --program-prefix="" --program-suffix="" --enable-dirty \
+ --enable-demo --enable-burst --enable-intervals
+
+.if !defined(WITHOUT_SOCKETS)
+CONFIGURE_ARGS+= --enable-unixdomain
+.else
+CONFIGURE_ARGS+= --disable-unixdomain
+.endif
+
+.if !defined(WITHOUT_SCTP)
+CONFIGURE_ARGS+= --enable-sctp
+.else
+CONFIGURE_ARGS+= --disable-sctp
+.endif
+.if !defined(WITHOUT_EXS)
+CONFIGURE_ARGS+= --enable-exs
+.else
+CONFIGURE_ARGS+= --disable-exs
+.endif
+
+.if !defined(WITHOUT_HISTOGRAM)
+CONFIGURE_ARGS+= --enable-histogram
+.else
+CONFIGURE_ARGS+= --disable-histogram
+.endif
+
+.if !defined(WITHOUT_OMNI)
+CONFIGURE_ARGS+= --enable-omni
+.else
+CONFIGURE_ARGS+= --disable-omni
+.endif
+
+MAN1= netperf.1 netserver.1
INFO= netperf
SCRIPTS= arr_script packet_byte_script sctp_stream_script snapshot_script \
tcp_range_script tcp_rr_script tcp_stream_script udp_rr_script \
diff --git a/benchmarks/netperf/files/patch-configure b/benchmarks/netperf/files/patch-configure
new file mode 100644
index 000000000000..208d74066a04
--- /dev/null
+++ b/benchmarks/netperf/files/patch-configure
@@ -0,0 +1,29 @@
+--- ./configure.orig 2012-05-12 07:05:20.000000000 +1000
++++ ./configure 2012-05-12 07:22:49.000000000 +1000
+@@ -6594,7 +6594,7 @@
+ done
+
+ case "$host" in
+- *-*-freebsd78.*)
++ *-*-freebsd[7-9].*)
+ # FreeBSD 7.x and later SCTP support doesn't need -lsctp.
+ ;;
+ *)
+@@ -7169,7 +7169,7 @@
+ enable_cpuutil="kstat - auto"
+ NETCPU_SOURCE="kstat"
+ ;;
+- *-*-freebsd[4-7].* | *-*-netbsd[1-9].* )
++ *-*-freebsd[4-9].* | *-*-netbsd[1-9].* )
+ use_cpuutil=true
+
+ $as_echo "#define USE_SYSCTL /**/" >>confdefs.h
+@@ -7238,7 +7238,7 @@
+ enable_rtlookup="rtmget - auto"
+ NETRTLKUP_SOURCE="rtmget"
+ ;;
+- *-*-freebsd[4-7].* | *-*-darwin*)
++ *-*-freebsd[4-9].* | *-*-darwin*)
+ use_rtlookup=true
+ enable_rtlookup="rtmget - auto"
+ NETRTLKUP_SOURCE="rtmget"