aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/netperf
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2012-11-12 02:39:40 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2012-11-12 02:39:40 +0000
commite91b181ec0a1b63841394ba0eda98f3b0f75bd9c (patch)
tree3af569f659f868dfe5066adbc58133f4389b270b /benchmarks/netperf
parentfca53a29cbe13d51a112f45c0cc9e63fcacc2a64 (diff)
downloadports-e91b181ec0a1b63841394ba0eda98f3b0f75bd9c.tar.gz
ports-e91b181ec0a1b63841394ba0eda98f3b0f75bd9c.zip
- Update to use OPTIONSNG
- Trim Makefile header - Drop my maintainership PR: ports/173547 Submitted by: edward Feature safe: yes
Notes
Notes: svn path=/head/; revision=307323
Diffstat (limited to 'benchmarks/netperf')
-rw-r--r--benchmarks/netperf/Makefile31
1 files changed, 15 insertions, 16 deletions
diff --git a/benchmarks/netperf/Makefile b/benchmarks/netperf/Makefile
index 6a93893ca2ca..121276b99c40 100644
--- a/benchmarks/netperf/Makefile
+++ b/benchmarks/netperf/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: netperf
-# Date created: 19 July 1996
-# Whom: koshy
-#
+# Created by: koshy
# $FreeBSD$
-#
PORTNAME= netperf
PORTVERSION= 2.6.0
@@ -11,14 +7,17 @@ CATEGORIES= benchmarks ipv6
MASTER_SITES= ftp://ftp.netperf.org/netperf/ \
http://fossies.org/unix/misc/
-MAINTAINER= sumikawa@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Network performance benchmarking package
-OPTIONS= SOCKETS "Enable Unix Domain socket support" On \
- SCTP "Enable SCTP support" On \
- EXS "Enable ICSC async socket support" On \
- HISTOGRAM "Enable optional histogram output" On \
- OMNI "Enable OMNI tests" Off \
+OPTIONS_DEFINE= OMNI SCTP SOCKETS HISTOGRAM EXS
+OPTIONS_DEFAULT= SCTP SOCKETS HISTOGRAM EXS
+
+OMNI_DESC= Enable OMNI tests
+SCTP_DESC= Enable SCTP support
+SOCKETS_DESC= Enable Unix Domain socket support
+HISTOGRAM_DESC= Enable optional histogram output
+EXS_DESC= Enable ICSC async socket support
.include <bsd.port.options.mk>
@@ -27,31 +26,31 @@ CONFIGURE_ENV= "transform="
CONFIGURE_ARGS= --program-prefix="" --program-suffix="" --enable-dirty \
--enable-demo --enable-burst --enable-intervals
-.if !defined(WITHOUT_SOCKETS)
+.if ${PORT_OPTIONS:MSOCKETS}
CONFIGURE_ARGS+= --enable-unixdomain
.else
CONFIGURE_ARGS+= --disable-unixdomain
.endif
-.if !defined(WITHOUT_SCTP)
+.if ${PORT_OPTIONS:MSCTP}
CONFIGURE_ARGS+= --enable-sctp
.else
CONFIGURE_ARGS+= --disable-sctp
.endif
-.if !defined(WITHOUT_EXS)
+.if ${PORT_OPTIONS:MEXS}
CONFIGURE_ARGS+= --enable-exs
.else
CONFIGURE_ARGS+= --disable-exs
.endif
-.if !defined(WITHOUT_HISTOGRAM)
+.if ${PORT_OPTIONS:MHISTOGRAM}
CONFIGURE_ARGS+= --enable-histogram
.else
CONFIGURE_ARGS+= --disable-histogram
.endif
-.if !defined(WITHOUT_OMNI)
+.if ${PORT_OPTIONS:MOMNI}
CONFIGURE_ARGS+= --enable-omni
.else
CONFIGURE_ARGS+= --disable-omni