aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/nttcp
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>1999-12-25 03:30:40 +0000
committerBill Fumerola <billf@FreeBSD.org>1999-12-25 03:30:40 +0000
commitcf4add4987f241767a4fb7595911279ebca8c695 (patch)
treeea176493a7fa896b20e2112208dd884851e9c36c /benchmarks/nttcp
parent95f3e4660a332fb69402b322d875e7da11c2bbc3 (diff)
downloadports-cf4add4987f241767a4fb7595911279ebca8c695.tar.gz
ports-cf4add4987f241767a4fb7595911279ebca8c695.zip
Notes
Diffstat (limited to 'benchmarks/nttcp')
-rw-r--r--benchmarks/nttcp/Makefile12
-rw-r--r--benchmarks/nttcp/distinfo2
-rw-r--r--benchmarks/nttcp/files/patch-aa21
3 files changed, 9 insertions, 26 deletions
diff --git a/benchmarks/nttcp/Makefile b/benchmarks/nttcp/Makefile
index 9c91104ef509..2e7ec17593cd 100644
--- a/benchmarks/nttcp/Makefile
+++ b/benchmarks/nttcp/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: nttcp
-# Version required: 1.3
+# Version required: 1.45
# Date created: 11 Nov 1998
# Whom: Bill Fumerola <billf@chc-chimes.com>
#
# $FreeBSD$
#
-DISTNAME= nttcp-1.4
+DISTNAME= nttcp-1.45
CATEGORIES= net benchmarks
MASTER_SITES= http://users.leo.org/~bartel/nttcp/ \
http://www.FreeBSD.org/~billf/
@@ -16,13 +16,7 @@ MAINTAINER= billf@FreeBSD.org
ALL_TARGET= nttcp
MAN1= nttcp.1
USE_GMAKE= yes
-MAKE_ENV+= CFLG="${CFLAGS}"
-
-post-patch:
-
- @${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.pre_sed
- @${SED} -e 's#-O2#${CFLAGS}#' \
- ${WRKSRC}/Makefile.pre_sed > ${WRKSRC}/Makefile
+MAKE_ENV+= OPT="${CFLAGS}"
do-install:
diff --git a/benchmarks/nttcp/distinfo b/benchmarks/nttcp/distinfo
index e311ea60bc7c..f567ec229e25 100644
--- a/benchmarks/nttcp/distinfo
+++ b/benchmarks/nttcp/distinfo
@@ -1 +1 @@
-MD5 (nttcp-1.4.tar.gz) = b97cadd2560c7e06faf890ebe7ceefc2
+MD5 (nttcp-1.45.tar.gz) = d172737dbfda224cd42d09cf7cbb3b15
diff --git a/benchmarks/nttcp/files/patch-aa b/benchmarks/nttcp/files/patch-aa
index 0f908806e9b6..f91b484f465f 100644
--- a/benchmarks/nttcp/files/patch-aa
+++ b/benchmarks/nttcp/files/patch-aa
@@ -1,31 +1,20 @@
---- Makefile.old Wed Oct 7 15:12:25 1998
-+++ Makefile Mon Dec 7 23:03:15 1998
+--- Makefile.orig Tue Sep 28 12:02:26 1999
++++ Makefile Fri Dec 24 22:29:00 1999
@@ -109,12 +109,12 @@
#INC=
## For FreeBSD
-#ARCH= -DFreeBSD
-#LIB=
--#OPT= -O2
++ARCH= -DFreeBSD
++LIB=
+ #OPT= -O2
-#CC= cc
-#DBG=
-#INC=
-+ARCH= -DFreeBSD
-+LIB=
-+OPT= -O2
+CC= cc
+DBG=
+INC=
## For SGI IRIX 5.3, 6.2 (cc or gcc)
#ARCH=
-@@ -151,7 +151,8 @@
- VERSION= 1.4
- prefix= /usr/local/dist/DIR/nttcp-$(VERSION)
- #prefix= /usr/local
--CFLAGS = $(ARCH) $(DBG) $(DEF) $(INC) $(OPT) -DVERSION=\"$(VERSION)\"
-+#CFLAGS = $(ARCH) $(DBG) $(DEF) $(INC) $(OPT) -DVERSION=\"$(VERSION)\"
-+CFLAGS = $(ARCH) $(CFLG) -DVERSION=\"$(VERSION)\"
- LFLAGS = $(DBG)
-
- nttcp: nttcp.o support.o