aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/p5-Benchmark-Stopwatch/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-30 08:08:28 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-30 08:08:28 +0000
commit1e5d116a0ec15357ee1ce8d71e9a119d7d42f9cf (patch)
treea906bcc26cb56b0b42ce22a6209e1683cb99c3df /benchmarks/p5-Benchmark-Stopwatch/Makefile
parent6f7705210481b34845b9e77f34dac47a6a164afc (diff)
Notes
Diffstat (limited to 'benchmarks/p5-Benchmark-Stopwatch/Makefile')
-rw-r--r--benchmarks/p5-Benchmark-Stopwatch/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/benchmarks/p5-Benchmark-Stopwatch/Makefile b/benchmarks/p5-Benchmark-Stopwatch/Makefile
new file mode 100644
index 000000000000..91b5aea817ab
--- /dev/null
+++ b/benchmarks/p5-Benchmark-Stopwatch/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Benchmark-Stopwatch
+# Date created: 2006-08-24
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Benchmark-Stopwatch
+PORTVERSION= 0.03
+CATEGORIES= benchmarks perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Benchmark
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Simple timing of stages of your code
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/Test/LongString.pm:${PORTSDIR}/devel/p5-Test-LongString
+
+PERL_MODBUILD= yes
+
+MAN3= Benchmark::Stopwatch.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= ${SITE_PERL}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>