aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/pathchirp/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-05 13:45:57 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-05 13:45:57 +0000
commit97f5625226f8a784e050b7e709dc32e924cb7bc5 (patch)
tree57defce1fa9d1db3e64fa45bc80585ff3215925e /benchmarks/pathchirp/Makefile
parent8cf4e482d924d6aac1749e3a05a97ec34bbce1c8 (diff)
downloadports-97f5625226f8a784e050b7e709dc32e924cb7bc5.tar.gz
ports-97f5625226f8a784e050b7e709dc32e924cb7bc5.zip
Notes
Diffstat (limited to 'benchmarks/pathchirp/Makefile')
-rw-r--r--benchmarks/pathchirp/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/benchmarks/pathchirp/Makefile b/benchmarks/pathchirp/Makefile
index c5bfd1e0d952..40568ac0e48b 100644
--- a/benchmarks/pathchirp/Makefile
+++ b/benchmarks/pathchirp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pathchirp
-PORTVERSION= 2.4.0
+PORTVERSION= 2.4.1
CATEGORIES= benchmarks
MASTER_SITES= http://www.spin.rice.edu/Software/pathChirp/
@@ -15,12 +15,22 @@ COMMENT= A measurement tool for available bandwidth estimation
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
PLIST_FILES= bin/pathchirp_rcv bin/pathchirp_snd bin/pathchirp_run
+PORTDOCS= README
+
+post-patch:
+ @${REINPLACE_CMD} -e '/CFLAGS.*O4/d' ${WRKSRC}/configure
do-install:
-.for f in pathchirp_rcv pathchirp_snd pathchirp_run
- ${INSTALL_PROGRAM} ${WRKSRC}/Bin/${ARCH}/${f} ${PREFIX}/bin
+.for f in rcv snd run
+ ${INSTALL_PROGRAM} ${WRKSRC}/Bin/${ARCH}/${PORTNAME}_${f} ${PREFIX}/bin
.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>