aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/phoronix-test-suite
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-08-10 08:34:43 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-08-10 08:34:43 +0000
commit51f96a61bf114d5a1d747fe50beab5521c26980d (patch)
treed1b1fc3d56fa54ed8a9fe02f7f514c5d9d5cf415 /benchmarks/phoronix-test-suite
parentac710b0a76a217783f9c179176ff22f3357fcf26 (diff)
downloadports-51f96a61bf114d5a1d747fe50beab5521c26980d.tar.gz
ports-51f96a61bf114d5a1d747fe50beab5521c26980d.zip
Fix some stage violations
Notes
Notes: svn path=/head/; revision=364513
Diffstat (limited to 'benchmarks/phoronix-test-suite')
-rw-r--r--benchmarks/phoronix-test-suite/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/benchmarks/phoronix-test-suite/Makefile b/benchmarks/phoronix-test-suite/Makefile
index 6e0d774aa79b..9b9eb66e4f8c 100644
--- a/benchmarks/phoronix-test-suite/Makefile
+++ b/benchmarks/phoronix-test-suite/Makefile
@@ -58,20 +58,17 @@ post-patch:
do-install:
cd ${WRKSRC} && ${INSTALL_OPTS} DESTDIR=${STAGEDIR} ./install-sh ${PREFIX}
-
-post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for FILE in ${DOCFILES1}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}/${FILE}
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}/${FILE}
.endfor
.for FILE in ${DOCFILES2}
- @${INSTALL_DATA} ${WRKSRC}/documentation/${FILE} ${DOCSDIR}/${FILE}
+ @${INSTALL_DATA} ${WRKSRC}/documentation/${FILE} ${STAGEDIR}${DOCSDIR}/${FILE}
.endfor
.for DIR in stubs includes
- @${CP} -rf ${WRKSRC}/documentation/${DIR} ${DOCSDIR}
+ @${CP} -rf ${WRKSRC}/documentation/${DIR} ${STAGEDIR}${DOCSDIR}
.endfor
- @${ECHO_MSG} "===> Docs installed in ${DOCSDIR}."
.endif
.include <bsd.port.mk>