aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/slowloris
diff options
context:
space:
mode:
authorAlexey Degtyarev <alexey@FreeBSD.org>2013-11-30 14:47:16 +0000
committerAlexey Degtyarev <alexey@FreeBSD.org>2013-11-30 14:47:16 +0000
commit8cac12f31312e88c222eabed170cfb9cee0e3887 (patch)
treee0c2d93d72b94f345bf63449d624a60f23abb099 /benchmarks/slowloris
parent4e68ae2bcafa95f8bc1c8883a102b20ddb1fd135 (diff)
downloadports-8cac12f31312e88c222eabed170cfb9cee0e3887.tar.gz
ports-8cac12f31312e88c222eabed170cfb9cee0e3887.zip
* Unbreak build after r334225.
* STAGE support.
Notes
Notes: svn path=/head/; revision=335290
Diffstat (limited to 'benchmarks/slowloris')
-rw-r--r--benchmarks/slowloris/Makefile28
1 files changed, 9 insertions, 19 deletions
diff --git a/benchmarks/slowloris/Makefile b/benchmarks/slowloris/Makefile
index 306a39b85ecd..f8359ad6d210 100644
--- a/benchmarks/slowloris/Makefile
+++ b/benchmarks/slowloris/Makefile
@@ -9,34 +9,24 @@ MASTER_SITES= ftp://ftp.renatasystems.org/pub/FreeBSD/ports/distfiles/
MAINTAINER= alexey@renatasystems.org
COMMENT= The low bandwidth, yet greedy and poisonous HTTP client
-USES= perl5
-NO_BUILD= yes
-
RUN_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long
-PLIST_FILES= bin/slowloris
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+USES= perl5
+NO_BUILD= yes
-PERL_THREADS= yes
+PLIST_FILES= bin/slowloris
-.if exists(${PERL})
-PERL_THREADS!= ${PERL} -V::usethreads
-.if ${PERL_THREADS} == "'define';"
-RUN_DEPENDS+= p5-threads-shared>=0:${PORTSDIR}/devel/p5-threads-shared
-PERL_THREADS= yes
-.else
-PERL_THREADS= no
-.endif
-.endif
+PERL_THREADS?= yes
.if ${PERL_THREADS} != "yes"
EXTRA_PATCHES+= ${FILESDIR}/extra-nothreads
+.else
+RUN_DEPENDS+= p5-threads-shared>=0:${PORTSDIR}/devel/p5-threads-shared
.endif
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/slowloris.pl ${PREFIX}/bin/slowloris
+ ${INSTALL_SCRIPT} ${WRKSRC}/slowloris.pl \
+ ${STAGEDIR}/${PREFIX}/bin/slowloris
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>