aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/stream/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-02-17 08:43:37 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-02-17 08:43:37 +0000
commit5e2348f9dd4ac63e23ab48ccc9b35d21afaaf7da (patch)
tree3c5e4d262776e7c37838829dc2d30f488b60f93e /benchmarks/stream/Makefile
parent4e311fc4f37f3b9d2f5085b95ba675745d53a16b (diff)
downloadports-5e2348f9dd4ac63e23ab48ccc9b35d21afaaf7da.tar.gz
ports-5e2348f9dd4ac63e23ab48ccc9b35d21afaaf7da.zip
Notes
Diffstat (limited to 'benchmarks/stream/Makefile')
-rw-r--r--benchmarks/stream/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/benchmarks/stream/Makefile b/benchmarks/stream/Makefile
index df86d758609b..8df09fda4da7 100644
--- a/benchmarks/stream/Makefile
+++ b/benchmarks/stream/Makefile
@@ -6,23 +6,30 @@
PORTNAME= stream
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= benchmarks
MASTER_SITES= ftp://ftp.cs.virginia.edu/pub/stream/Code/
-DISTFILES= second_cpu.c stream_d.c
+DISTFILES= stream.c README
DIST_SUBDIR= stream-${PORTVERSION}
MAINTAINER= sf@slappy.org
COMMENT= Synthetic benchmark program that measures sustainable memory bandwidth
-MAKEFILE= ${FILESDIR}/Makefile
PLIST_FILES= bin/stream
+PORTDOCS= stream.c README
do-extract:
- @${MKDIR} ${WRKDIR}
- @${CP} -r ${_DISTDIR} ${WRKDIR}
+ @${MKDIR} ${BUILD_WRKSRC}
+ @${CP} ${_DISTDIR}/stream.c ${BUILD_WRKSRC}
-post-install:
- ${STRIP_CMD} ${PREFIX}/bin/stream
+do-build:
+ (cd ${BUILD_WRKSRC} ; ${CC} ${CFLAGS} -o stream stream.c -lm)
+
+do-install:
+ (cd ${BUILD_WRKSRC}; ${INSTALL_PROGRAM} stream ${PREFIX}/bin)
+. if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${_DISTDIR}; ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
+. endif
.include <bsd.port.mk>