aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/super-smack
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2014-07-03 14:45:05 +0000
committerJason E. Hale <jhale@FreeBSD.org>2014-07-03 14:45:05 +0000
commit88ccd7cce48a96e6d78c67743f64f21b9b449348 (patch)
tree3c30962418a588b0407387e5ee9da396e6b481c9 /benchmarks/super-smack
parentc8821edb097b470c21ceb3e2484f115b01f656a3 (diff)
downloadports-88ccd7cce48a96e6d78c67743f64f21b9b449348.tar.gz
ports-88ccd7cce48a96e6d78c67743f64f21b9b449348.zip
Notes
Diffstat (limited to 'benchmarks/super-smack')
-rw-r--r--benchmarks/super-smack/Makefile42
-rw-r--r--benchmarks/super-smack/files/patch-Makefile.in13
-rw-r--r--benchmarks/super-smack/pkg-descr3
3 files changed, 27 insertions, 31 deletions
diff --git a/benchmarks/super-smack/Makefile b/benchmarks/super-smack/Makefile
index ed2289334def..4967cbb8ad52 100644
--- a/benchmarks/super-smack/Makefile
+++ b/benchmarks/super-smack/Makefile
@@ -5,7 +5,7 @@ PORTNAME= super-smack
PORTVERSION= 1.3
PORTREVISION= 2
CATEGORIES= benchmarks databases
-MASTER_SITES= http://vegan.net/tony/supersmack/
+MASTER_SITES= GENTOO/distfiles
MAINTAINER= ports@FreeBSD.org
COMMENT= Benchmarking, stress testing, and load generation tool for Databases
@@ -16,39 +16,23 @@ MAKE_JOBS_UNSAFE= yes
PORTDOCS= README TUTORIAL
-OPTIONS_MULTI= DB
+OPTIONS_DEFINE= DOCS
+OPTIONS_MULTI= DB
OPTIONS_MULTI_DB= MYSQL PGSQL
OPTIONS_DEFAULT= MYSQL
-PGSQL_DESC= Enable PostgreSQL support
-MYSQL_DESC= Enable MySQL support
+MYSQL_USE= MYSQL=yes
+MYSQL_CONFIGURE_ON= --with-mysql \
+ --with-mysql-include=${LOCALBASE}/include/mysql \
+ --with-mysql-lib=${LOCALBASE}/lib/mysql
-NO_STAGE= yes
+PGSQL_USES= pgsql
+PGSQL_CONFIGURE_ON= --with-pgsql \
+ --with-pgsql-include=${LOCALBASE}/include \
+ --with-pgsql-lib=${LOCALBASE}/lib
-OPTIONS_DEFINE= DOCS
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-CONFIGURE_ARGS+=--with-mysql \
- --with-mysql-include=${LOCALBASE}/include/mysql \
- --with-mysql-lib=${LOCALBASE}/lib/mysql
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-USES+= pgsql
-CONFIGURE_ARGS+=--with-pgsql \
- --with-pgsql-include=${LOCALBASE}/include \
- --with-pgsql-lib=${LOCALBASE}/lib
-.endif
-
-.if ${PORT_OPTIONS:MDOCS}
post-install:
- ${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/benchmarks/super-smack/files/patch-Makefile.in b/benchmarks/super-smack/files/patch-Makefile.in
new file mode 100644
index 000000000000..009606ef5fad
--- /dev/null
+++ b/benchmarks/super-smack/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+--- ./Makefile.in.orig 2005-04-30 11:19:40.000000000 -0400
++++ ./Makefile.in 2014-07-03 10:20:34.000000000 -0400
+@@ -379,8 +379,8 @@
+
+
+ install-data-local:
+- $(mkinstalldirs) $(SMACKS_DIR) $(DATADIR)
+- cp -rp $(srcdir)/smacks/* $(SMACKS_DIR)
++ $(mkinstalldirs) $(DESTDIR)$(SMACKS_DIR) $(DESTDIR)$(DATADIR)
++ cp -rp $(srcdir)/smacks/* $(DESTDIR)$(SMACKS_DIR)
+
+ dist-hook:
+ mkdir -p $(distdir)/smacks
diff --git a/benchmarks/super-smack/pkg-descr b/benchmarks/super-smack/pkg-descr
index 9bacf94182e5..78cd194e85f8 100644
--- a/benchmarks/super-smack/pkg-descr
+++ b/benchmarks/super-smack/pkg-descr
@@ -2,5 +2,4 @@ Super Smack is a benchmarking, stress testing, and load generation tool
for MySQL (and PostgreSQL). Super Smack was originally written by Sasha
Pachev, and then hosted and maintained by Jeremy Zawodny.
-Author: Tony Bourke <tony (at) vegan (dot) net>
-WWW: http://vegan.net/tony/supersmack/
+WWW: http://jeremy.zawodny.com/mysql/super-smack/